Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » /bin/sh: arm-none-linux-gnueabi-g++: not found(can not compile with arm using eclipse)
/bin/sh: arm-none-linux-gnueabi-g++: not found [message #539902] Mon, 14 June 2010 09:10 Go to next message
Elie  is currently offline Elie Friend
Messages: 7
Registered: June 2010
Junior Member
Hi,

I am trying to use the arm-none-linux-gnueabi-g++

I have the toolchain downloaded, and i add it to my path

echo $PATH
/home/toolchain/arm-2008q1/bin:/usr/local/sbin:/usr/local/bi n:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games


I also can run the command arm-none-linux-gnueabi-g++ from the command line,

inside eclipse i went to project build settings
and changed the gcc to arm-none-linux-gnueabi-gcc
also g++ to arm-none-linux-gnueabi-g++

However when i try to build, i get the error

/bin/sh: arm-none-linux-gnueabi-g++: not found

any clue on what is missing?
Re: /bin/sh: arm-none-linux-gnueabi-g++: not found [message #540006 is a reply to message #539902] Mon, 14 June 2010 14:59 Go to previous messageGo to next message
Axel Mueller is currently offline Axel MuellerFriend
Messages: 1973
Registered: July 2009
Senior Member
Did your change your $PATH after Eclipse was started? I guess Eclipse has not the current PATH settings. You have to either restart Eclipse or completely logout and then login (depends how you start Eclipse).

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: /bin/sh: arm-none-linux-gnueabi-g++: not found [message #540019 is a reply to message #540006] Mon, 14 June 2010 15:34 Go to previous messageGo to next message
Elie  is currently offline Elie Friend
Messages: 7
Registered: June 2010
Junior Member
i had to change the $PATH inside eclipse to make it work
inside environment.

i restarted eclipse many times before doing that and it didnt work until i change it manually again inside eclipse.

Re: /bin/sh: arm-none-linux-gnueabi-g++: not found [message #540087 is a reply to message #540019] Mon, 14 June 2010 20:30 Go to previous messageGo to next message
Axel Mueller is currently offline Axel MuellerFriend
Messages: 1973
Registered: July 2009
Senior Member
Did you change the PATH variable in .bashrc our in .bash_profile? These files are only read when you login. That's why Eclipse (or any other program) will not see your changes to the PATH variable.

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: /bin/sh: arm-none-linux-gnueabi-g++: not found [message #540143 is a reply to message #540087] Tue, 15 June 2010 07:20 Go to previous messageGo to next message
Elie  is currently offline Elie Friend
Messages: 7
Registered: June 2010
Junior Member
Yes i changed the file but i did not log out, before using eclipse

thank you i think that was the problem Smile
Re: /bin/sh: arm-none-linux-gnueabi-g++: not found [message #894660 is a reply to message #540143] Tue, 10 July 2012 03:04 Go to previous messageGo to next message
Otl Nitsche is currently offline Otl NitscheFriend
Messages: 4
Registered: July 2012
Junior Member
Hi guys,

I'm new to eclipse and embedded systems and came accros the same problem. I am trying to run the tutorial provided here:
[can't post links - youtube "beaglebone c++" and you find the video]

Unfortunately I am stuck with the compiling process of the first eclipse example. I added includes and library paths as described and when I try to "Build All" I get this:
Quote:

**** Build of configuration Debug for project beaglebone ****

make all
Building file: ../src/beaglebone.cpp
Invoking: GCC C++ Compiler
arm-linux-gnueabi-g++ -I/usr/arm-linux-gnueabi/include/c++/4.4.7 -O0 -g3 -Wall -c -fmessage-length=0 -MMD -MP -MF"src/beaglebone.d" -MT"src/beaglebone.d" -o "src/beaglebone.o" "../src/beaglebone.cpp"
/bin/sh: 1: arm-linux-gnueabi-g++: not found
make: *** [src/beaglebone.o] Error 127

**** Build Finished ****


I googled the problem, found this thread and still don't know what to do exactely. Can you please extend on the solution provided here by giving me the noob-rundown of how to change the $PATH variable? What are the steps?

Cheers,
Otl
Re: /bin/sh: arm-none-linux-gnueabi-g++: not found [message #1101627 is a reply to message #894660] Wed, 04 September 2013 18:30 Go to previous message
richa m is currently offline richa mFriend
Messages: 1
Registered: September 2013
Junior Member
@ Otl

Did u find any solution to your issue of setting path? ...please can you share
Previous Topic:Debugger dies during initialization on OSX 10.6
Next Topic:Adding project reference programmatically.
Goto Forum:
  


Current Time: Sun Dec 21 12:07:05 GMT 2014

Powered by FUDForum. Page generated in 0.03240 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software