Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » The program 'Eclipse' received an X Window System error.
The program 'Eclipse' received an X Window System error. [message #539642] Fri, 11 June 2010 14:56 Go to next message
Dilton McGowan II is currently offline Dilton McGowan II
Messages: 108
Registered: July 2009
Senior Member
Hi,

I'm seeing Eclipse disappear on Ubuntu now. Running it in a terminal I
get this error feedback:

The program 'Eclipse' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
(Details: serial 76652 error_code 158 request_code 151 minor_code 7)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error()
function.)

My platform:

Ubuntu 32 (All Effects Off)

eclipse.buildId=M20100211-1343
eclipse.vmargs=-Xms40m
-Xmx256m

java.fullversion=JRE 1.6.0 IBM J9 2.4 Linux x86-32
jvmxi3260sr7-20091214_49398 (JIT enabled, AOT enabled)
J9VM - 20091214_049398
JIT - r9_20091123_13891
GC - 20091111_AA

Any help appreciated,
Dilton
Re: The program 'Eclipse' received an X Window System error. [message #645846 is a reply to message #539642] Mon, 20 December 2010 19:20 Go to previous messageGo to next message
Pavel A. is currently offline Pavel A.
Messages: 1
Registered: December 2010
Junior Member
Hello.
I had the same problem. It was an error while calling XulRunner lib functions. Checking my system I have found that I have two XulRunner libs installed: version 1.9.1 and 1.9.2. Using package manager I removed 1.9.1. It was the solution! Now eclipse works perfectly.
Re: The program 'Eclipse' received an X Window System error. [message #664638 is a reply to message #645846] Mon, 11 April 2011 13:38 Go to previous messageGo to next message
Doug Chasman is currently offline Doug Chasman
Messages: 1
Registered: April 2011
Junior Member
Same here - this solution saved me a ton of time - thank you so much!
Re: The program 'Eclipse' received an X Window System error. [message #700906 is a reply to message #664638] Sun, 24 July 2011 07:35 Go to previous message
Venkat Akkineni is currently offline Venkat Akkineni
Messages: 1
Registered: July 2011
Junior Member
Amen

This is the solution.
Previous Topic:What is the difference between forums PDE - Plugin Development Environment and Plugin Development En
Next Topic:Problems with restricting property tester by using the type attribute
Goto Forum:
  


Current Time: Wed Oct 22 21:44:07 GMT 2014

Powered by FUDForum. Page generated in 0.02961 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software