Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Missing requirement package 'junit.framework 4.3.0'
icon4.gif  Missing requirement package 'junit.framework 4.3.0' [message #539323] Thu, 10 June 2010 12:36
Alexander Malic is currently offline Alexander MalicFriend
Messages: 29
Registered: July 2009
Junior Member
Hi,

i'm using eclipse3.5SR2 as IDE but i'm developing a rcp-application based on a eclipse3.4 target platform.

i want to use swtbot to test the rcp-application. i installed swt-bot via update manager for my ide. but as far as i understood it i need to install swtbot too inside my target platform

so i added the swtbot for eclipse 3.4 update site. and started to edit my target definition (preferences/plug-in development/target platform -> press edit button)

the idea was to add swtbot via software-site ( http://download.eclipse.org/technology/swtbot/ganymede/dev-b uild/update-site) to the target-platform.
i checked "swtbot for eclipse testing" and "swtbot junit 4.x headless launchers for eclipse". but the target definition dialog shows me following error message:
(x) cannot satisfy dependency:
(x) missing requirement: swtbot headless junit .... requires 'package junit framework 4.3.0' but it could not be found
(x) software being installed


first i thought i have to add the ganymede update site too, so the missing requirements can be resolved -> not working

can anyone help me solve this problem. i'd like to test swtbot against a more complicated tescase then the ones described in the user-guide.

many thanks in advance,
Alex M

btw: if this was already asked before -> i tried to search for the question, but since eclipse-forums are using google as their search provider and there is no option for restricting the search on a specific forum category (projects/swtbot) the search functionality is almost useless!
Previous Topic:568-dev-e34.zip missing org.eclipse.swtbot.eclipse.ui_2.0.0.568-dev-e34.jar
Next Topic:...\plugins\org.eclipse.test\JUNIT.XSL doesn't exist
Goto Forum:
  


Current Time: Thu Dec 18 09:32:02 GMT 2014

Powered by FUDForum. Page generated in 0.01596 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software