Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » in standalone help system,Search don't work for me
in standalone help system,Search don't work for me [message #538583] Tue, 08 June 2010 06:18 Go to next message
Neda  is currently offline Neda Friend
Messages: 12
Registered: June 2010
Junior Member
Hello everybody,\
recently I have implemented an standalone help for my purpose. I change the language of the content into Arabic,but when I browse the HelpSystem and search for a content, nothing found ! I change the charset of pages to UTF-8 . But nothing changed.
another problem is about the Header of Hel pages,where the search box shown there,I don't know where can I change the word " SEARCH " to my term in arabic...
Thanks in advance
Re: in standalone help system,Search don't work for me [message #541210 is a reply to message #538583] Fri, 18 June 2010 17:41 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
You may need to force the search index to get rebuilt for your documentation plug-ins. The search index is built the first time a search is performed and after that only when the version of a plug-in changes, so if you change the contents without bumping the version number you will not see the new entries.

I don't know if this is what is happening to you but the first thing I would try is to increase the plugin version and restart help.

When you say the "Search" label is not translated I am guessing that every other label is translated. In that case there is a missing resource in the language pack, I have heard of this problem before - see https://bugs.eclipse.org/bugs/show_bug.cgi?id=303804 for more details. I don't know if a newer language pack is available, if not you will need to edit the translations in /org.eclipse.help.webapp/src/org/eclipse/help/internal/webap p/WebappResources.properties in your language pack so you have translations for the three resources below:

search=Search Results
Search=&Search:
SearchLabel=&Search:
Re: in standalone help system,Search don't work for me [message #541261 is a reply to message #541210] Sat, 19 June 2010 04:24 Go to previous messageGo to next message
Neda  is currently offline Neda Friend
Messages: 12
Registered: June 2010
Junior Member
Hi,
thank you for your reply... you're right...I don't have any language pack for my stand alone help... can you help me? I need ARABIC or PERSIAN language pack for my reason Smile
Re: in standalone help system,Search don't work for me [message #542067 is a reply to message #541261] Wed, 23 June 2010 17:25 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
The language packs for Eclipse can be found at http://www.eclipse.org/babel/ - not all languages have translations but I expect you will be able to find Arabic translations there.
Re: in standalone help system,Search don't work for me [message #624189 is a reply to message #541210] Sat, 19 June 2010 04:24 Go to previous messageGo to next message
Neda  is currently offline Neda Friend
Messages: 12
Registered: June 2010
Junior Member
Hi,
thank you for your reply... you're right...I don't have any language pack for my stand alone help... can you help me? I need ARABIC or PERSIAN language pack for my reason :)
Re: in standalone help system,Search don't work for me [message #624193 is a reply to message #624189] Wed, 23 June 2010 17:25 Go to previous message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
The language packs for Eclipse can be found at http://www.eclipse.org/babel/ - not all languages have translations but I expect you will be able to find Arabic translations there.
Previous Topic:Re: Testing Help Runtime
Next Topic:Turn OFF DEBUG org.mortbay.log???
Goto Forum:
  


Current Time: Wed Nov 26 05:36:40 GMT 2014

Powered by FUDForum. Page generated in 0.14561 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software