Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » UML2 Tools and Helios
UML2 Tools and Helios [message #538135] Sat, 05 June 2010 15:08 Go to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

The UML2 Tools aren't included in the Helios RC3. As I wanted to install
them by update url
http://download.eclipse.org/modeling/mdt/updates/releases/ I checked the
latest incubation version 0.9.0 from there. But the installation
couldn't be completed because of the inconsistencies I attached at the
end of this message. Is there a possibility to get the nice UML2
diagrams working in the Helios RC3? Or do I have to check out it from
the CVS?

best regards,
Gilbert


Cannot complete the install because of a conflicting dependency.
Software being installed: UML2 Diagramming (Incubation)
0.9.0.v200906190654 (org.eclipse.uml2.diagram.feature.group
0.9.0.v200906190654)
Software currently installed: Eclipse Modeling Tools
1.3.0.20100529-0859 (epp.package.modeling 1.3.0.20100529-0859)
Only one of the following can be installed at once:
EMF Ecore 2.5.0.v200906151043 (org.eclipse.emf.ecore
2.5.0.v200906151043)
EMF Ecore 2.1.1 (org.eclipse.emf.ecore 2.1.1)
EMF Ecore 2.2.4.v200808252119 (org.eclipse.emf.ecore
2.2.4.v200808252119)
EMF Ecore 2.4.1.v200808251517 (org.eclipse.emf.ecore
2.4.1.v200808251517)
EMF Ecore 2.3.2.v200802051830 (org.eclipse.emf.ecore
2.3.2.v200802051830)
EMF Ecore 2.0.4 (org.eclipse.emf.ecore 2.0.4)
EMF Ecore 2.6.0.v20100527-1913 (org.eclipse.emf.ecore
2.6.0.v20100527-1913)
EMF Ecore 2.4.2.v200902171115 (org.eclipse.emf.ecore
2.4.2.v200902171115)
Cannot satisfy dependency:
From: Eclipse Modeling Tools 1.3.0.20100529-0859
(epp.package.modeling 1.3.0.20100529-0859)
To: org.eclipse.epp.package.modeling.feature.feature.group
[1.3.0.20100529-0859]
Cannot satisfy dependency:
From: Ecore Tools (Incubation) 0.10.0.v20100521-2009
(org.eclipse.emf.ecoretools 0.10.0.v20100521-2009)
To: bundle org.eclipse.emf.ecore [2.6.0,3.0.0)
Cannot satisfy dependency:
From: Ecore Tools (Incubation) 0.10.0.v20100601-1628
(org.eclipse.emf.ecoretools.feature.group 0.10.0.v20100601-1628)
To: org.eclipse.emf.ecoretools [0.10.0.v20100521-2009]
Cannot satisfy dependency:
From: Ecore Tools SDK (Incubation) 0.10.0.v20100601-1628
(org.eclipse.emf.ecoretools.sdk.feature.group 0.10.0.v20100601-1628)
To: org.eclipse.emf.ecoretools.feature.group [0.10.0.v20100601-1628]
Cannot satisfy dependency:
From: Object Constraint Language (OCL) 2.0 Compatibility API
1.1.101.v200808291106 (org.eclipse.emf.ocl 1.1.101.v200808291106)
To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Object Constraint Language (OCL) 2.0 Compatibility API
1.1.101.v200901271800 (org.eclipse.emf.ocl 1.1.101.v200901271800)
To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
Cannot satisfy dependency:
From: Object Constraint Language (OCL) 2.0 Compatibility API
1.1.101.v200908161630 (org.eclipse.emf.ocl 1.1.101.v200908161630)
To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
Cannot satisfy dependency:
From: EPP Modeling Feature 1.3.0.20100529-0859
(org.eclipse.epp.package.modeling.feature.feature.group 1.3.0.20100529-0859)
To: org.eclipse.emf.ecoretools.sdk.feature.group 0.0.0
Cannot satisfy dependency:
From: OCL 2.0 Binding for Ecore 1.2.1.v200807301850
(org.eclipse.ocl.ecore 1.2.1.v200807301850)
To: bundle org.eclipse.emf.ecore [2.4.0,2.5.0)
Cannot satisfy dependency:
From: OCL 2.0 Binding for Ecore 1.3.0.v200905271400
(org.eclipse.ocl.ecore 1.3.0.v200905271400)
To: bundle org.eclipse.emf.ecore [2.5.0,2.6.0)
Cannot satisfy dependency:
From: UML2 Activity Diagram Plugin (Incubation) 0.9.0.v200906190654
(org.eclipse.uml2.diagram.activity 0.9.0.v200906190654)
To: bundle org.eclipse.emf.ocl 0.0.0
Cannot satisfy dependency:
From: UML2 Diagramming (Incubation) 0.9.0.v200906190654
(org.eclipse.uml2.diagram.feature.group 0.9.0.v200906190654)
To: org.eclipse.uml2.diagram.activity [0.9.0.v200906190654]
Re: UML2 Tools and Helios [message #538140 is a reply to message #538135] Sat, 05 June 2010 15:27 Go to previous messageGo to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

Ok, indeed it was possible with the sources from CVS repository. Sorry
for the post.
Re: UML2 Tools and Helios [message #544879 is a reply to message #538135] Mon, 05 July 2010 20:07 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Gilbert

> Cannot satisfy dependency:
> From: UML2 Activity Diagram Plugin (Incubation) 0.9.0.v200906190654
> (org.eclipse.uml2.diagram.activity 0.9.0.v200906190654)
> To: bundle org.eclipse.emf.ocl 0.0.0

This is very unfortunate. org.eclipse.emf.ocl was deprecated long ago
and so was removed in Helios, which would be no problem if UML2-Tools
had rebuilt. The erroneous dependency prevents 0.9.0 or 0.9.1 being
installed on Helios.

It would be good if someone could do a rebuild as-is/as-was.

Otherwise may be MDT/OCL could provide a compatibility feature just
to remap org.eclipse.emf.ocl to org.eclipse.ocl. However I'm not sure
that the mapping of the obsolete API to the prevailing API can be done
within the version bounds that would make it useable.

Regards

Ed Willink
Re: UML2 Tools and Helios [message #544977 is a reply to message #538135] Tue, 06 July 2010 09:07 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi

See See
http://wiki.eclipse.org/MDT/OCL/FAQ#How_do_I_workaround_org. eclipse.emf.ocl_deprecation_in_Helios_and_later.3F

Regards

Ed Willink

On 05/06/2010 16:08, Gilbert Mirenque wrote:
> The UML2 Tools aren't included in the Helios RC3. As I wanted to install
> them by update url
> http://download.eclipse.org/modeling/mdt/updates/releases/ I checked the
> latest incubation version 0.9.0 from there. But the installation
> couldn't be completed because of the inconsistencies I attached at the
> end of this message. Is there a possibility to get the nice UML2
> diagrams working in the Helios RC3? Or do I have to check out it from
> the CVS?
>
> best regards,
> Gilbert
>
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: UML2 Diagramming (Incubation)
> 0.9.0.v200906190654 (org.eclipse.uml2.diagram.feature.group
> 0.9.0.v200906190654)
> Software currently installed: Eclipse Modeling Tools
> 1.3.0.20100529-0859 (epp.package.modeling 1.3.0.20100529-0859)
> Only one of the following can be installed at once:
> EMF Ecore 2.5.0.v200906151043 (org.eclipse.emf.ecore
> 2.5.0.v200906151043)
> EMF Ecore 2.1.1 (org.eclipse.emf.ecore 2.1.1)
> EMF Ecore 2.2.4.v200808252119 (org.eclipse.emf.ecore
> 2.2.4.v200808252119)
> EMF Ecore 2.4.1.v200808251517 (org.eclipse.emf.ecore
> 2.4.1.v200808251517)
> EMF Ecore 2.3.2.v200802051830 (org.eclipse.emf.ecore
> 2.3.2.v200802051830)
> EMF Ecore 2.0.4 (org.eclipse.emf.ecore 2.0.4)
> EMF Ecore 2.6.0.v20100527-1913 (org.eclipse.emf.ecore
> 2.6.0.v20100527-1913)
> EMF Ecore 2.4.2.v200902171115 (org.eclipse.emf.ecore
> 2.4.2.v200902171115)
> Cannot satisfy dependency:
> From: Eclipse Modeling Tools 1.3.0.20100529-0859
> (epp.package.modeling 1.3.0.20100529-0859)
> To: org.eclipse.epp.package.modeling.feature.feature.group
> [1.3.0.20100529-0859]
> Cannot satisfy dependency:
> From: Ecore Tools (Incubation) 0.10.0.v20100521-2009
> (org.eclipse.emf.ecoretools 0.10.0.v20100521-2009)
> To: bundle org.eclipse.emf.ecore [2.6.0,3.0.0)
> Cannot satisfy dependency:
> From: Ecore Tools (Incubation) 0.10.0.v20100601-1628
> (org.eclipse.emf.ecoretools.feature.group 0.10.0.v20100601-1628)
> To: org.eclipse.emf.ecoretools [0.10.0.v20100521-2009]
> Cannot satisfy dependency:
> From: Ecore Tools SDK (Incubation) 0.10.0.v20100601-1628
> (org.eclipse.emf.ecoretools.sdk.feature.group 0.10.0.v20100601-1628)
> To: org.eclipse.emf.ecoretools.feature.group [0.10.0.v20100601-1628]
> Cannot satisfy dependency:
> From: Object Constraint Language (OCL) 2.0 Compatibility API
> 1.1.101.v200808291106 (org.eclipse.emf.ocl 1.1.101.v200808291106)
> To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: Object Constraint Language (OCL) 2.0 Compatibility API
> 1.1.101.v200901271800 (org.eclipse.emf.ocl 1.1.101.v200901271800)
> To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: Object Constraint Language (OCL) 2.0 Compatibility API
> 1.1.101.v200908161630 (org.eclipse.emf.ocl 1.1.101.v200908161630)
> To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: EPP Modeling Feature 1.3.0.20100529-0859
> (org.eclipse.epp.package.modeling.feature.feature.group 1.3.0.20100529-0859)
> To: org.eclipse.emf.ecoretools.sdk.feature.group 0.0.0
> Cannot satisfy dependency:
> From: OCL 2.0 Binding for Ecore 1.2.1.v200807301850
> (org.eclipse.ocl.ecore 1.2.1.v200807301850)
> To: bundle org.eclipse.emf.ecore [2.4.0,2.5.0)
> Cannot satisfy dependency:
> From: OCL 2.0 Binding for Ecore 1.3.0.v200905271400
> (org.eclipse.ocl.ecore 1.3.0.v200905271400)
> To: bundle org.eclipse.emf.ecore [2.5.0,2.6.0)
> Cannot satisfy dependency:
> From: UML2 Activity Diagram Plugin (Incubation) 0.9.0.v200906190654
> (org.eclipse.uml2.diagram.activity 0.9.0.v200906190654)
> To: bundle org.eclipse.emf.ocl 0.0.0
> Cannot satisfy dependency:
> From: UML2 Diagramming (Incubation) 0.9.0.v200906190654
> (org.eclipse.uml2.diagram.feature.group 0.9.0.v200906190654)
> To: org.eclipse.uml2.diagram.activity [0.9.0.v200906190654]
Re: UML2 Tools and Helios [message #549341 is a reply to message #538135] Mon, 26 July 2010 13:41 Go to previous messageGo to next message
Christian Waniek is currently offline Christian Waniek
Messages: 50
Registered: May 2010
Member
Hi Gilbert,

there is a new incubation release (0.9.0 / 0.9.2 (2010/07/17)) which perfectly works with Eclipse Helios


http:// modeling.eclipse.org/modeling/mdt/downloads/?project=uml2too ls&showAll=0&showMax=5&sortBy=date

But I don't know if you can isntall it via the Update Manager. I downloaded the ZIP File and installed all missing dependencies manually.

And besides, it might interest you that develoment of UML2Tools hasn't stopped completely, though there aren't any active committers listed for this project.

Regards
Christian Waniek
Re: UML2 Tools and Helios [message #549454 is a reply to message #549341] Mon, 26 July 2010 16:44 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Christian

Something has gone astray with the promotion.

0.9.2 ZIPs have been put in a 0.9.0 folder.

The 0.9.1 I build is not shown on the download page.

The 0.9.2 Update ZIP is missing completely. This really must be provided
because installation of anything other that Update Sites on p2 is now
very difficult.

~/downloads/modeling/mdt/uml2tools/downloads/drops doesn't show any
0.9.2 ZIPs under 0.9.0 or 0.9.2.

Regards

Ed Willink



On 26/07/2010 14:41, Christian Waniek wrote:
> Hi Gilbert,
>
> there is a new incubation release (0.9.0 / 0.9.2 (2010/07/17)) which
> perfectly works with Eclipse Helios
>
>
> http://modeling.eclipse.org/modeling/mdt/downloads/?project= uml2tools&showAll=0&showMax=5&sortBy=date
>
>
> But I don't know if you can isntall it via the Update Manager. I
> downloaded the ZIP File and installed all missing dependencies manually.
>
> And besides, it might interest you that develoment of UML2Tools hasn't
> stopped completely, though there aren't any active committers listed for
> this project.
>
> Regards
> Christian Waniek
Re: UML2 Tools and Helios [message #549562 is a reply to message #549454] Tue, 27 July 2010 08:39 Go to previous messageGo to next message
Christian Waniek is currently offline Christian Waniek
Messages: 50
Registered: May 2010
Member
Hi Ed,

You're right, the version numbers are a bit confusing and I hope this will be fixed with a release version soon.

A few monbth ago there was a 0.9.1 version of U2T, but for some reasons this wasn't a build for everyone (I've forgotten why).

Some nightly and incubation builds can also be found here:
http:// modeling.eclipse.org/modeling/mdt/uml2tools/downloads/drops/ 0.9.0/

And besides, for me installation without an update site isn't very difficult. I downloaded the U2T SDK zip and all dependencies as zips and unzipped them to the dropins-folder of my eclipse helios sdk. Then I started eclipse and I could use U2T.

Regards
Christian Waniek
Re: UML2 Tools and Helios [message #549573 is a reply to message #549562] Tue, 27 July 2010 08:49 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Christian

dropins are now very deprecated. All. sorts of nasty things happen
because p2 cannolt check your installation consistency.

Regards

Ed Willink


On 27/07/2010 09:39, Christian Waniek wrote:
> Hi Ed,
>
> You're right, the version numbers are a bit confusing and I hope this
> will be fixed with a release version soon.
>
> A few monbth ago there was a 0.9.1 version of U2T, but for some reasons
> this wasn't a build for everyone (I've forgotten why).
>
> Some nightly and incubation builds can also be found here:
> http://modeling.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/
>
> And besides, for me installation without an update site isn't very
> difficult. I downloaded the U2T SDK zip and all dependencies as zips and
> unzipped them to the dropins-folder of my eclipse helios sdk. Then I
> started eclipse and I could use U2T.
>
> Regards
> Christian Waniek
Re: UML2 Tools and Helios [message #554814 is a reply to message #538135] Tue, 24 August 2010 13:18 Go to previous messageGo to next message
Daniel Rippel is currently offline Daniel Rippel
Messages: 29
Registered: July 2009
Junior Member
Hi to all,

just out of curiosity, is it actually planned to include the UML2 Tools into the Helios repositories once they're updated again? Or will the UML2 Tool project be removed completly? Because I'm actually working on a RCP Application which uses UML2 Tools editors and I'd like to know if they're still under development or if I have to switch ot papyrus anyways.

Just another question: Are there planns to complete the Sequence Diagram Editor? Actually (v 0.9.2) it's still quiet buggy and refuses to open if anything more thanInteractions, lifelines and synchronous calls are present within the model.

Thank you,
Daniel

[Updated on: Tue, 24 August 2010 13:58]

Report message to a moderator

Re: UML2 Tools and Helios [message #554895 is a reply to message #554814] Tue, 24 August 2010 16:08 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Daniel

There don't seem to be any new enthusiasts to develop UML2-Tools so I
think that it is your difficult choice when you switch to Papyrus.

Regards

Ed Willink

On 24/08/2010 14:18, Daniel Rippel wrote:
> Hi to all,
>
> just out of curiosity, is it actually planned to include the UML2 Tools
> into the Helios repositories once they're updated again? Or will the
> UML2 Tool project be removed completly? Because I'm actually working on
> a RCP Application which uses UML2 Tools editors and I'd like to know if
> they're still under development or if I have to switch ot papyrus anyways.
>
> Thank you,
> Daniel
Re: UML2 Tools and Helios [message #554969 is a reply to message #554895] Wed, 25 August 2010 00:47 Go to previous messageGo to next message
Kieran Simpson is currently offline Kieran Simpson
Messages: 10
Registered: November 2009
Junior Member
That's a shame actually, as I thought having a decent UML editing tool in Eclipse was worthwhile. I was waiting for the UML-tools to be updated for Helios.
Re: UML2 Tools and Helios [message #554983 is a reply to message #554969] Wed, 25 August 2010 04:57 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Kieran

It's certainly a shame, but Papyrus is also within Eclipse.

I understand that Papyrus is more model-driven so hopefully the second
attempt will learn from the limitations of the first.

Regards

Ed Willink


On 25/08/2010 01:47, Kieran Simpson wrote:
> That's a shame actually, as I thought having a decent UML editing tool
> in Eclipse was worthwhile. I was waiting for the UML-tools to be updated
> for Helios.
Re: UML2 Tools and Helios [message #555004 is a reply to message #538135] Wed, 25 August 2010 07:14 Go to previous messageGo to next message
Daniel Rippel is currently offline Daniel Rippel
Messages: 29
Registered: July 2009
Junior Member
> It's certainly a shame, but Papyrus is also within Eclipse.

> I understand that Papyrus is more model-driven so hopefully the second
> attempt will learn from the limitations of the first.

Thats true. Unfortunately, Papyrus is as incomplete as the UML2 Tools were before. I hopped that they will be fully functional with this release. So we can only hope that Papyrus will mature quickly and include all UML Diagrams soon.

Thank you for your answer. I'll try to switch to Papyrus once I managed to check out the sources without my Eclipse crashing (Heap space overflow)
Re: UML2 Tools and Helios [message #557362 is a reply to message #554983] Tue, 07 September 2010 06:41 Go to previous messageGo to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

> I understand that Papyrus is more model-driven so hopefully the second
> attempt will learn from the limitations of the first.
Well, Papyrus is not able to generate a diagram from an existing *.uml
file. So for me at least this un-functionality is not very model-driven.
Besides that state machines are missed completely.
Re: UML2 Tools and Helios [message #557602 is a reply to message #557362] Wed, 08 September 2010 09:16 Go to previous messageGo to next message
Christian Waniek is currently offline Christian Waniek
Messages: 50
Registered: May 2010
Member
Also in my opinion papyrus isn't a real alternative for the uml2 tools. As you already stated, statemachines are missing and you can't initialize diagrams out of *.uml files. Mainly the second point hinders one to migrate existing UML2-models, created e.g. with the uml2 tools, to papyrus. If you are working in long living projects this is a very important matter because you don't want to re-draw numerous diagrams.

So our company is still relying on the uml2 tools and we are still contributing patches an trying to place one or two comitters for the uml2 tools. So I hope the uml2 tools project won't die.

Of course, our goal is to have a release for helios at the end of the day.

Regards
Christian Waniek
Re: UML2 Tools and Helios [message #558071 is a reply to message #557602] Fri, 10 September 2010 06:26 Go to previous messageGo to next message
Kieran Simpson is currently offline Kieran Simpson
Messages: 10
Registered: November 2009
Junior Member
That's great Christian if a few of your people can keep the good work going on the UML2Tools. Keep up the good work.
Re: UML2 Tools and Helios [message #625638 is a reply to message #538135] Sat, 05 June 2010 15:27 Go to previous messageGo to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

Ok, indeed it was possible with the sources from CVS repository. Sorry
for the post.
Re: UML2 Tools and Helios [message #625816 is a reply to message #538135] Mon, 05 July 2010 20:07 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Gilbert

> Cannot satisfy dependency:
> From: UML2 Activity Diagram Plugin (Incubation) 0.9.0.v200906190654
> (org.eclipse.uml2.diagram.activity 0.9.0.v200906190654)
> To: bundle org.eclipse.emf.ocl 0.0.0

This is very unfortunate. org.eclipse.emf.ocl was deprecated long ago
and so was removed in Helios, which would be no problem if UML2-Tools
had rebuilt. The erroneous dependency prevents 0.9.0 or 0.9.1 being
installed on Helios.

It would be good if someone could do a rebuild as-is/as-was.

Otherwise may be MDT/OCL could provide a compatibility feature just
to remap org.eclipse.emf.ocl to org.eclipse.ocl. However I'm not sure
that the mapping of the obsolete API to the prevailing API can be done
within the version bounds that would make it useable.

Regards

Ed Willink
Re: UML2 Tools and Helios [message #625819 is a reply to message #538135] Tue, 06 July 2010 09:07 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi

See See
http://wiki.eclipse.org/MDT/OCL/FAQ#How_do_I_workaround_org. eclipse.emf.ocl_deprecation_in_Helios_and_later.3F

Regards

Ed Willink

On 05/06/2010 16:08, Gilbert Mirenque wrote:
> The UML2 Tools aren't included in the Helios RC3. As I wanted to install
> them by update url
> http://download.eclipse.org/modeling/mdt/updates/releases/ I checked the
> latest incubation version 0.9.0 from there. But the installation
> couldn't be completed because of the inconsistencies I attached at the
> end of this message. Is there a possibility to get the nice UML2
> diagrams working in the Helios RC3? Or do I have to check out it from
> the CVS?
>
> best regards,
> Gilbert
>
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: UML2 Diagramming (Incubation)
> 0.9.0.v200906190654 (org.eclipse.uml2.diagram.feature.group
> 0.9.0.v200906190654)
> Software currently installed: Eclipse Modeling Tools
> 1.3.0.20100529-0859 (epp.package.modeling 1.3.0.20100529-0859)
> Only one of the following can be installed at once:
> EMF Ecore 2.5.0.v200906151043 (org.eclipse.emf.ecore
> 2.5.0.v200906151043)
> EMF Ecore 2.1.1 (org.eclipse.emf.ecore 2.1.1)
> EMF Ecore 2.2.4.v200808252119 (org.eclipse.emf.ecore
> 2.2.4.v200808252119)
> EMF Ecore 2.4.1.v200808251517 (org.eclipse.emf.ecore
> 2.4.1.v200808251517)
> EMF Ecore 2.3.2.v200802051830 (org.eclipse.emf.ecore
> 2.3.2.v200802051830)
> EMF Ecore 2.0.4 (org.eclipse.emf.ecore 2.0.4)
> EMF Ecore 2.6.0.v20100527-1913 (org.eclipse.emf.ecore
> 2.6.0.v20100527-1913)
> EMF Ecore 2.4.2.v200902171115 (org.eclipse.emf.ecore
> 2.4.2.v200902171115)
> Cannot satisfy dependency:
> From: Eclipse Modeling Tools 1.3.0.20100529-0859
> (epp.package.modeling 1.3.0.20100529-0859)
> To: org.eclipse.epp.package.modeling.feature.feature.group
> [1.3.0.20100529-0859]
> Cannot satisfy dependency:
> From: Ecore Tools (Incubation) 0.10.0.v20100521-2009
> (org.eclipse.emf.ecoretools 0.10.0.v20100521-2009)
> To: bundle org.eclipse.emf.ecore [2.6.0,3.0.0)
> Cannot satisfy dependency:
> From: Ecore Tools (Incubation) 0.10.0.v20100601-1628
> (org.eclipse.emf.ecoretools.feature.group 0.10.0.v20100601-1628)
> To: org.eclipse.emf.ecoretools [0.10.0.v20100521-2009]
> Cannot satisfy dependency:
> From: Ecore Tools SDK (Incubation) 0.10.0.v20100601-1628
> (org.eclipse.emf.ecoretools.sdk.feature.group 0.10.0.v20100601-1628)
> To: org.eclipse.emf.ecoretools.feature.group [0.10.0.v20100601-1628]
> Cannot satisfy dependency:
> From: Object Constraint Language (OCL) 2.0 Compatibility API
> 1.1.101.v200808291106 (org.eclipse.emf.ocl 1.1.101.v200808291106)
> To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: Object Constraint Language (OCL) 2.0 Compatibility API
> 1.1.101.v200901271800 (org.eclipse.emf.ocl 1.1.101.v200901271800)
> To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: Object Constraint Language (OCL) 2.0 Compatibility API
> 1.1.101.v200908161630 (org.eclipse.emf.ocl 1.1.101.v200908161630)
> To: bundle org.eclipse.ocl.ecore [1.1.0,2.0.0)
> Cannot satisfy dependency:
> From: EPP Modeling Feature 1.3.0.20100529-0859
> (org.eclipse.epp.package.modeling.feature.feature.group 1.3.0.20100529-0859)
> To: org.eclipse.emf.ecoretools.sdk.feature.group 0.0.0
> Cannot satisfy dependency:
> From: OCL 2.0 Binding for Ecore 1.2.1.v200807301850
> (org.eclipse.ocl.ecore 1.2.1.v200807301850)
> To: bundle org.eclipse.emf.ecore [2.4.0,2.5.0)
> Cannot satisfy dependency:
> From: OCL 2.0 Binding for Ecore 1.3.0.v200905271400
> (org.eclipse.ocl.ecore 1.3.0.v200905271400)
> To: bundle org.eclipse.emf.ecore [2.5.0,2.6.0)
> Cannot satisfy dependency:
> From: UML2 Activity Diagram Plugin (Incubation) 0.9.0.v200906190654
> (org.eclipse.uml2.diagram.activity 0.9.0.v200906190654)
> To: bundle org.eclipse.emf.ocl 0.0.0
> Cannot satisfy dependency:
> From: UML2 Diagramming (Incubation) 0.9.0.v200906190654
> (org.eclipse.uml2.diagram.feature.group 0.9.0.v200906190654)
> To: org.eclipse.uml2.diagram.activity [0.9.0.v200906190654]
Re: UML2 Tools and Helios [message #625837 is a reply to message #538135] Mon, 26 July 2010 13:41 Go to previous messageGo to next message
Christian Waniek is currently offline Christian Waniek
Messages: 50
Registered: May 2010
Member
Hi Gilbert,

there is a new incubation release (0.9.0 / 0.9.2 (2010/07/17)) which perfectly works with Eclipse Helios


http://modeling.eclipse.org/modeling/mdt/downloads/?project= uml2tools&showAll=0&showMax=5&sortBy=date

But I don't know if you can isntall it via the Update Manager. I downloaded the ZIP File and installed all missing dependencies manually.

And besides, it might interest you that develoment of UML2Tools hasn't stopped completely, though there aren't any active committers listed for this project.

Regards
Christian Waniek
Re: UML2 Tools and Helios [message #625871 is a reply to message #549341] Mon, 26 July 2010 16:44 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Christian

Something has gone astray with the promotion.

0.9.2 ZIPs have been put in a 0.9.0 folder.

The 0.9.1 I build is not shown on the download page.

The 0.9.2 Update ZIP is missing completely. This really must be provided
because installation of anything other that Update Sites on p2 is now
very difficult.

~/downloads/modeling/mdt/uml2tools/downloads/drops doesn't show any
0.9.2 ZIPs under 0.9.0 or 0.9.2.

Regards

Ed Willink



On 26/07/2010 14:41, Christian Waniek wrote:
> Hi Gilbert,
>
> there is a new incubation release (0.9.0 / 0.9.2 (2010/07/17)) which
> perfectly works with Eclipse Helios
>
>
> http://modeling.eclipse.org/modeling/mdt/downloads/?project= uml2tools&showAll=0&showMax=5&sortBy=date
>
>
> But I don't know if you can isntall it via the Update Manager. I
> downloaded the ZIP File and installed all missing dependencies manually.
>
> And besides, it might interest you that develoment of UML2Tools hasn't
> stopped completely, though there aren't any active committers listed for
> this project.
>
> Regards
> Christian Waniek
Re: UML2 Tools and Helios [message #625872 is a reply to message #549454] Tue, 27 July 2010 08:39 Go to previous messageGo to next message
Christian Waniek is currently offline Christian Waniek
Messages: 50
Registered: May 2010
Member
Hi Ed,

You're right, the version numbers are a bit confusing and I hope this will be fixed with a release version soon.

A few monbth ago there was a 0.9.1 version of U2T, but for some reasons this wasn't a build for everyone (I've forgotten why).

Some nightly and incubation builds can also be found here:
http://modeling.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/

And besides, for me installation without an update site isn't very difficult. I downloaded the U2T SDK zip and all dependencies as zips and unzipped them to the dropins-folder of my eclipse helios sdk. Then I started eclipse and I could use U2T.

Regards
Christian Waniek
Re: UML2 Tools and Helios [message #625873 is a reply to message #625872] Tue, 27 July 2010 08:49 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Christian

dropins are now very deprecated. All. sorts of nasty things happen
because p2 cannolt check your installation consistency.

Regards

Ed Willink


On 27/07/2010 09:39, Christian Waniek wrote:
> Hi Ed,
>
> You're right, the version numbers are a bit confusing and I hope this
> will be fixed with a release version soon.
>
> A few monbth ago there was a 0.9.1 version of U2T, but for some reasons
> this wasn't a build for everyone (I've forgotten why).
>
> Some nightly and incubation builds can also be found here:
> http://modeling.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/
>
> And besides, for me installation without an update site isn't very
> difficult. I downloaded the U2T SDK zip and all dependencies as zips and
> unzipped them to the dropins-folder of my eclipse helios sdk. Then I
> started eclipse and I could use U2T.
>
> Regards
> Christian Waniek
Re: UML2 Tools and Helios [message #625970 is a reply to message #538135] Tue, 24 August 2010 13:18 Go to previous messageGo to next message
Daniel Rippel is currently offline Daniel Rippel
Messages: 29
Registered: July 2009
Junior Member
Hi to all,

just out of curiosity, is it actually planned to include the UML2 Tools into the Helios repositories once they're updated again? Or will the UML2 Tool project be removed completly? Because I'm actually working on a RCP Application which uses UML2 Tools editors and I'd like to know if they're still under development or if I have to switch ot papyrus anyways.

Thank you,
Daniel
Re: UML2 Tools and Helios [message #625972 is a reply to message #625970] Tue, 24 August 2010 16:08 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Daniel

There don't seem to be any new enthusiasts to develop UML2-Tools so I
think that it is your difficult choice when you switch to Papyrus.

Regards

Ed Willink

On 24/08/2010 14:18, Daniel Rippel wrote:
> Hi to all,
>
> just out of curiosity, is it actually planned to include the UML2 Tools
> into the Helios repositories once they're updated again? Or will the
> UML2 Tool project be removed completly? Because I'm actually working on
> a RCP Application which uses UML2 Tools editors and I'd like to know if
> they're still under development or if I have to switch ot papyrus anyways.
>
> Thank you,
> Daniel
Re: UML2 Tools and Helios [message #625973 is a reply to message #554895] Wed, 25 August 2010 00:47 Go to previous messageGo to next message
Kieran Simpson is currently offline Kieran Simpson
Messages: 10
Registered: November 2009
Junior Member
That's a shame actually, as I thought having a decent UML editing tool in Eclipse was worthwhile. I was waiting for the UML-tools to be updated for Helios.
Re: UML2 Tools and Helios [message #625974 is a reply to message #625973] Wed, 25 August 2010 04:57 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Kieran

It's certainly a shame, but Papyrus is also within Eclipse.

I understand that Papyrus is more model-driven so hopefully the second
attempt will learn from the limitations of the first.

Regards

Ed Willink


On 25/08/2010 01:47, Kieran Simpson wrote:
> That's a shame actually, as I thought having a decent UML editing tool
> in Eclipse was worthwhile. I was waiting for the UML-tools to be updated
> for Helios.
Re: UML2 Tools and Helios [message #625975 is a reply to message #538135] Wed, 25 August 2010 07:14 Go to previous messageGo to next message
Daniel Rippel is currently offline Daniel Rippel
Messages: 29
Registered: July 2009
Junior Member
> It's certainly a shame, but Papyrus is also within Eclipse.

> I understand that Papyrus is more model-driven so hopefully the second
> attempt will learn from the limitations of the first.

Thats true. Unfortunately, Papyrus is as incomplete as the UML2 Tools were before. I hopped that they will be fully functional with this release. So we can only hope that Papyrus will mature quickly and include all UML Diagrams soon.

Thank you for your answer. I'll try to switch to Papyrus once I managed to check out the sources without my Eclipse crashing (Heap space overflow)
Re: UML2 Tools and Helios [message #626002 is a reply to message #554983] Tue, 07 September 2010 06:41 Go to previous messageGo to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

> I understand that Papyrus is more model-driven so hopefully the second
> attempt will learn from the limitations of the first.
Well, Papyrus is not able to generate a diagram from an existing *.uml
file. So for me at least this un-functionality is not very model-driven.
Besides that state machines are missed completely.
Re: UML2 Tools and Helios [message #626003 is a reply to message #557362] Wed, 08 September 2010 09:16 Go to previous messageGo to next message
Christian Waniek is currently offline Christian Waniek
Messages: 50
Registered: May 2010
Member
Also in my opinion papyrus isn't a real alternative for the uml2 tools. As you already stated, statemachines are missing and you can't initialize diagrams out of *.uml files. Mainly the second point hinders one to migrate existing UML2-models, created e.g. with the uml2 tools, to papyrus. If you are working in long living projects this is a very important matter because you don't want to re-draw numerous diagrams.

So our company is still relying on the uml2 tools and we are still contributing patches an trying to place one or two comitters for the uml2 tools. So I hope the uml2 tools project won't die.

Of course, our goal is to have a release for helios at the end of the day.

Regards
Christian Waniek
Re: UML2 Tools and Helios [message #626009 is a reply to message #626003] Fri, 10 September 2010 06:26 Go to previous message
Kieran Simpson is currently offline Kieran Simpson
Messages: 10
Registered: November 2009
Junior Member
That's great Christian if a few of your people can keep the good work going on the UML2Tools. Keep up the good work.
Previous Topic:Activity Diagram gets jumbled
Next Topic:I'm worried - UML2Tools vs Papyrus
Goto Forum:
  


Current Time: Mon Sep 22 18:17:56 GMT 2014

Powered by FUDForum. Page generated in 0.03522 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software