Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Error initializing parser for input
Error initializing parser for input [message #537680] Thu, 03 June 2010 11:22 Go to next message
Magisterion is currently offline MagisterionFriend
Messages: 10
Registered: June 2010
Junior Member
I'm trying to use the last IMP build to create new Language for Eclipse 3.5.
When i try to test plugin for my JScript file flash_commands.js - i got Coloring, but nothing else (i create plugins for outline and etc - how said at documentation). And there is the next errors:

Error initializing parser for input flash_commands.js:
org.eclipse.imp.model.ModelFactory$ModelException: No such element: 
	at org.eclipse.imp.model.ModelFactory.doOpen(ModelFactory.java:127)
	at org.eclipse.imp.model.ModelFactory.open(ModelFactory.java:122)
	at org.eclipse.imp.editor.UniversalEditor.initializeParseController(UniversalEditor.java:730)
	at org.eclipse.imp.editor.UniversalEditor.createPartControl(UniversalEditor.java:693)
	at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:662)
	at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:462)
	at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
	at org.eclipse.ui.internal.EditorAreaHelper.setVisibleEditor(EditorAreaHelper.java:271)
	at org.eclipse.ui.internal.EditorManager.setVisibleEditor(EditorManager.java:1417)
	at org.eclipse.ui.internal.EditorManager$5.runWithException(EditorManager.java:942)
	at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3885)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3506)
	at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
	at org.eclipse.ui.internal.Workbench$28.runWithException(Workbench.java:1384)
	at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3885)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3506)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2316)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1287)


is this normal? If not - how to fix this?
Re: Error initializing parser for input [message #537697 is a reply to message #537680] Thu, 03 June 2010 12:03 Go to previous messageGo to next message
Magisterion is currently offline MagisterionFriend
Messages: 10
Registered: June 2010
Junior Member
Problem is solved. I just try to open files without a Project. When i create project and open file from it - there not problems.
Re: Error initializing parser for input [message #537817 is a reply to message #537697] Thu, 03 June 2010 17:07 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. FuhrerFriend
Messages: 294
Registered: July 2009
Senior Member
On 6/3/10 8:03 AM, Magisterion wrote:
> Problem is solved. I just try to open files without a Project. When i
> create project and open file from it - there not problems.

IMP is supposed to be able to (and mostly does) handle opening source
files that don't belong to any workspace project (e.g., files that live
entirely outside the workspace).

I.e., this sounds like a bug. If you can send a bit more info, hopefully
we can diagnose and fix it.

If you can, please open a bug in bugzilla for this so we can track it.

Thanks!

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: Error initializing parser for input [message #537959 is a reply to message #537817] Fri, 04 June 2010 10:26 Go to previous messageGo to next message
Magisterion is currently offline MagisterionFriend
Messages: 10
Registered: June 2010
Junior Member
Robert M. Fuhrer wrote on Thu, 03 June 2010 13:07
On 6/3/10 8:03 AM, Magisterion wrote:
> Problem is solved. I just try to open files without a Project. When i
> create project and open file from it - there not problems.

IMP is supposed to be able to (and mostly does) handle opening source
files that don't belong to any workspace project (e.g., files that live
entirely outside the workspace).

I.e., this sounds like a bug. If you can send a bit more info, hopefully
we can diagnose and fix it.

If you can, please open a bug in bugzilla for this so we can track it.

Thanks!

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)

Looks like all works fine, withing errors. I haven't outline and folding because of wrong parsing rules . But anyway - later i try to open different files without projects - and if bug will give any problems i will post it.
Re: Error initializing parser for input [message #577862 is a reply to message #537680] Thu, 03 June 2010 12:03 Go to previous messageGo to next message
Magisterion is currently offline MagisterionFriend
Messages: 10
Registered: June 2010
Junior Member
Problem is solved. I just try to open files without a Project. When i create project and open file from it - there not problems.
Re: Error initializing parser for input [message #577909 is a reply to message #537697] Thu, 03 June 2010 17:07 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. FuhrerFriend
Messages: 294
Registered: July 2009
Senior Member
On 6/3/10 8:03 AM, Magisterion wrote:
> Problem is solved. I just try to open files without a Project. When i
> create project and open file from it - there not problems.

IMP is supposed to be able to (and mostly does) handle opening source
files that don't belong to any workspace project (e.g., files that live
entirely outside the workspace).

I.e., this sounds like a bug. If you can send a bit more info, hopefully
we can diagnose and fix it.

If you can, please open a bug in bugzilla for this so we can track it.

Thanks!

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: Error initializing parser for input [message #577969 is a reply to message #537817] Fri, 04 June 2010 10:26 Go to previous message
Magisterion is currently offline MagisterionFriend
Messages: 10
Registered: June 2010
Junior Member
Robert M. Fuhrer wrote on Thu, 03 June 2010 13:07
> On 6/3/10 8:03 AM, Magisterion wrote:
> > Problem is solved. I just try to open files without a Project. When i
> > create project and open file from it - there not problems.
>
> IMP is supposed to be able to (and mostly does) handle opening source
> files that don't belong to any workspace project (e.g., files that live
> entirely outside the workspace).
>
> I.e., this sounds like a bug. If you can send a bit more info, hopefully
> we can diagnose and fix it.
>
> If you can, please open a bug in bugzilla for this so we can track it.
>
> Thanks!
>
> --
> Cheers,
> -- Bob
>
> --------------------------------
> Robert M. Fuhrer
> Research Staff Member
> Programming Technologies Dept.
> IBM T.J. Watson Research Center
>
> IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
> X10: Productive High-Performance Parallel Programming (http://x10.sf.net)

Looks like all works fine, withing errors. I haven't outline and folding because of wrong parsing rules . But anyway - later i try to open different files without projects - and if bug will give any problems i will post it.
Previous Topic:Problem with occurence marker
Next Topic:Unicode
Goto Forum:
  


Current Time: Mon Nov 24 00:31:00 GMT 2014

Powered by FUDForum. Page generated in 0.02323 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software