Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Visual Editor (VE) » Re: Installing visual editor
Re: Installing visual editor [message #537427] Wed, 02 June 2010 12:15 Go to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26237
Registered: July 2009
Senior Member
This kind of question comes up repeatedly on the VE newsgroup/forum.
Have a look there. I've added it to the "to" list of this reply.


H wrote:
> Hey, I'm a total newbie to programming in general (just starting my
> first class). I'm on a ubuntu computer. I have installed eclipse
> 3.5. I tried installing visual editor 1.4 through one of the mirrors,
> because I was unable to install it directly through the website.
> Everything went fine until it got to calculating dependencies, but
> then I got this:
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Java EMF Model
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> (org.eclipse.jem.feature.group
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> Missing requirement: Java EMF Model Utilities
> 2.0.200.R3_1_maintenance (org.eclipse.jem.util
> 2.0.200.R3_1_maintenance) requires 'bundle org.eclipse.emf.ecore
> [2.4.0,3.0.0)' but it could not be found
> Cannot satisfy dependency:
> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
> (org.eclipse.jem.feature.group
> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
> To: org.eclipse.jem.workbench [2.0.201.R3_1_maintenance]
> Cannot satisfy dependency:
> From: Java EMF Model Workbench Support 2.0.201.R3_1_maintenance
> (org.eclipse.jem.workbench 2.0.201.R3_1_maintenance)
> To: bundle org.eclipse.jem.util [2.0.0,3.0.0)
>
> Any idea what's going on, or where I can get these bundles? Any help
> REALLY appreciated.
Re: Installing visual editor [message #537568 is a reply to message #537427] Wed, 02 June 2010 21:56 Go to previous message
Yves YANG is currently offline Yves YANGFriend
Messages: 687
Registered: July 2009
Senior Member
Yes, we need definitively to do something. We should change the update site
configuration for not listing the JEM bundles (embedded it of course) and
leave the Update mnager to make the resolution. I have added a comment here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=270849#c47

Now I have created an independent bug to handle this case:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=315508

Hope it will be resolved soon.

Best regards
Yves YANG
"Ed Merks" <Ed.Merks@gmail.com> wrote in message
news:hu5i1g$itl$2@build.eclipse.org...
> This kind of question comes up repeatedly on the VE newsgroup/forum. Have
> a look there. I've added it to the "to" list of this reply.
>
>
> H wrote:
>> Hey, I'm a total newbie to programming in general (just starting my first
>> class). I'm on a ubuntu computer. I have installed eclipse 3.5. I
>> tried installing visual editor 1.4 through one of the mirrors, because I
>> was unable to install it directly through the website. Everything went
>> fine until it got to calculating dependencies, but then I got this:
>>
>> Cannot complete the install because one or more required items could not
>> be found.
>> Software being installed: Java EMF Model
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> Missing requirement: Java EMF Model Utilities 2.0.200.R3_1_maintenance
>> (org.eclipse.jem.util 2.0.200.R3_1_maintenance) requires 'bundle
>> org.eclipse.emf.ecore [2.4.0,3.0.0)' but it could not be found
>> Cannot satisfy dependency:
>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> To: org.eclipse.jem.workbench [2.0.201.R3_1_maintenance]
>> Cannot satisfy dependency:
>> From: Java EMF Model Workbench Support 2.0.201.R3_1_maintenance
>> (org.eclipse.jem.workbench 2.0.201.R3_1_maintenance)
>> To: bundle org.eclipse.jem.util [2.0.0,3.0.0)
>>
>> Any idea what's going on, or where I can get these bundles? Any help
>> REALLY appreciated.
Re: Installing visual editor [message #618390 is a reply to message #537427] Wed, 02 June 2010 21:56 Go to previous message
Yves YANG is currently offline Yves YANGFriend
Messages: 687
Registered: July 2009
Senior Member
Yes, we need definitively to do something. We should change the update site
configuration for not listing the JEM bundles (embedded it of course) and
leave the Update mnager to make the resolution. I have added a comment here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=270849#c47

Now I have created an independent bug to handle this case:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=315508

Hope it will be resolved soon.

Best regards
Yves YANG
"Ed Merks" <Ed.Merks@gmail.com> wrote in message
news:hu5i1g$itl$2@build.eclipse.org...
> This kind of question comes up repeatedly on the VE newsgroup/forum. Have
> a look there. I've added it to the "to" list of this reply.
>
>
> H wrote:
>> Hey, I'm a total newbie to programming in general (just starting my first
>> class). I'm on a ubuntu computer. I have installed eclipse 3.5. I
>> tried installing visual editor 1.4 through one of the mirrors, because I
>> was unable to install it directly through the website. Everything went
>> fine until it got to calculating dependencies, but then I got this:
>>
>> Cannot complete the install because one or more required items could not
>> be found.
>> Software being installed: Java EMF Model
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> Missing requirement: Java EMF Model Utilities 2.0.200.R3_1_maintenance
>> (org.eclipse.jem.util 2.0.200.R3_1_maintenance) requires 'bundle
>> org.eclipse.emf.ecore [2.4.0,3.0.0)' but it could not be found
>> Cannot satisfy dependency:
>> From: Java EMF Model 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd
>> (org.eclipse.jem.feature.group
>> 1.4.0.v20090826-1446-7H-FPbAcggQleH8hJifHfUd)
>> To: org.eclipse.jem.workbench [2.0.201.R3_1_maintenance]
>> Cannot satisfy dependency:
>> From: Java EMF Model Workbench Support 2.0.201.R3_1_maintenance
>> (org.eclipse.jem.workbench 2.0.201.R3_1_maintenance)
>> To: bundle org.eclipse.jem.util [2.0.0,3.0.0)
>>
>> Any idea what's going on, or where I can get these bundles? Any help
>> REALLY appreciated.
Previous Topic:Re: Installing visual editor
Next Topic:Re: Can't install VE 1.4 on Galileo 3.5
Goto Forum:
  


Current Time: Sat Nov 29 03:54:28 GMT 2014

Powered by FUDForum. Page generated in 0.02476 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software