Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OSEE » Installation Docs
Installation Docs [message #537404] Wed, 02 June 2010 11:05 Go to next message
al  is currently offline al Friend
Messages: 22
Registered: June 2010
Junior Member
I've been following this project for several years and am about to install and use OSEE for a small project.

Yet, I'm finding that the install docs are confusing and spread all over.
I've seen that there is version dependencies and not version metrics.

Has anyone compiled a complete installation set of docs that are up to date?

Re: Installation Docs [message #538302 is a reply to message #537404] Mon, 07 June 2010 09:40 Go to previous messageGo to next message
Mark D-B is currently offline Mark D-BFriend
Messages: 188
Registered: July 2009
Senior Member
Please clarify in what way the install docs are confusing and spread all over. I am an OSEE user, not a developer, and have found that Ryan's reorganisation of the web site has added much-needed clarity. http://wiki.eclipse.org/OSEE/Users_Guide/Getting_Started gives a step-by-step guide to setting the tool up for use with PostgreSQL.
Re: Installation Docs [message #547832 is a reply to message #538302] Mon, 19 July 2010 17:50 Go to previous messageGo to next message
Ray Joseph is currently offline Ray JosephFriend
Messages: 87
Registered: July 2009
Member
Mark,

I am very interested in the documentation as I need a lot of help moving...forward. So, I would like to start with my finds where I have difficulties; not that there are problems, but I have concerns. Starting from the wiki you pointed to:

1) The first step is: Non-Eclipse System Requirements
a) 'Supported Databases' takes us to the Postgresql pages where the first opportunity to down load is the 'one click installer' for version 8.4.4. Is this the necessary version?
b) 'Install Eclipse' takes us to the page where we can download version 3.6.0. But in the same section of the wiki, 'Eclipse Dependencies' it says to use version 3.5.
c) 'Notes' goes into coordination of 3.5.0 and 3.5.1 and OSEE 0.8.3.
From the above, I can tell if these are just alternative opportunities or specific requirements to the latest OSEE.

2) The next step is: Launch Application Server
a) The first line says to see the 'User's Guide' for more information. But we are already in the User Guide.
b) The 'Instructions' sections points to the 'microdoc' site. This site seems to address 'OSEE Application Server 0.8.3. I do not know if these instruction are still valid or if the download link is the correct version since it states 0.8.3. And also points to a 0.7.0 version. The page continues with the OSEE Client 0.7.0.
c) At the bottom of the 'microdoc' site, it addresses an add-on package labeled 0.7. Is this package something that should be used with the latest version?

3) The next section addresses 'Application Server Launch Instructions'.
a) There are no instructions for ' <ConnectionId>
b) There are no instructions for '<VersionForYourEclipse>'.
The page says to see the User Guide, but this is the guide.

I really appreciate everyone's efforts. I hope that I have contributed some value to helping people learn about OSEE. I know I can really use some help.

Ray
Re: Installation Docs [message #577096 is a reply to message #538302] Mon, 19 July 2010 17:50 Go to previous messageGo to next message
Ray Joseph is currently offline Ray JosephFriend
Messages: 87
Registered: July 2009
Member
Mark,

I am very interested in the documentation as I need a lot of help moving...forward. So, I would like to start with my finds where I have difficulties; not that there are problems, but I have concerns. Starting from the wiki you pointed to:

1) The first step is: Non-Eclipse System Requirements
a) 'Supported Databases' takes us to the Postgresql pages where the first opportunity to down load is the 'one click installer' for version 8.4.4. Is this the necessary version?
b) 'Install Eclipse' takes us to the page where we can download version 3.6.0. But in the same section of the wiki, 'Eclipse Dependencies' it says to use version 3.5.
c) 'Notes' goes into coordination of 3.5.0 and 3.5.1 and OSEE 0.8.3.
From the above, I can tell if these are just alternative opportunities or specific requirements to the latest OSEE.

2) The next step is: Launch Application Server
a) The first line says to see the 'User's Guide' for more information. But we are already in the User Guide.
b) The 'Instructions' sections points to the 'microdoc' site. This site seems to address 'OSEE Application Server 0.8.3. I do not know if these instruction are still valid or if the download link is the correct version since it states 0.8.3. And also points to a 0.7.0 version. The page continues with the OSEE Client 0.7.0.
c) At the bottom of the 'microdoc' site, it addresses an add-on package labeled 0.7. Is this package something that should be used with the latest version?

3) The next section addresses 'Application Server Launch Instructions'.
a) There are no instructions for ' <ConnectionId>
b) There are no instructions for '<VersionForYourEclipse>'.
The page says to see the User Guide, but this is the guide.

I really appreciate everyone's efforts. I hope that I have contributed some value to helping people learn about OSEE. I know I can really use some help.

Ray
Re: Installation Docs [message #634345 is a reply to message #547832] Thu, 21 October 2010 11:01 Go to previous message
Mark D-B is currently offline Mark D-BFriend
Messages: 188
Registered: July 2009
Senior Member
Dear Ray,

Sorry for the late reply - things are very busy for me at the moment.

1)
a) I have not verified that Postgres 8.4.4 works with OSEE but it is very unlikely that it won't - I have three different Postgres versions running with my various Linux and Windows OSEE installs and they all behave the same. Hence, linking to the latest version of Postgres from the instructions makes sense to me.

b) I have added a link to the last version of 3.5

c) Note has been clarified

2)
a) Line removed
b) No it doesn't. It says to go to that site if you are using microdoc. However, there is no explanation of what microdoc is earlier in the text, which is more than a little confusing. I will attempt to address this better when time permits
c) Microdoc does not contain the latest OSEE - this is available from the Download link.

3) Please see the example - this should allow you to work out what you need for your specific set-up


All the best,

Mark
Previous Topic:Problem with document import
Next Topic:installation problem with Osee 0.9.4, eclipse 3.5.2
Goto Forum:
  


Current Time: Fri Dec 19 01:48:17 GMT 2014

Powered by FUDForum. Page generated in 0.01811 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software