Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMP » dependency on xpand 1.0.0
dependency on xpand 1.0.0 [message #537158] Tue, 01 June 2010 13:57 Go to next message
Jean-Paul de Vooght is currently offline Jean-Paul de VooghtFriend
Messages: 20
Registered: April 2010
Junior Member
Howdy!
I tried to upgrade my AMP 0.5.0 to the 0.7.0 but Eclipse complained about a dependency:
Cannot complete the install because one or more required items could not be found.
  Software being installed: AMF IDE Integration and Generation for Escape (Incubation) 0.7.0.v201005280155-17K-9oB5855KBT58KK (org.eclipse.amp.amf.target.escape.feature.group 0.7.0.v201005280155-17K-9oB5855KBT58KK)
  Missing requirement: AMF IDE Support for Code Generation (Incubation) 0.7.0.v201005280155 (org.eclipse.amp.amf.gen.ide 0.7.0.v201005280155) requires 'bundle org.eclipse.xtend 1.0.0' but it could not be found
  Cannot satisfy dependency:
    From: AMF IDE Integration and Generation for Escape (Incubation) 0.7.0.v201005280155-17K-9oB5855KBT58KK (org.eclipse.amp.amf.target.escape.feature.group 0.7.0.v201005280155-17K-9oB5855KBT58KK)
    To: org.eclipse.amp.amf.gen.ide 0.7.0

I had previously installed the xpand SDK but ended up with version 0.7.2

Any easy way around this?

Re: dependency on xpand 1.0.0 [message #537279 is a reply to message #537158] Tue, 01 June 2010 18:38 Go to previous messageGo to next message
Jean-Paul de Vooght is currently offline Jean-Paul de VooghtFriend
Messages: 20
Registered: April 2010
Junior Member
Ok - after trying to figure out some basic AMP modeling, I realized that my AMP upgrade-gone-wrong was introduced weird problems: no wonder since I am running with the Ascape 0.7 generator while everything else stayed back at 0.5

Now I have three options:
1. sort out the upgrade to 0.7 (eclipse does not want to revert to before xpand 0.7.2 install so not sure how I'll fix that)
2. sort out that one package and downgrade back ascape gen to 0.5
3. go take a walk

For everyone's sanity, I'll take 3 for now.

JP
Re: dependency on xpand 1.0.0 [message #537284 is a reply to message #537279] Tue, 01 June 2010 19:17 Go to previous messageGo to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
Jean-Paul de Vooght wrote on Tue, 01 June 2010 14:38

For everyone's sanity, I'll take 3 for now.

JP


Yeah, good choice. The XPand dependency changes have been a bit of a bear on the build side too but they're worth it. One other option:

4. Uninstall everything related to AMP, XPand, XText, MWE. Then reinstall AMP. that should get you just the XPand and XText dependencies you need.

Re: dependency on xpand 1.0.0 [message #538129 is a reply to message #537284] Sat, 05 June 2010 12:55 Go to previous messageGo to next message
Jean-Paul de Vooght is currently offline Jean-Paul de VooghtFriend
Messages: 20
Registered: April 2010
Junior Member
Success. Finally.
In the end I used the Itemis URL for the install manager and was able to install the dependent packages.
I am now on 0.7.0
Dreading the next update...

Back to learning the DSL...
Re: dependency on xpand 1.0.0 [message #538144 is a reply to message #538129] Sat, 05 June 2010 16:56 Go to previous messageGo to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
Jean-Paul de Vooght wrote on Sat, 05 June 2010 08:55
Success. Finally.
In the end I used the Itemis URL for the install manager and was able to install the dependent packages.
I am now on 0.7.0
Dreading the next update...

Back to learning the DSL...


Glad to hear it -- you really shouldn't need the Itemis site as there is only a Design time dependency you should need. Did you have a problem from a fresh install as well, or were you only trying to upgrade an initial installation? In any case, this "shouldn't" happen again as all of the depdencies should be quite stable post Helios. The XText team has been making quite a lot of changes leading up to their final 1.0.0 release. And I'm about to release 0.8.0! Very Happy
Re: dependency on xpand 1.0.0 [message #538187 is a reply to message #538144] Sun, 06 June 2010 08:15 Go to previous messageGo to next message
Jean-Paul de Vooght is currently offline Jean-Paul de VooghtFriend
Messages: 20
Registered: April 2010
Junior Member
Fresh install problems.
I had it at one point working without the itemis site but I had accidentally started from the Eclipse for Java and couldn't quickly get the views right (problems with Ascape, etc.).

So I scrapped everything and re-started from Classic except this time I couldn't get the Xtext/Xpand dependencies right and ended up using itemis...

I am really a total newbie at this Install Manager is disappointing at times.

Here's where I'm at:

Fresh install of Classic (all installs via Install Manager)
Ascape installed OK
AGF 3D installed OK
AMP (all except sources) + Option for Ascape NOK

Cannot complete the install because one or more required items could not be found.
  Software being installed: AMP AMF - Agent Modeling Framework SDK (Incubation) 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO (org.eclipse.amp.amf.feature.group 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO)
  Missing requirement: AMF Code Generator (Incubation) 0.7.0.v201005252336 (org.eclipse.amp.amf.gen 0.7.0.v201005252336) requires 'bundle org.eclipse.xpand 1.0.0' but it could not be found
  Cannot satisfy dependency:
    From: AMP AMF - Agent Modeling Framework SDK (Incubation) 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO (org.eclipse.amp.amf.feature.group 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO)
    To: org.eclipse.amp.amf.gen 0.7.0


So I have to bring in manually all other pieces listed at http://www.eclipse.org/amp/developers/building.php which include

EMF - Eclipse Modeling Framework SDK 2.5
MWE
Xpand SDK
XSD - XML Schema Definition SDK
Xtext SDK
BIRT Framework

That's where I get stuck now as the Install Manager drops the ball on me leaving findinf the right install site URLs to me...

Does this make sense or did I miss a fundamental step?
Thanks for your patience (I realize we're off the core topic here)

[Updated on: Sun, 06 June 2010 12:38]

Report message to a moderator

Re: dependency on xpand 1.0.0 [message #538220 is a reply to message #538187] Sun, 06 June 2010 17:11 Go to previous message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member

Install issues are part of the joy of Eclipse, I'm afraid. To be clear -- it did *not* work for you to simply get a fresh copy of Eclipse, go to the AMP update site and grab the pieces you wanted? You should be able to do that as long as you leave the optional components out -- and if you can't there is a problem with the basic update site that I need to fix.

You know, I'm wondering if there are simply a lot of issues with getting XPand and XText working with Galileo / 3.5 now. Have you tried the Helios release candidate? There is even a discovery tool there so it should find all of the Xpand and Xtext stuff for you. If Galileo still doesn't work -- give that a try?

I'm in the process of building the Early Access release for the Metascape tools. I'm thinking that maybe I should just provide a full build for the AMP tools as well..

Jean-Paul de Vooght wrote on Sun, 06 June 2010 04:15
Fresh install problems.
I had it at one point working without the itemis site but I had accidentally started from the Eclipse for Java and couldn't quickly get the views right (problems with Ascape, etc.).

So I scrapped everything and re-started from Classic except this time I couldn't get the Xtext/Xpand dependencies right and ended up using itemis...

I am really a total newbie at this Install Manager is disappointing at times.

Here's where I'm at:

Fresh install of Classic (all installs via Install Manager)
Ascape installed OK
AGF 3D installed OK
AMP (all except sources) + Option for Ascape NOK

Cannot complete the install because one or more required items could not be found.
  Software being installed: AMP AMF - Agent Modeling Framework SDK (Incubation) 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO (org.eclipse.amp.amf.feature.group 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO)
  Missing requirement: AMF Code Generator (Incubation) 0.7.0.v201005252336 (org.eclipse.amp.amf.gen 0.7.0.v201005252336) requires 'bundle org.eclipse.xpand 1.0.0' but it could not be found
  Cannot satisfy dependency:
    From: AMP AMF - Agent Modeling Framework SDK (Incubation) 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO (org.eclipse.amp.amf.feature.group 0.7.0.v201005252336-17e-BlSTFKz-kQhQVjpLCFFO)
    To: org.eclipse.amp.amf.gen 0.7.0


So I have to bring in manually all other pieces listed at http://www.eclipse.org/amp/developers/building.php which include

EMF - Eclipse Modeling Framework SDK 2.5
MWE
Xpand SDK
XSD - XML Schema Definition SDK
Xtext SDK
BIRT Framework

That's where I get stuck now as the Install Manager drops the ball on me leaving findinf the right install site URLs to me...

Does this make sense or did I miss a fundamental step?
Thanks for your patience (I realize we're off the core topic here)

Previous Topic:prey-predator
Next Topic:Alternative Reporting Mechanism
Goto Forum:
  


Current Time: Thu Dec 18 20:24:56 GMT 2014

Powered by FUDForum. Page generated in 0.01838 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software