Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Migrating from 3.3 to eclipse 3.5
Migrating from 3.3 to eclipse 3.5 [message #537097] Tue, 01 June 2010 10:34 Go to next message
Jack Clouseau is currently offline Jack Clouseau
Messages: 21
Registered: June 2010
Junior Member
Hi All,


Am building an RCP project using ant scripts....

The scripts and everthing works fine if my Target Platform is eclipse 3.3 but the same fails for 3.5.

Am getting the below error even though the the plugin (org.mortbay.jetty_5.1.11.v200706111724.jar) is present in my target eclipse 3.5 ( manually copied this plugin into the plugin folder and reloaded the target platform in the eclipse)....

org.eclipse.pde.build_3.5.2.R35x_20100114\scripts\genericTar gets.xml:106: Bundle org.mortbay.jetty_0.0.0 failed to resolve.:
Unsatisfied import package javax.servlet_[2.4.0,2.5.0).
Unsatisfied import package javax.servlet.http_[2.4.0,2.5.0).
[java] Unsatisfied import package javax.servlet.resources_[2.4.0,2.5.0).


can anyone help me in resolving this issue??? any suggestions is much appreciated...

Thanks
Re: Migrating from 3.3 to eclipse 3.5 [message #537142 is a reply to message #537097] Tue, 01 June 2010 12:56 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

You can't just copy a plugin into your target platform. As your error
message states, it can see the org.mortbay.jetty plugin it just can't
resolve it because *its* dependencies aren't correct (javax.servlet,
javax.servlet.http, javax.servlet.resources)

What in your RCP project depends on jetty directly? A feature or a
plugin? Are you using Import-Package or Require-Bundle (Import-Package
is much more resilient to bundles being split, and the jetty libs
weren't bundles to begin with)?

In this specific case, to move to 3.5 you have to change your RCP app
features and/or plugins to the new configuration
(org.mortbay.jetty.server, org.mortbay.jetty.util). It's not a build
issue. But your RCP app in your workspace against a 3.5 target platform
should have indicated a problem with jetty ... did it not?

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


icon14.gif  Re: Migrating from 3.3 to eclipse 3.5 [message #537888 is a reply to message #537142] Fri, 04 June 2010 05:16 Go to previous message
Jack Clouseau is currently offline Jack Clouseau
Messages: 21
Registered: June 2010
Junior Member
Paul,

Am really sorry for the late reply...but the suggestions that you gave came handy for me...it really worked..

One of the feature in our project was having dependency issues....now i resolved that and its working fine...

Thanks a lot for your inputs Paul....
Previous Topic:why does not these prefs get imported?
Next Topic:Composite's Scrollbar issue
Goto Forum:
  


Current Time: Wed Sep 03 07:01:54 GMT 2014

Powered by FUDForum. Page generated in 0.01722 seconds