Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » iDEN Device problems
iDEN Device problems [message #537015] Mon, 31 May 2010 19:17 Go to next message
Peter is currently offline Peter
Messages: 6
Registered: May 2010
Junior Member
Hi,

I'm currently developing a fairly low level application for iDEN devices running on Sprint. I'm having a couple issues that I find difficult to solve:

Firstly, I've been having trouble getting MTJ to import the iDEN SDK devices. in Ganymede, when it's browsing device directories, it gives a NullPointerException. In Galileo, the search simply comes up blank.

Secondly, I would like to use function calls from both the Motorola API and from the Sprint extensions.

Long story short, I'm looking for a place for me to create my own custom library import list. Possibly making my own device configurations. (not importing them, not duplicating them) Can anybody here Point me towards applicable documentation? Or help me out in any other way?

-Peter
Re: iDEN Device problems [message #537126 is a reply to message #537015] Tue, 01 June 2010 08:21 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 42
Registered: January 2010
Member
hi,

as far as i remeber those SDKs are not UEI compliant. thats why MTJ does not import them directly. it would be necessary to add the support to them on MTJ

right now unfortunately there is noone that is able to do that Sad contributions are welcome from everyone.

anyway, is it possible that you send the version and urls of the sdks? i can at least file a bug about that to see if anyone can work on a contribution

Smile
gep
Re: iDEN Device problems [message #537243 is a reply to message #537015] Tue, 01 June 2010 12:27 Go to previous messageGo to next message
Peter is currently offline Peter
Messages: 6
Registered: May 2010
Junior Member
Thanks for the reply. It's not the one I was hoping for, but it's good to get information.

The SDK's I'm looking at are mostly listed on MotoDev's SDK list. The iDEN SDKs all install as plugins to each other, and are labelled 'iDEN SDK for J2ME (MIDP 2_0)' in my programs list. It looks to be version 1.6.4.

In particular the ones I've been using are:
-i9 SDK
-i680 SDK
-i580 SDK
-i355 SDK

Thanks again for the reply. Where are the bugs kept so I can watch this one?
-Peter
Re: iDEN Device problems [message #538711 is a reply to message #537243] Tue, 08 June 2010 09:16 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 42
Registered: January 2010
Member
here is the bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=316124.

sorry if i wasn't able to give you a good answer Sad i hope that someone is able to work on this contribution. anyway i will find some time to test those SDKs and see how they work with MTJ. but i can't promise to do this fast.


Smile
gep
Re: iDEN Device problems [message #539458 is a reply to message #538711] Thu, 10 June 2010 15:06 Go to previous messageGo to next message
Peter is currently offline Peter
Messages: 6
Registered: May 2010
Junior Member
Thank you for being helpful. I appreciate it.

I will keep an eye on the bug and this thread in case anything happens.

-Peter
Re: iDEN Device problems [message #580677 is a reply to message #537015] Tue, 01 June 2010 08:21 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 42
Registered: January 2010
Member
hi,

as far as i remeber those SDKs are not UEI compliant. thats why MTJ does not import them directly. it would be necessary to add the support to them on MTJ

right now unfortunately there is noone that is able to do that :( contributions are welcome from everyone.

anyway, is it possible that you send the version and urls of the sdks? i can at least file a bug about that to see if anyone can work on a contribution

:)
gep
Re: iDEN Device problems [message #580736 is a reply to message #537015] Tue, 01 June 2010 12:27 Go to previous messageGo to next message
Peter is currently offline Peter
Messages: 6
Registered: May 2010
Junior Member
Thanks for the reply. It's not the one I was hoping for, but it's good to get information.

The SDK's I'm looking at are mostly listed on MotoDev's http://developer.motorola.com/platforms/java/sdks/ The iDEN SDKs all install as plugins to each other, and are labelled 'iDEN SDK for J2ME (MIDP 2_0)' in my programs list. It looks to be version 1.6.4.

In particular the ones I've been using are:
http://developer.motorola.com/docstools/sdks/i9/i9_J2ME_SDK. zip/
http://developer.motorola.com/docstools/sdks/i680/i680_J2ME_ SDK_R01.00.00.exe/
http://developer.motorola.com/docstools/sdks/i580/i580_SDK.z ip/
http://developer.motorola.com/docstools/sdks/i355/i355_SDK.z ip/

Thanks again for the reply. Where are the bugs kept so I can watch this one?
-Peter
Re: iDEN Device problems [message #580789 is a reply to message #580736] Tue, 08 June 2010 09:16 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 42
Registered: January 2010
Member
here is the bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=316124

sorry if i wasn't able to give you a good answer :( i hope that someone is able to work on this contribution. anyway i will find some time to test those SDKs and see how they work with MTJ. but i can't promise to do this fast.


:)
gep
Re: iDEN Device problems [message #580806 is a reply to message #580789] Thu, 10 June 2010 15:06 Go to previous message
Peter is currently offline Peter
Messages: 6
Registered: May 2010
Junior Member
Thank you for being helpful. I appreciate it.

I will keep an eye on the bug and this thread in case anything happens.

-Peter
Previous Topic:Missing features of MIDP 2.X/CLDC API (WTK 3.0)
Next Topic:Problems importing devices from Moto SDK
Goto Forum:
  


Current Time: Fri Aug 29 08:13:50 EDT 2014

Powered by FUDForum. Page generated in 0.01888 seconds