Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Importing Project Fails: Loader Constraint Error
Importing Project Fails: Loader Constraint Error [message #536697] Sun, 30 May 2010 01:20 Go to next message
Andrew  is currently offline Andrew
Messages: 6
Registered: May 2010
Junior Member
I run Eclipse with four plugins installed: EGit, M2Eclipse (the Maven plugin), JDT Weaving, and the Scala plugin. When I try to import a project from Git, I'm getting this error after entering all my repository information and going to the branches screen:
Cannot list the available branches.

Reason:
loader constraint violation: loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) previously initiated loading for a different type with name "com/jcraft/jsch/JScj"


I haven't seen an error like this before, and deleting and reinstalling Eclipse has no effect. I'm running Ubuntu Lucid, and this error occurs on an empty workspace.

Any help diagnosing this problem would be greatly appreciated.
Re: Importing Project Fails: Loader Constraint Error [message #536706 is a reply to message #536697] Sun, 30 May 2010 03:29 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 298
Registered: July 2009
Senior Member
Andrew wrote:

> I run Eclipse with four plugins installed: EGit, M2Eclipse (the Maven
> plugin), JDT Weaving, and the Scala plugin. When I try to import a project
> from Git, I'm getting this error after entering all my repository
> information and going to the branches screen: Cannot list the available
> branches.
>
> Reason:
> loader constraint violation: loader (instance of
> org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) previously
> initiated loading for a different type with name "com/jcraft/jsch/JScj"
>
> I haven't seen an error like this before, and deleting and reinstalling
> Eclipse has no effect. I'm running Ubuntu Lucid, and this error occurs on
> an empty workspace.
>
> Any help diagnosing this problem would be greatly appreciated.

Versions of all included features is *essential* to resolving this kind
of problems.

Is your Eclipse from eclipse.org? If comes with your Linux distribution
you should ask for help there. We have seen problems where they package
things differently.

Anyway. My guess is that the plugins have different constraint on JSch (I
assume... did you *type* that error message?). The constraints can be found
in the MANIFEST.MF files in the various plugins. EGit wants JSch in the
range [0.1.37,0.2.0). Does any one the other features provide and require a
different version?

-- robin
Re: Importing Project Fails: Loader Constraint Error [message #536728 is a reply to message #536697] Sun, 30 May 2010 08:44 Go to previous message
Andrew  is currently offline Andrew
Messages: 6
Registered: May 2010
Junior Member
I was using Eclipse installed from the Ubuntu package repositories. I downloaded a copy from eclipse.org, and the same configuration works flawlessly. Thanks!
I guess I should get some version information from this installation and compare it to Ubuntu's.
Previous Topic:Create a new local remote repository
Next Topic:Importing Project Fails: Loader Constraint Error
Goto Forum:
  


Current Time: Wed Apr 16 20:52:21 EDT 2014

Powered by FUDForum. Page generated in 0.01561 seconds