Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMW » Eclipse 3.4.2 reads XMI 2.1 with errors!
Eclipse 3.4.2 reads XMI 2.1 with errors! [message #536177] Thu, 27 May 2010 10:27 Go to next message
Alexey is currently offline Alexey
Messages: 61
Registered: January 2010
Member
Hello! I use Eclipse 3.4.2 (because its the highest version of Eclipse, which supports AMW).

And as I tried to import an XMI-file of the version 2.1 I got this error:



org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1Diagnos ticWrappedException: org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'http://schema.omg.org/spec/XMI/2.1' not found. (platform:/resource/test/metamodels/plm/PSM_XSDSchema .xmi, 3, 76)

Could someone please advise me, how to "correct" that?

Thanx!

Alexey

[Updated on: Thu, 27 May 2010 11:45]

Report message to a moderator

Re: Eclipse 3.4.2 reads XMI 2.1 with errors! [message #536831 is a reply to message #536177] Mon, 31 May 2010 08:07 Go to previous message
Marcos Didonet Del Fabro is currently offline Marcos Didonet Del Fabro
Messages: 84
Registered: July 2009
Member
Hi alexey,

I think this is a compatibility version of.xmi handled by Eclipse.

You may find more info about that on the EMF-related newsgroups.


Marcos
Previous Topic:XML to Ecore Tranformation needed!
Next Topic:HTTP Status 404" error when starting tomcat
Goto Forum:
  


Current Time: Fri Sep 19 07:53:06 GMT 2014

Powered by FUDForum. Page generated in 0.02812 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software