Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Marketplace Client Project » Cannot find plugin when searching/browsing
Cannot find plugin when searching/browsing [message #535710] Tue, 25 May 2010 11:12 Go to next message
Per Salomonsson is currently offline Per Salomonsson
Messages: 13
Registered: July 2009
Junior Member
To be able to use the Marketplace Client from Eclipse i added p2 metadata to the update site and i also logged into http://marketplace.eclipse.org/ and updated the plugin info with feature ID (several days ago).

Then when trying to install the plugin from the Marketplace Client it was listed in the "Recent" tab, but never showed up when searching for it.
I have tried searching for the strings
QuickImage
nu.psnet.quickimage

On http://marketplace.eclipse.org/ i have listed it with the following info:
Solution Name: QuickImage
Update site: http://psnet.nu/eclipse/updates/
Feature id: nu.psnet.quickimage

Any ideas why it doesn't show up?
Re: Cannot find plugin when searching/browsing [message #535818 is a reply to message #535710] Tue, 25 May 2010 19:18 Go to previous messageGo to next message
Ian Skerrett is currently offline Ian Skerrett
Messages: 198
Registered: July 2009
Senior Member
This looks like a bug. Can you please open a bugzilla entry.

btw, I noticed you selected 'Other Open Source License'. Please specify this in the bug. What license are you using?
Re: Cannot find plugin when searching/browsing [message #535901 is a reply to message #535710] Wed, 26 May 2010 09:39 Go to previous messageGo to next message
Per Salomonsson is currently offline Per Salomonsson
Messages: 13
Registered: July 2009
Junior Member
Ok, will open a bugzilla entry.
It's licensed under CPL 1.0.
Re: Cannot find plugin when searching/browsing [message #535940 is a reply to message #535901] Wed, 26 May 2010 12:37 Go to previous messageGo to next message
Ian Skerrett is currently offline Ian Skerrett
Messages: 198
Registered: July 2009
Senior Member
fyi, not sure if you realize but the OSI has superseded the CPL with the EPL. This means it is no longer an active OSI approved license. You might want to consider updating to use the EPL 1.0.

http://dev.eclipse.org/blogs/mike/2009/04/16/one-small-step- towards-reducing-license-proliferation/

http://opensource.org/licenses/category
Re: Cannot find plugin when searching/browsing [message #535965 is a reply to message #535710] Wed, 26 May 2010 14:08 Go to previous messageGo to next message
Per Salomonsson is currently offline Per Salomonsson
Messages: 13
Registered: July 2009
Junior Member
I changed the license to EPL, seems to make most sence.
I also filed a bug report https://bugs.eclipse.org/bugs/show_bug.cgi?id=314462
Re: Cannot find plugin when searching/browsing [message #536129 is a reply to message #535710] Thu, 27 May 2010 08:11 Go to previous messageGo to next message
Per Salomonsson is currently offline Per Salomonsson
Messages: 13
Registered: July 2009
Junior Member
Now it is possible to search for the plugin. Don't know if something changed or i just had to wait a week?
Although, it is not possible to browse to find it. On the marketplace web page it is tagged with the categories "Graphics", "Editor", "Web". But when using the Eclipse Marketplace client it does not show up when selecting All Markets -> Graphics -> [Go].

How do I make the plugin show up under Graphics?
Re: Cannot find plugin when searching/browsing [message #537709 is a reply to message #536129] Thu, 03 June 2010 12:56 Go to previous messageGo to next message
Nathan Gervais is currently offline Nathan Gervais
Messages: 7
Registered: July 2009
Junior Member
Sorry for the delay in responding, There was an issue with the query performed to return 'Graphics' Type queries. Here's how the that Query is performed.

http://marketplace.eclipse.org/featured/8/api/p is the API call thats being made to Marketplace. It will return 6 nodes ordered by Foundation Membership, after that it will return open source listings, but also randomly.

Currently the 'Graphics' category is returning 2 Member Listings, and then 4 OS listings in a random order.

You listing Quick Image does appear, thanks for the initial report btw.

-ng
Re: Cannot find plugin when searching/browsing [message #569737 is a reply to message #536129] Thu, 03 June 2010 12:56 Go to previous message
Nathan Gervais is currently offline Nathan Gervais
Messages: 7
Registered: July 2009
Junior Member
Sorry for the delay in responding, There was an issue with the query performed to return 'Graphics' Type queries. Here's how the that Query is performed.

http://marketplace.eclipse.org/featured/8/api/p is the API call thats being made to Marketplace. It will return 6 nodes ordered by Foundation Membership, after that it will return open source listings, but also randomly.

Currently the 'Graphics' category is returning 2 Member Listings, and then 4 OS listings in a random order.

You listing Quick Image does appear, thanks for the initial report btw.

-ng
Previous Topic:Cannot find plugin when searching/browsing
Next Topic:Marketplace Server Implementation for RCP
Goto Forum:
  


Current Time: Fri Sep 19 20:05:38 GMT 2014

Powered by FUDForum. Page generated in 0.01971 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software