Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » buckminster headless install
buckminster headless install [message #534413] Wed, 19 May 2010 05:44 Go to next message
Maxi is currently offline MaxiFriend
Messages: 9
Registered: May 2010
Junior Member
Hi all

I have troubles installing buckminster headless.
As I am behind a proxy I cannot install on windows in commandline with following:
director -r http://download.eclipse.org/tools/buckminster/headless-3.5/ -d c:\buckminster_headless -p Buckminster -i org.eclipse.buckminster.cmdline.product


I get the message
19.05.2010 07:38:05 org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection timed out: connect
19.05.2010 07:38:05 org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: Retrying request


How can I fix this problem?

So I have tested another way to install:
I have downloaded the file 'org.eclipse.buckminster.site.eclipse.headless_1.1.350.r1125 2.zip' and install from this file:
director.bat -r file://C:\org.eclipse.buckminster.site.eclipse.headless_1.1.350.r11252 -d c:\buckminster -p Buckminster -i org.eclipse.buckminster.cmdline.product

That was OK
So I tried to install required features. I tried
C:\buckminster>buckminster.bat install file://C:\buckminster_headless\org.eclipse.buckminster.site.eclipse.headless_1.1.350.r11252 org.eclipse.buckminster.core.headless.feature

but there was an error
No suitable feature/version found that matches org.eclipse.buckminster.core.headless.feature.feature.group


Can you help me to install buckminster headless and its required features correctly?
Any ideas?
best regards
Rainer
Re: buckminster headless install [message #534418 is a reply to message #534413] Wed, 19 May 2010 06:18 Go to previous messageGo to next message
Bernhard Merkle is currently offline Bernhard MerkleFriend
Messages: 88
Registered: July 2009
Member
I had the same problem here and tried to specify httpproxy values, but
p2 seems not to pick them up

news://news.eclipse.org:119/hscah4$1n3$1@build.eclipse.org



On 19.05.2010 07:44, rainer123@wolke7.net wrote:
> Hi all
>
> I have troubles installing buckminster headless.
> As I am behind a proxy I cannot install on windows in commandline with
> following:
> director -r http://download.eclipse.org/tools/buckminster/headless-3.5/
> -d c:\buckminster_headless -p Buckminster -i
> org.eclipse.buckminster.cmdline.product
>
> I get the message
> 19.05.2010 07:38:05 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: I/O exception (java.net.ConnectException) caught when processing
> request: Connection timed out: connect
> 19.05.2010 07:38:05 org.apache.commons.httpclient.HttpMethodDirector
> executeWithRetry
> INFO: Retrying request
>
> How can I fix this problem?
>
> So I have tested another way to install:
> I have downloaded the file
> 'org.eclipse.buckminster.site.eclipse.headless_1.1.350.r1125 2.zip' and
> install from this file:
> director.bat -r
> file://C:\org.eclipse.buckminster.site.eclipse.headless_1.1. 350.r11252
> -d c:\buckminster -p Buckminster -i org.eclipse.buckminster.cmdline.product
> That was OK
> So I tried to install required features. I tried
> C:\buckminster>buckminster.bat install
> file://C:\buckminster_headless\org.eclipse.buckminster.site. eclipse.headless_1.1.350.r11252
> org.eclipse.buckminster.core.headless.feature
> but there was an error
> No suitable feature/version found that matches
> org.eclipse.buckminster.core.headless.feature.feature.group
>
> Can you help me to install buckminster headless and its required
> features correctly?
> Any ideas?
> best regards
> Rainer
Re: buckminster headless install [message #657371 is a reply to message #534418] Wed, 02 March 2011 15:15 Go to previous messageGo to next message
Josh Hester is currently offline Josh HesterFriend
Messages: 30
Registered: July 2009
Member
Did anyone ever figure this out? I'm having the same problem and I've done everything I know to specify my proxy settings from passing them in to putting them into org.eclipse.core.net.prefs
Re: buckminster headless install [message #657516 is a reply to message #657371] Thu, 03 March 2011 06:51 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3229
Registered: July 2009
Senior Member
Hi Josh,

IIRC, 3.5 had a problem with this. In 3.6, Buckminster relies on the
platfrom which in turn relies on your environment settings. You should
probably try passing nothing at all and have no
org.eclipse.core.net.prefs. That works well for us when using Bucky
behind a proxy.

HTH,
Thomas Hallgren

On 2011-03-02 16:15, Josh Hester wrote:
> Did anyone ever figure this out? I'm having the same problem and I've
> done everything I know to specify my proxy settings from passing them in
> to putting them into org.eclipse.core.net.prefs
Re: buckminster headless install [message #657624 is a reply to message #657516] Thu, 03 March 2011 13:57 Go to previous messageGo to next message
Matthew Webber is currently offline Matthew WebberFriend
Messages: 198
Registered: December 2010
Senior Member
What I do is apply my proxy settings to the director install. So after unzipping director.zip, I do this in my install script:

# set up the proxy
cat > ${unzip_dir}/director/configuration/.settings/org.eclipse.co re.net.prefs <<'END_OF_CONFIG'
systemProxiesEnabled=false
org.eclipse.core.net.hasMigrated=true
proxyData/HTTPS/port=8080
proxyData/HTTP/host=wwwcache.xxx.com
nonProxiedHosts=trac.xxx.com|localhost|127.0.0.1
proxyData/HTTP/hasAuth=false
proxyData/HTTP/port=8080
eclipse.preferences.version=1
proxyData/HTTPS/hasAuth=false
proxyData/HTTPS/host=wwwcache.xxx.com
END_OF_CONFIG


That's for Linux, obviously, but there should be an equivalent for Windows.

However, given Thomas' advice it looks like this isn't needed.

Matthew Webber
Re: buckminster headless install [message #657747 is a reply to message #657624] Thu, 03 March 2011 20:06 Go to previous messageGo to next message
Josh Hester is currently offline Josh HesterFriend
Messages: 30
Registered: July 2009
Member
Matthew Webber wrote on Thu, 03 March 2011 08:57
What I do is apply my proxy settings to the director install. So after unzipping director.zip, I do this in my install script:

# set up the proxy
cat > ${unzip_dir}/director/configuration/.settings/org.eclipse.co re.net.prefs <<'END_OF_CONFIG'
systemProxiesEnabled=false
org.eclipse.core.net.hasMigrated=true
proxyData/HTTPS/port=8080
proxyData/HTTP/host=wwwcache.xxx.com
nonProxiedHosts=trac.xxx.com|localhost|127.0.0.1
proxyData/HTTP/hasAuth=false
proxyData/HTTP/port=8080
eclipse.preferences.version=1
proxyData/HTTPS/hasAuth=false
proxyData/HTTPS/host=wwwcache.xxx.com
END_OF_CONFIG


That's for Linux, obviously, but there should be an equivalent for Windows.

However, given Thomas' advice it looks like this isn't needed.

Matthew Webber



This worked and helped immensely! Thank you!! I definitely needed to specify this somewhere as the directory was not picking up my environment variables on linux as Thomas suggested.
Re: buckminster headless install [message #718022 is a reply to message #657516] Tue, 23 August 2011 04:06 Go to previous message
Jörn Guy  Süß is currently offline Jörn Guy SüßFriend
Messages: 83
Registered: July 2009
Location: Germany
Member

I am trying this on solaris with 3.6, but no success. Also tried the .settings approach. No success. Which environment variables are mapped?
Previous Topic:Basedir for Feature incorrect
Next Topic:Re: getting shiro with buckminster
Goto Forum:
  


Current Time: Wed Nov 26 00:46:33 GMT 2014

Powered by FUDForum. Page generated in 0.01840 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software