Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » linking problem with extension point(linking problem with extension point)
linking problem with extension point [message #532307] Fri, 07 May 2010 21:05 Go to next message
Laurier  is currently offline Laurier Friend
Messages: 3
Registered: May 2010
Junior Member

I am trying to implement an extension point and am getting the error below left in the .metadata/.log file at runtime. It cannot find the extension point org.csstudio.cls.product.startupmodule.Workbench. When run at a terminal, a ClassNotFound exception comes out.

I created the project as an RCP plugin project but had to add the java nature to the .project file in order to add the src directory and the org.csstudio.cls.product.startupmodule package. The startupmodule package contains the Workbench java class with which I intend to implement the org.csstudio.module.workbench extension point. I thought that it was working for a while because the application runs within the IDE quite well (using the Launch link from the product page) but I just noticed this runtime error which only occurs after exporting.

I backtracked with version control and was able to compare a working export directory structure with a broken one and found that the 'org' directory structure was missing from the broken export. Any version where I specify my own extension point (like so in my plugin.xml)
... (omited working extensions...)
does not execute after exporting and is missing the 'org' directory. What areas might affect the whether the 'org' directory appears in the export? Did steps may I have missed in implementing the extension point?

I tried adding things to the file. I also tried adding '.' and 'src' to the .classpath using "Configure Build Path". My .classpath is pasted below the error message.

From reading other posts I expect the OSGI terminal might be useful here. I'm unfamiliar with it. How might I use it in this case?

Any/all ideas are certainly welcome.

Thank you, I appreciete your help,


!SESSION 2010-05-06 14:20:45.878 -----------------------------------------------
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2010-05-06 14:20:49.622
!MESSAGE Application error
java.lang.Exception: Need exactly one org.csstudio.startup.module.workbench extension point, found 0
at org.csstudio.startup.application.Application.getWorkbenchExt Point(
at org.csstudio.startup.application.Application.startApplicatio n(
at org.csstudio.startup.application.Application.start(Applicati
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework( 559)
at org.eclipse.equinox.launcher.Main.basicRun(

<?xml version="1.0" encoding="UTF-8"?>
<classpathentry kind="src" path="src"/>
<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
Re: linking problem with extension point [message #532999 is a reply to message #532307] Tue, 11 May 2010 19:29 Go to previous message
Laurier  is currently offline Laurier Friend
Messages: 3
Registered: May 2010
Junior Member
Checking the checkbox "Generate metadata repository" in the export wizard solves my problem.

I'm going to read about this option and try to figure out more about why this does what it does and when and why it's required.

Thanks for reading, hopefully this helps.

Previous Topic:Unable to export RCP Application
Next Topic:P2 Feature-based Product Export failing
Goto Forum:

Current Time: Tue Oct 06 20:22:59 GMT 2015

Powered by FUDForum. Page generated in 0.03292 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software