Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Swordfish » Problems with Swordfish Headless Build(Swordfish Headless Build, Eclipse)
Problems with Swordfish Headless Build [message #532160] Fri, 07 May 2010 07:16 Go to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello!

I'm trying to do Headless Build with Eclipse SDK 3.5.2 and Swordfish. Everything wen't ok until I received message "[java] [eclipse.fetch] Could not retrieve feature.xml and/or build.properties: Cannot use javahl nor command line svn client." in the console.

Any idea why this is happening? I think I have everything needed installed in my Eclipse so what is this problem?

Thanks in advance
Jari
Re: Problems with Swordfish Headless Build [message #532165 is a reply to message #532160] Fri, 07 May 2010 07:48 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Hi Jari,

the build by default checks out sources from the Eclipse SVN.
You may run it locally, but for the third parties build you'd need the required orbit projects in your workspace.

If you have that you can call the build with -Dlocal=true.

Then it won't try to fetch sources from the Eclipse SVN.

Otherwise you should have an svn command line client installed and in your path.

Do you want to build Swordfish for Galileo or Helios ?
If you build for Galileo you should also add -Declipse.target.version=galileo

Cheers
Jürgen
Re: Problems with Swordfish Headless Build [message #532446 is a reply to message #532165] Mon, 10 May 2010 02:36 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Thanks for the reply Jürgen.

I tried to run it locally, but something is still wrong, missed a step maybe. I have org.eclipse.swordfish.build, org.eclipse.swordfish.bundles and org.eclipse.swordfish.third-parties.site in my workspace. I run the command "ant -Dlocal=true Dthird.parties=true" from cmd and it is giving error " org.eclipse.swordfish.build\target-third-parties\site\plugin s does not exist."

I also tried to run the third parties build without the -Dlocal=true after I added svn client to Path, but then it is stuck in the phase: [java] fetchElement:
[java] [mkdir] Created dir: ...\workspace_soa\org.eclipse.swordfish.build\tmp\features
[java] [mkdir] Created dir: ...\workspace_soa\org.eclipse.swordfish.build\tmp\plugins

I have followed the instructions from http://wiki.eclipse.org/Swordfish_Documentation:_Creating_He adless_Build.

Did I forget some step or is there some other problems?

Regards
Jari
Re: Problems with Swordfish Headless Build [message #532490 is a reply to message #532446] Mon, 10 May 2010 05:02 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Hi Jari,

as described in the doc, the first thing you have to get to is the build results from the third parties build.

It looks like your command line has network problems. This could be related to missing proxy settings.

Please try to run a svn checkout for a file in a console window. e.g. try
svn co https://dev.eclipse.org/svnroot/soa/org.eclipse.swordfish/tr unk/rt/org.eclipse.swordfish.build/maps .

If that fails, you may have to configure the svn settings for your client.

Cheers
Jürgen
Re: Problems with Swordfish Headless Build [message #532540 is a reply to message #532490] Mon, 10 May 2010 08:32 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello

Thanks for the help so far.

Now I think it is working for the svn, there was some certificate that needed to be accecpted from the CLI in the first time.

But there is still problems, the process stops in:

[get] Error getting http://sop-bp02.servicebackbone.org:8088/tools/orbit/downloa ds/drops/S20100423142122/bundles/com.sun.xml.bind_2.1.12.v20 1003251730.jar to ...

Does this file exist?

Regards
Jari

[Updated on: Mon, 10 May 2010 08:37]

Report message to a moderator

Re: Problems with Swordfish Headless Build [message #532582 is a reply to message #532540] Mon, 10 May 2010 10:02 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Sorry, as we had some problems with timeouts on the Eclipse HTTP server in the past, we cached the orbit bundles on our local build server.
But you can simply replace sop-bp02.servicebackbone.org:8088 by download.eclipse.org and it should work.
Re: Problems with Swordfish Headless Build [message #532731 is a reply to message #532582] Tue, 11 May 2010 01:37 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Ok. These address settings seems to be defined in the org.eclipse.swordfish.build\tmp\fetch_org.eclipse.swordfish. third-parties.feature.xml which is fetched during the third parties build.

Is there some workaround to change that address. Where do I need to change it?

Regards
Jari

Re: Problems with Swordfish Headless Build [message #532755 is a reply to message #532731] Tue, 11 May 2010 03:27 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
No, there is no workaround.

But I simply changed it to the official orbit URL and checked that in now ... hoping that we won't get timeouts now again ...

Cheers
Jürgen
Re: Problems with Swordfish Headless Build [message #532811 is a reply to message #532755] Tue, 11 May 2010 05:46 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Ok. Now the third.partied build went ok. I will continue with the rest of the steps.

Thanks for the help!

Regards
Jari

[Updated on: Tue, 11 May 2010 05:54]

Report message to a moderator

Re: Problems with Swordfish Headless Build [message #532824 is a reply to message #532755] Tue, 11 May 2010 06:13 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
I'm now trying to do the Swordfish Headless Build and noticed the same problem with the address. First of all I did the build without any parameters(-D), is it correct? I just modified that launcher.properties file as in documentation ( http://wiki.eclipse.org/Swordfish_Documentation:_Creating_He adless_Build).

I noticed that fetch_org.eclipse.swordfish.registry.feature.xml and fetch_org.eclipse.swordfish.feature.xml are using also the address http://sop-bp02.servicebackbone.org:8088. Could you replace the address to all places needed?

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #533110 is a reply to message #532824] Wed, 12 May 2010 05:46 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Well, I would suggest that you run all but the 3rd party build locally. ( -Dlocal=true )
Re: Problems with Swordfish Headless Build [message #533190 is a reply to message #532824] Wed, 12 May 2010 10:17 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
.

[Updated on: Wed, 12 May 2010 10:18]

Report message to a moderator

Re: Problems with Swordfish Headless Build [message #533192 is a reply to message #532160] Wed, 12 May 2010 10:19 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Well, I would suggest that you run all but the 3rd party build locally. ( -Dlocal=true )
Re: Problems with Swordfish Headless Build [message #533899 is a reply to message #533192] Mon, 17 May 2010 08:40 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello

I tried to run the Headless Build with -Dlocal=true but come up with errors like:

[java] [eclipse.buildScript] Some inter-plug-in dependencies have not beensatisfied.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.apt.pluggable.core:
[java] [eclipse.buildScript] Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.tool_0.0.0.
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.apt.dispatch_0.0.0.
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.apt.model_0.0.0.
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.apt.util_0.0.0.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.compiler.apt:
[java] [eclipse.buildScript] Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.tool_0.0.0.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.compiler.tool:
[java] [eclipse.buildScript] Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
[java] [eclipse.buildScript] Bundle org.tigris.subversion.subclipse.core:
[java] [eclipse.buildScript] Another singleton version selected: org.tigris.subversion.subclipse.core_1.6.10
[java] [eclipse.buildScript] Bundle org.tigris.subversion.subclipse.ui:
[java] [eclipse.buildScript] Another singleton version selected: org.tigris.subversion.subclipse.ui_1.6.10
[java]
[java] BUILD FAILED
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
build.xml:35: The following error occurred while executing this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
build.xml:91: The following error occurred while executing this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\template
s\headless-build\customTargets.xml:12: The following error occurred while execut
ing this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\template
s\headless-build\allElements.xml:16: The following error occurred while executin
g this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
genericTargets.xml:106: Unable to find feature: org.eclipse.swordfish.build.feat
ure.
[java]
[java] Total time: 4 seconds

BUILD FAILED
C:\Documents and Settings\user\workspace_soa\org.eclipse.swordfish.build\bu
ild.xml:275: The following error occurred while executing this line:
C:\Documents and Settings\user\workspace_soa\org.eclipse.swordfish.build\bu
ild.xml:230: Java returned: 13

Total time: 3 minutes 16 seconds

Everything went well with the third parties build. Is there something wrong with my java version or is it something else?

I'm using:
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)

Thanks and regards
Jari

[Updated on: Mon, 17 May 2010 08:42]

Report message to a moderator

Re: Problems with Swordfish Headless Build [message #534415 is a reply to message #533899] Wed, 19 May 2010 01:55 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Hi Jari,

it might be a problem of path lengths under your winDOS (path > 254 characters).

In such cases you might get pretty surprising errors.

HTH
Jürgen

BTW: As we had massive problems with accessing the orbit again, we had to switch back to our local Tomcat. Sad So in case you check out / update you might have to adapt the orbitBundles.map files in RT / Tooling
Re: Problems with Swordfish Headless Build [message #534703 is a reply to message #534415] Thu, 20 May 2010 00:30 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hi Jürgen,

I modified my PATH and it had no effect on the build, so I think the problem is somewhere else. Any ideas where?

Regards
Jari
Re: Problems with Swordfish Headless Build [message #535024 is a reply to message #534703] Fri, 21 May 2010 02:34 Go to previous messageGo to next message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Maybe I'm missing something obvious... ?!

This looks like the build feature cannot be found:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
genericTargets.xml:106: Unable to find feature: org.eclipse.swordfish.build.feat
ure.

So which projects did you actually check out?
For the remote build, it's enough to check out
rt/org.eclipse.swordfish.build
rt/org.eclipse.swordfish.bundles
third-parties/org.eclipse.swordfish.third-parties.site

But for a local build, you'll need at least the other projects from rt/ to build runtime (and to build tooling locally, you'll need all project in tools/)
The local build will copy your projects to a temp folder before the actual building starts and thus mimic an svn fetch.

Have a look at org.eclipse.swordfish.build/tmp to see which features and bundles have been copied from your checkout area to the build area.

HTH
Jürgen
Re: Problems with Swordfish Headless Build [message #535464 is a reply to message #535024] Sun, 23 May 2010 16:01 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello Jürgen

The problem was infact that I didn't have those needed checkouts from repository (all from rt and tools). Now I'm past that issue but there are still some problems.

In pde.build.internal section my ant build is complaining following now:

[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\genericTargets.xml:106: Unable to find plug-in: org.eclipse.equinox.p2.ql_0.0.0.
Please check the error log for more details.

Where can I found the correct plugin and where to place it? Or is there some workaround to get past this problem?

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #535778 is a reply to message #535464] Tue, 25 May 2010 11:05 Go to previous messageGo to next message
Zsolt Beothy-Elo is currently offline Zsolt Beothy-Elo
Messages: 10
Registered: July 2009
Junior Member
Jari,
I suspect you are using a Galileo Eclipse to build the latest Swordfish sources instead of using Helios. Swordfish is based on P2 functionality that is only available with Helios.

Regards,
Zsolt
Re: Problems with Swordfish Headless Build [message #536046 is a reply to message #535778] Wed, 26 May 2010 14:37 Go to previous messageGo to next message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello Zsolt

That is the case. Could you provide information where to get the correct Helios version? Didn't find it, atleast from SwordFish site.

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #536259 is a reply to message #536046] Thu, 27 May 2010 09:47 Go to previous messageGo to next message
Zsolt Beothy-Elo is currently offline Zsolt Beothy-Elo
Messages: 10
Registered: July 2009
Junior Member
Jari,
this is not related to Swordfish in any way. You just need a Helio Eclipse SDK.
Have a look at the download site of the eclipse project (http://download.eclipse.org/eclipse/downloads/) and choose the latest 3.6 Stream Stable Builds. Currently it is 3.6 RC2. Of course you can also choose one of the Eclipse packages containing the Plugin Development Environment (PDE). Of course I recommend the SOA package Smile To get Helios versions of the packages go to the Eclipse download page (http://www.eclipse.org/downloads/) and then click on the "Development Builds" tab. There you find the latest development versions of the packages, currently RC1.

Regards,
Zsolt
Re: Problems with Swordfish Headless Build [message #537265 is a reply to message #536259] Tue, 01 June 2010 13:46 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello!

I have now tried to do the third.parties build with Helios and struggling again with that one Smile I think there are some timeouts when the build is downloading those svn stuff from download.eclipse.org. Any ideas how to get it working?

Are there any tutorial for Creating Headless Build with Helios or is there are possibility to do it still with Galileo if I check out the old files from somewhere?

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #578856 is a reply to message #532540] Mon, 10 May 2010 10:02 Go to previous message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Sorry, as we had some problems with timeouts on the Eclipse HTTP server in the past, we cached the orbit bundles on our local build server.
But you can simply replace sop-bp02.servicebackbone.org:8088 by download.eclipse.org and it should work.
Re: Problems with Swordfish Headless Build [message #578862 is a reply to message #578856] Tue, 11 May 2010 01:38 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Ok. These address settings seems to be defined in the org.eclipse.swordfish.build\tmp\fetch_org.eclipse.swordfish. third-parties.feature.xml which is fetched during the third parties build.

Is there some workaround to change that address. Where do I need to change it?

Regards
Jari
Re: Problems with Swordfish Headless Build [message #578873 is a reply to message #578862] Tue, 11 May 2010 03:27 Go to previous message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
No, there is no workaround.

But I simply changed it to the official orbit URL and checked that in now ... hoping that we won't get timeouts now again ...

Cheers
Jürgen
Re: Problems with Swordfish Headless Build [message #578901 is a reply to message #578873] Tue, 11 May 2010 05:46 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Ok. Now the third.partied build went ok. I will continues with the rest of the steps.

Thanks for the help!

Regards
Jari
Re: Problems with Swordfish Headless Build [message #578911 is a reply to message #578873] Tue, 11 May 2010 06:13 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
I'm now trying to do the Swordfish Headless Build and noticed the same problem with the address. First of all I did the build without any parameters(-D), is it correct? I just modified that launcher.properties file as in documentation ( http://wiki.eclipse.org/Swordfish_Documentation:_Creating_He adless_Build).

I noticed that fetch_org.eclipse.swordfish.registry.feature.xml and fetch_org.eclipse.swordfish.feature.xml are using also the address http://sop-bp02.servicebackbone.org:8088 Could you replace the address to all places needed?

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #578925 is a reply to message #578911] Wed, 12 May 2010 05:46 Go to previous message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Well, I would suggest that you run all but the 3rd party build locally. ( -Dlocal=true )
Re: Problems with Swordfish Headless Build [message #578946 is a reply to message #578911] Wed, 12 May 2010 10:17 Go to previous message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Hi Jari,

somehow it looks like my last reply was not posted:
I would suggest to only run the 3rd party build remotely.
Otherwise I'd use -Dlocal=true

Cheers
Jürgen
Re: Problems with Swordfish Headless Build [message #578970 is a reply to message #533192] Mon, 17 May 2010 08:40 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello

I tried to run the Headless Build with -Dlocal=true but come up with errors like:

[java] [eclipse.buildScript] Some inter-plug-in dependencies have not beensatisfied.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.apt.pluggable.core:
[java] [eclipse.buildScript] Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.tool_0.0.0.
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.apt.dispatch_0.0.0.
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.apt.model_0.0.0.
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.apt.util_0.0.0.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.compiler.apt:
[java] [eclipse.buildScript] Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
[java] [eclipse.buildScript] Unsatisfied import package org.eclipse.jdt.internal.compiler.tool_0.0.0.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.compiler.tool:
[java] [eclipse.buildScript] Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
[java] [eclipse.buildScript] Bundle org.tigris.subversion.subclipse.core:
[java] [eclipse.buildScript] Another singleton version selected: org.tigris.subversion.subclipse.core_1.6.10
[java] [eclipse.buildScript] Bundle org.tigris.subversion.subclipse.ui:
[java] [eclipse.buildScript] Another singleton version selected: org.tigris.subversion.subclipse.ui_1.6.10
[java]
[java] BUILD FAILED
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
build.xml:35: The following error occurred while executing this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
build.xml:91: The following error occurred while executing this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\template
s\headless-build\customTargets.xml:12: The following error occurred while execut
ing this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\template
s\headless-build\allElements.xml:16: The following error occurred while executin
g this line:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
genericTargets.xml:106: Unable to find feature: org.eclipse.swordfish.build.feat
ure.
[java]
[java] Total time: 4 seconds

BUILD FAILED
C:\Documents and Settings\user\workspace_soa\org.eclipse.swordfish.build\bu
ild.xml:275: The following error occurred while executing this line:
C:\Documents and Settings\user\workspace_soa\org.eclipse.swordfish.build\bu
ild.xml:230: Java returned: 13

Total time: 3 minutes 16 seconds

Everything went well with the third parties build. Is there something wrong with my java version or is it something else?

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #578987 is a reply to message #533899] Wed, 19 May 2010 01:55 Go to previous message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Hi Jari,

it might be a problem of path lengths under your winDOS (path > 254 characters).

In such cases you might get pretty surprising errors.

HTH
Jürgen

BTW: As we had massive problems with accessing the orbit again, we had to switch back to our local Tomcat. :( So in case you check out / update you might have to adapt the orbitBundles.map files in RT / Tooling
Re: Problems with Swordfish Headless Build [message #579002 is a reply to message #578987] Thu, 20 May 2010 00:30 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hi Jürgen,

I modified my PATH and it had no effect on the build, so I think the problem is somewhere else. Any ideas where?

Regards
Jari
Re: Problems with Swordfish Headless Build [message #579016 is a reply to message #579002] Fri, 21 May 2010 02:34 Go to previous message
Jürgen Kindler is currently offline Jürgen Kindler
Messages: 48
Registered: July 2009
Location: Bonn (Germany)
Member
Maybe I'm missing something obvious... ?!

This looks like the build feature cannot be found:
[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\
genericTargets.xml:106: Unable to find feature: org.eclipse.swordfish.build.feat
ure.

So which projects did you actually check out?
For the remote build, it's enough to check out
rt/org.eclipse.swordfish.build
rt/org.eclipse.swordfish.bundles
third-parties/org.eclipse.swordfish.third-parties.site

But for a local build, you'll need at least the other projects from rt/ to build runtime (and to build tooling locally, you'll need all project in tools/)
The local build will copy your projects to a temp folder before the actual building starts and thus mimic an svn fetch.

Have a look at org.eclipse.swordfish.build/tmp to see which features and bundles have been copied from your checkout area to the build area.

HTH
Jürgen
Re: Problems with Swordfish Headless Build [message #579035 is a reply to message #579016] Sun, 23 May 2010 16:01 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello Jürgen

The problem was infact that I didn't have those needed checkouts from repository (all from rt and tools). Now I'm past that issue but there are still some problems.

In pde.build.internal section my ant build is complaining following now:

[java] C:\Documents and Settings\user\workspace_soa\org.eclipse.swordf
ish.build\tmp\eclipse\plugins\org.eclipse.pde.build_3.5.2.R3 5x_20100114\scripts\genericTargets.xml:106: Unable to find plug-in: org.eclipse.equinox.p2.ql_0.0.0.
Please check the error log for more details.

Where can I found the correct plugin and where to place it? Or is there some workaround to get past this problem?

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #579049 is a reply to message #579035] Tue, 25 May 2010 11:05 Go to previous message
Zsolt Beothy-Elo is currently offline Zsolt Beothy-Elo
Messages: 10
Registered: July 2009
Junior Member
Jari,
I suspect you are using a Galileo Eclipse to build the latest Swordfish sources instead of using Helios. Swordfish is based on P2 functionality that is only available with Helios.

Regards,
Zsolt
Re: Problems with Swordfish Headless Build [message #579066 is a reply to message #535778] Wed, 26 May 2010 14:37 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello Zsolt

That is the case. Could you provide information where to get the correct Helios version? Didn't find it, atleast from SwordFish site.

Thanks and regards
Jari
Re: Problems with Swordfish Headless Build [message #579091 is a reply to message #536046] Thu, 27 May 2010 09:47 Go to previous message
Zsolt Beothy-Elo is currently offline Zsolt Beothy-Elo
Messages: 10
Registered: July 2009
Junior Member
Jari,
this is not related to Swordfish in any way. You just need a Helio Eclipse SDK.
Have a look at the download site of the eclipse project (http://download.eclipse.org/eclipse/downloads/) and choose the latest 3.6 Stream Stable Builds. Currently it is 3.6 RC2. Of course you can also choose one of the Eclipse packages containing the Plugin Development Environment (PDE). Of course I recommend the SOA package :) To get Helios versions of the packages go to the Eclipse download page (http://www.eclipse.org/downloads/) and then click on the "Development Builds" tab. There you find the latest development versions of the packages, currently RC1.

Regards,
Zsolt
Re: Problems with Swordfish Headless Build [message #579143 is a reply to message #579091] Tue, 01 June 2010 13:46 Go to previous message
Jari is currently offline Jari
Messages: 22
Registered: May 2010
Junior Member
Hello!

I have now tried to do the third.parties build with Helios and struggling again with that one :) I think there are some timeouts when the build is downloading those svn stuff from download.eclipse.org. Any ideas how to get it working?

Are there any tutorial for Creating Headless Build with Helios or is there are possibility to do it still with Galileo if I check out the old files from somewhere?

Thanks and regards
Jari
Previous Topic:Swordfish FlightBooking demo with BPEL not working
Next Topic:Swordfish and JMS
Goto Forum:
  


Current Time: Wed Jul 30 19:30:24 EDT 2014

Powered by FUDForum. Page generated in 0.03673 seconds