Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Icon in Editor
Icon in Editor [message #532146] Fri, 07 May 2010 10:48 Go to next message
saurav sarkar is currently offline saurav sarkarFriend
Messages: 426
Registered: July 2009
Senior Member
Hi All,

I am stumbling across a strange problem.I have contributed an editor on html extensions.I have assigned an icon to the editor.The strange thing is in the 'Open with' menu action where the editor is not associated with the icon.
Though the icon appears in the editor when opened.


Thanks and Regards,
Saurav
Re: Icon in Editor [message #532513 is a reply to message #532146] Mon, 10 May 2010 11:04 Go to previous message
saurav sarkar is currently offline saurav sarkarFriend
Messages: 426
Registered: July 2009
Senior Member
Ok..silly mistake i did.But would also like to keep little bit of blame on the org.eclipse.ui.editor extension point.

I did debug and yes found out.The editor id has to be following the plug-in and then the editor id.I knew this but somehow forgotten.

In my view the editor id must be generated with the plug-in namespace.
@Platform/UI experts: Please comment on this.

cheers,
Saurav
Previous Topic:launching an xsl transformation which uses extension functions
Next Topic:method type inference -- jsdoc @type annotation is not used?
Goto Forum:
  


Current Time: Mon Sep 26 07:19:37 GMT 2016

Powered by FUDForum. Page generated in 0.01888 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software