Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » User region and springframework upgrades
User region and springframework upgrades [message #531900] Thu, 06 May 2010 13:51 Go to next message
Dmitry Sklyut is currently offline Dmitry SklyutFriend
Messages: 276
Registered: January 2010
Senior Member
Breaking up server into a kernel and user region allows user region to independently update version of springframework.

Should there be some documentation available or validation done before starting user region that checks on the maximum supported version of springframework?

Currently the only fool proof way to check the max version of support for user region that I know of is to look in the manifest of com.springsource.kernel.dmfragment
....
org.springframework.beans.factory;version="[2.5.6
 ,3.1)",org.springframework.beans.factory.config;version="[2.5.6,3.1)"
 ,org.springframework.beans.factory.support;version="[2.5.6,3.1)",org.
 springframework.context;version="[2.5.6,3.1)",org.springframework.con
 text.event;version="[2.5.6,3.1)",org.springframework.instrument.class
 loading;version="[2.5.6,3.1)",org.springframework.jmx.export;version=
 "[2.5.6,3.1)"
....


Am I missing something? Shouldn't version range of dm extender fragment match dm extender version range that is
[2.5.6, 4.0.0)
?

Regards,

Dmitry
Re: User region and springframework upgrades [message #531906 is a reply to message #531900] Thu, 06 May 2010 13:59 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Virgo is more conservative than Spring DM. We assume that backward incompatibilities may be introduced by Spring 3.1 whereas Spring DM assumes sufficient backward compatibility right up until Spring 4!

Your point about the version of Spring being unchecked is interesting. Of course there will be some resolution failures which will give a pretty strong hint, but there is no simple event log messages which says "Your version of Spring is too high". I suppose a check could be added during user region initialisation. Please file a bug if you would like to see that.

At some stage, we are going to be looking for people to fix some of these bugs. Wink
Re: User region and springframework upgrades [message #531946 is a reply to message #531906] Thu, 06 May 2010 14:57 Go to previous message
Dmitry Sklyut is currently offline Dmitry SklyutFriend
Messages: 276
Registered: January 2010
Senior Member
Bugzilla: 311900

I think in short term a version matrix should be enough.

But the burden is on you to commit the code so we can start looking at it Smile . With change in packaging it would be much harder to try to address it in both places (dm-server and virgo code base)
Previous Topic:Speeding up resolution and server start up
Next Topic:Re: User region and springframework upgrades
Goto Forum:
  


Current Time: Sun Nov 23 07:36:06 GMT 2014

Powered by FUDForum. Page generated in 0.01711 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software