Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » unmet dependencies on installing PDT [SOLVED](Error on installing PDT )
unmet dependencies on installing PDT [SOLVED] [message #531888] Thu, 06 May 2010 13:26 Go to next message
p cooper is currently offline p cooper
Messages: 6
Registered: May 2010
Junior Member
Ubuntu 10.04 ( recent upgrade to lucid)
I can install exclipse (3.5.2) from the Ubuntu repository , but when I try to add PDT according to
http://wiki.eclipse.org/PDT/Installation#From_Update_Site

it tells me this :

Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) Runtime Feature 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ (org.eclipse.php.feature.group 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ)
Missing requirement: Dynamic Languages Toolkit - Core Frameworks 2.0.0.v20100505-1154-7L--EAAoOUVSNc7Bb2w0 (org.eclipse.dltk.core.feature.group 2.0.0.v20100505-1154-7L--EAAoOUVSNc7Bb2w0) requires 'org.eclipse.emf.ecore.feature.group 2.4.0' but it could not be found
Cannot satisfy dependency:
From: PHP Development Tools (PDT) Runtime Feature 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ (org.eclipse.php.feature.group 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ)
To: org.eclipse.dltk.core.feature.group [2.0.0,3.0.0)

What am I missing ?

[Updated on: Sat, 08 May 2010 11:09]

Report message to a moderator

Re: unmet dependencies on installing PDT [message #532034 is a reply to message #531888] Thu, 06 May 2010 20:22 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
"p cooper" <paul@medalto.co.uk> wrote in message
news:hrug31$82b$1@build.eclipse.org...
> Ubuntu 10.04 ( recent upgrade to lucid) I can install exclipse (3.5.2)
> from the Ubuntu repository , but when I try to add PDT according to
> http://wiki.eclipse.org/PDT/Installation#From_Update_Site
>
> it tells me this :
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: PHP Development Tools (PDT) Runtime Feature
> 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ (org.eclipse.php.feature.group
> 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ)
> Missing requirement: Dynamic Languages Toolkit - Core Frameworks
> 2.0.0.v20100505-1154-7L--EAAoOUVSNc7Bb2w0
> (org.eclipse.dltk.core.feature.group
> 2.0.0.v20100505-1154-7L--EAAoOUVSNc7Bb2w0) requires
> 'org.eclipse.emf.ecore.feature.group 2.4.0' but it could not be found
> Cannot satisfy dependency:
> From: PHP Development Tools (PDT) Runtime Feature
> 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ (org.eclipse.php.feature.group
> 2.2.0.v201004270700-7L7J-F8NcJTJJwdOKOJJ)
> To: org.eclipse.dltk.core.feature.group [2.0.0,3.0.0)
>
> What am I missing ?

My guess is that the Ubuntu repository version of Eclipse doesn't have the
default update sites setup. This prevents the required plugins from being
found.

My suggestion would be to remove the Eclipse that you installed from Ubuntu
and download Eclipse from the eclipse.org site. Setting up Eclipse to run
is little more than extracting the tar file, pointing to a Sun JDK and
running eclipse.
Re: unmet dependencies on installing PDT [message #532125 is a reply to message #531888] Fri, 07 May 2010 09:12 Go to previous messageGo to next message
p cooper is currently offline p cooper
Messages: 6
Registered: May 2010
Junior Member
ive got the sun jdk

$ sudo aptitude show sun-java6-jdk
Package: sun-java6-jdk
State: installed
Automatically installed: no
Version: 6.20dlj-1ubuntu3
Priority: optional
Section: java
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Uncompressed Size: 62.5M
Depends: sun-java6-bin (>= 6.20dlj-1ubuntu3), libc6, libx11-6
PreDepends: debconf (>= 0.5) | debconf-2.0
Suggests: sun-java6-demo, openjdk-6-doc, sun-java6-source
Provides: java-compiler, java-sdk, java2-compiler, java2-sdk, java5-sdk, java6-sdk
Description: Sun Java(TM) Development Kit (JDK) 6
The JDK(TM) is a development environment for building applications, applets, and components using the Java programming language.

The JDK includes tools useful for developing and testing programs written in the Java programming language and running on the Java Platform.

NOTE: You must accept Sun's EULA prior to successfully installing this package

paul@zimmy-desktop:/usr/lib/jvm/java-6-sun-1.6.0.20/bin$

and configured eclipse.ini

-startup
plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715. jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.20 0.v20090519
-product
org.eclipse.epp.package.php.product
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vm
/usr/lib/jvm/java-6-sun-1.6.0.20/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx256m
/home/paul/eclipse/eclipse.ini
and its here

paul@zimmy-desktop:/$ ls /usr/lib/jvm/java-6-sun-1.6.0.20/bin/
appletviewer HtmlConverter jarsigner javah jconsole jinfo jsadebugd jvisualvm pack200 rmiregistry tnameserv xjc
apt i386 java javap jcontrol jmap jstack keytool policytool schemagen unpack200
ControlPanel idlj javac java-rmi.cgi jdb jps jstat native2ascii rmic serialver wsgen
extcheck jar javadoc javaws jhat jrunscript jstatd orbd rmid servertool wsimport
paul@zimmy-desktop:/$


and get this

paul@zimmy-desktop:~/eclipse$ java eclipse -vm /usr/lib/jvm/java-6-sun-1.6.0.20/bin/java
Exception in thread "main" java.lang.NoClassDefFoundError: eclipse
Caused by: java.lang.ClassNotFoundException: eclipse
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294 )
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334 )
Could not find the main class: eclipse. Program will exit.
paul@zimmy-desktop:~/eclipse$
thanks f or any pointers

Re: unmet dependencies on installing PDT [message #532252 is a reply to message #532125] Fri, 07 May 2010 16:53 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
"p cooper" <paul@medalto.co.uk> wrote in message
news:hs0lij$ajv$1@build.eclipse.org...
> ive got the sun jdk
> $ sudo aptitude show sun-java6-jdk
> Package: sun-java6-jdk
> State: installed
> Automatically installed: no
> Version: 6.20dlj-1ubuntu3
> Priority: optional
> Section: java
> Maintainer: Debian Java Maintainers
> <mailto:pkg-java-maintainers@lists.alioth.debian.org>
> Uncompressed Size: 62.5M
> Depends: sun-java6-bin (>= 6.20dlj-1ubuntu3), libc6, libx11-6
> PreDepends: debconf (>= 0.5) | debconf-2.0
> Suggests: sun-java6-demo, openjdk-6-doc, sun-java6-source
> Provides: java-compiler, java-sdk, java2-compiler, java2-sdk, java5-sdk,
> java6-sdk
> Description: Sun Java(TM) Development Kit (JDK) 6
> The JDK(TM) is a development environment for building applications,
> applets, and components using the Java programming language.
> The JDK includes tools useful for developing and testing programs written
> in the Java programming language and running on the Java Platform.
> NOTE: You must accept Sun's EULA prior to successfully installing this
> package
>
> mailto:paul@zimmy-desktop:/usr/lib/jvm/java-6-sun-1.6.0.20/bin$
> and configured eclipse.ini
>
> -startup
> plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715. jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.20 0.v20090519
> -product
> org.eclipse.epp.package.php.product
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vm
> /usr/lib/jvm/java-6-sun-1.6.0.20/bin/java
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -XX:MaxPermSize=256m
> -Xms40m
> -Xmx256m
> /home/paul/eclipse/eclipse.ini and its here
> mailto:paul@zimmy-desktop:/$ ls /usr/lib/jvm/java-6-sun-1.6.0.20/bin/
> appletviewer HtmlConverter jarsigner javah jconsole jinfo
> jsadebugd jvisualvm pack200 rmiregistry tnameserv xjc
> apt i386 java javap jcontrol jmap
> jstack keytool policytool schemagen unpack200
> ControlPanel idlj javac java-rmi.cgi jdb jps
> jstat native2ascii rmic serialver wsgen
> extcheck jar javadoc javaws jhat jrunscript
> jstatd orbd rmid servertool wsimport
> mailto:paul@zimmy-desktop:/$
>
> and get this
> mailto:paul@zimmy-desktop:~/eclipse$ java eclipse -vm
> /usr/lib/jvm/java-6-sun-1.6.0.20/bin/java
> Exception in thread "main" java.lang.NoClassDefFoundError: eclipse
> Caused by: java.lang.ClassNotFoundException: eclipse
> at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294 )
> at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
> at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334 )
> Could not find the main class: eclipse. Program will exit.
> mailto:paul@zimmy-desktop:~/eclipse$ thanks f or any pointers
>

You don't want to run 'java eclipse ...' To launch Eclipse, you run the
eclipse executable. It should be in the root directory where you extracted
the Eclipse tar file. Change directory this directory and run eclipse.

cd {Directory were Eclipse extracted}
eclipse (run this if '.' is in your path)
../eclipse (run this if '.' isn't in your path)
Re: unmet dependencies on installing PDT [message #532274 is a reply to message #532252] Fri, 07 May 2010 18:26 Go to previous messageGo to next message
p cooper is currently offline p cooper
Messages: 6
Registered: May 2010
Junior Member
thats what i thought

paul@zimmy-desktop:/$ /home/paul/eclipse/eclipse
bash: /home/paul/eclipse/eclipse: cannot execute binary file
paul@zimmy-desktop:/$ cd /home/paul/eclipse/
paul@zimmy-desktop:~/eclipse$ ls -la | grep eclips
-rwxr-xr-x 1 paul paul 68333 2009-05-19 23:04 eclipse
-rw-rw-r-- 1 paul paul 395 2010-05-07 09:43 eclipse.ini
-rw-rw-r-- 1 paul paul 59 2008-12-10 22:05 .eclipseproduct
paul@zimmy-desktop:~/eclipse$ chmod 755 eclipse
paul@zimmy-desktop:~/eclipse$ /home/paul/eclipse/eclipse
bash: /home/paul/eclipse/eclipse: cannot execute binary file
paul@zimmy-desktop:~/eclipse$ ls -la | grep ecl
-rwxr-xr-x 1 paul paul 68333 2009-05-19 23:04 eclipse
-rw-rw-r-- 1 paul paul 395 2010-05-07 09:43 eclipse.ini
-rw-rw-r-- 1 paul paul 59 2008-12-10 22:05 .eclipseproduct
paul@zimmy-desktop:~/eclipse$ ./eclipse
bash: ./eclipse: cannot execute binary file
paul@zimmy-desktop:~/eclipse$
Re: unmet dependencies on installing PDT [message #532305 is a reply to message #532274] Fri, 07 May 2010 20:53 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
"p cooper" <paul@medalto.co.uk> wrote in message
news:hs1m01$hc6$1@build.eclipse.org...
> thats what i thought
> mailto:paul@zimmy-desktop:/$ /home/paul/eclipse/eclipse bash:
> /home/paul/eclipse/eclipse: cannot execute binary file
> mailto:paul@zimmy-desktop:/$ cd /home/paul/eclipse/
> mailto:paul@zimmy-desktop:~/eclipse$ ls -la | grep eclips
> -rwxr-xr-x 1 paul paul 68333 2009-05-19 23:04 eclipse
> -rw-rw-r-- 1 paul paul 395 2010-05-07 09:43 eclipse.ini
> -rw-rw-r-- 1 paul paul 59 2008-12-10 22:05 .eclipseproduct
> mailto:paul@zimmy-desktop:~/eclipse$ chmod 755 eclipse
> mailto:paul@zimmy-desktop:~/eclipse$ /home/paul/eclipse/eclipse bash:
> /home/paul/eclipse/eclipse: cannot execute binary file
> mailto:paul@zimmy-desktop:~/eclipse$ ls -la | grep ecl
> -rwxr-xr-x 1 paul paul 68333 2009-05-19 23:04 eclipse
> -rw-rw-r-- 1 paul paul 395 2010-05-07 09:43 eclipse.ini
> -rw-rw-r-- 1 paul paul 59 2008-12-10 22:05 .eclipseproduct
> mailto:paul@zimmy-desktop:~/eclipse$ ./eclipse bash: ./eclipse: cannot
> execute binary file
> mailto:paul@zimmy-desktop:~/eclipse$

Are you running a 32 or 64 bit version of Linux. If you are running 32, did
you download the 64 bit version of Eclipse?
Re: unmet dependencies on installing PDT [message #532332 is a reply to message #532305] Sat, 08 May 2010 11:09 Go to previous message
p cooper is currently offline p cooper
Messages: 6
Registered: May 2010
Junior Member
oops Embarrassed
Previous Topic:My plugin TextEditor is never created
Next Topic:Exception starting certain eclipse bundles
Goto Forum:
  


Current Time: Wed Sep 17 09:36:44 GMT 2014

Powered by FUDForum. Page generated in 0.01779 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software