Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » PDE Build version problem(I use eclipse PDE to build a set of plugins. I get a InvocationTargetException while executing the code)
PDE Build version problem [message #531609] Wed, 05 May 2010 14:43
Hariharan L Narayanan is currently offline Hariharan L Narayanan
Messages: 2
Registered: July 2009
Junior Member
I have a few plugins in my cvs and I have removed the version dependency for those plugins. ie if my plugin name is com.foo and it is dependent on com.foo1, the Manifest.MF of com.foo will contain

Require-Bundle: com.foo1
and no bundle-version dependency will be specified on the com.foo1 plugin.

but once it is in the build the Manifest gets changed to

Require-Bundle: com.foo1;bundle-version="[1.0.0, 2.0.0)"
which gives an exception in the runtime when i invoke the code.

the exception is

Caused by: org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: com.foo1; bundle-version="[1.0.0, 2.0.0)"

So is there any way to restrict the PDE from adding the version dependency in the Manifest files? Or is there any other solution to this problem?

Please help. Awaiting a response ASAP. Thanks in advance
Previous Topic:How to Setup Client Dev Environment for FileNet P8 4.x with JBoss and Eclipse
Next Topic:Tutorial for creating custom "Run Configuration"
Goto Forum:
  


Current Time: Fri Sep 19 05:51:15 GMT 2014

Powered by FUDForum. Page generated in 0.05121 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software