Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Not including root files in plug-ins
Not including root files in plug-ins [message #530776] Fri, 30 April 2010 19:36
No real name is currently offline No real nameFriend
Messages: 2
Registered: April 2010
Junior Member
Hello, I have searched high and low and there is very little on Google about this, so I figured I'd ask.

I looked at the documentation for adding root files here:

http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .pde.doc.user/tasks/pde_rootfiles.htm

I have a plug-in project so I followed these steps:

Quote:
Add a build.properties file containing absolute root properties to the automatically generated container feature:

${buildDirectory}/build.properties: generatedBuildProperties = ${buildDirectory}/root.properties
${buildDirectory/root.properties: root = absolute:${buildDirectory}/rootfiles
${buildDirectory}/rootfiles/*



So my plug-in project now has a build.properties file in its root that looks like this:

generatedBuildProperties = root.properties


And I have another file called root.properties in the same directory that contains this:

root = html/


(Yes the HTML directory exists in my projects root as well.) Now I go to my .product file and click on the "Eclipse Product export wizard" link and sure I get a package that works, but my html directory is NOT there.

Can anyone tell me what I have done wrong? Thank you for your help.

[Updated on: Fri, 30 April 2010 19:37]

Report message to a moderator

Previous Topic:building a custom eclipse product
Next Topic:Not including root files in plug-ins
Goto Forum:
  


Current Time: Sat Dec 20 21:02:11 GMT 2014

Powered by FUDForum. Page generated in 0.01575 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software