Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » [Mediawiki] Errors with mediawiki-to-eclipse-help (FileNotFoundException while working with MediaWiki Templates )
[Mediawiki] Errors with mediawiki-to-eclipse-help [message #530136] Wed, 28 April 2010 15:43 Go to next message
Nicolas Guyomar is currently offline Nicolas GuyomarFriend
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi,

I'm getting the following error for each templates on our wiki pages using template, like : http://wiki.eclipse.org/MoDisco/Components/ModelBrowser
( the tabItems : Overview, Documentation 0.7, 0.8 ... )

[mediawiki-to-eclipse-help] 28 avr. 2010 17:32:55 org.eclipse.mylyn.internal.wikitext.mediawiki.core.WikiTemplateResolver resolveTemplate
[mediawiki-to-eclipse-help] ATTENTION: Cannot read from http://wiki.eclipse.org/index.php?title=Template%3Amodiscojavatabs&action=raw: http://wiki.eclipse.org/index.php?title=Template%3Amodiscojavatabs&action=raw
[mediawiki-to-eclipse-help] java.io.FileNotFoundException: http://wiki.eclipse.org/index.php?title=Template%3Amodiscojavatabs&action=raw
[mediawiki-to-eclipse-help] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

and so on ....


This error is not a problem for my help content generation, but quite annoying because it fills the log file.

I had a quick look on the Eclipse wiki, it seems like not a lot a projects are using those templates.

Could it be ignore ? I insist on the fact that the help content is very well generated.

Regards

Nicolas


Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #530250 is a reply to message #530136] Thu, 29 April 2010 05:49 Go to previous messageGo to next message
David Green is currently offline David GreenFriend
Messages: 135
Registered: July 2009
Senior Member
On 10-04-28 8:43 AM, Nicolas Guyomar wrote:
> Hi,
>
> I'm getting the following error for each templates on our wiki pages
> using template, like :
> http://wiki.eclipse.org/MoDisco/Components/ModelBrowser
> ( the tabItems : Overview, Documentation 0.7, 0.8 ... )
>
>
> [mediawiki-to-eclipse-help] 28 avr. 2010 17:32:55
> org.eclipse.mylyn.internal.wikitext.mediawiki.core.WikiTempl ateResolver
> resolveTemplate
> [mediawiki-to-eclipse-help] ATTENTION: Cannot read from
> http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw:
> http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw
>
> [mediawiki-to-eclipse-help] java.io.FileNotFoundException:
> http://wiki.eclipse.org/index.php?title=Template%3Amodiscoja vatabs&action=raw
>
> [mediawiki-to-eclipse-help] at
> sun.net.www.protocol.http.HttpURLConnection.getInputStream(U nknown Source)
>
> and so on ....
>
>
> This error is not a problem for my help content generation, but quite
> annoying because it fills the log file.

You can exclude template content by adding the following to your Ant build script:

<mediawiki-to-eclipse-help
templateExcludes="*modiscojavatabs*"

Templates that are excluded using this mechanism produce no output. From the documentation:

Indicate MediaWiki template names to exclude. A comma-delimited list of names, may include ‘*’ wildcards. Defaults to
null. Example: bug, navigationHeader

Please let me know if that works for you.

Regards,

David

> I had a quick look on the Eclipse wiki, it seems like not a lot a
> projects are using those templates.
>
> Could it be ignore ? I insist on the fact that the help content is very
> well generated.
>
> Regards
>
> Nicolas
Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #530271 is a reply to message #530250] Thu, 29 April 2010 07:42 Go to previous messageGo to next message
Nicolas Guyomar is currently offline Nicolas GuyomarFriend
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi David

Thank you for your answer.

I didn't know this (new ?) option, I'm glad it exists.

Unfortunately I tried different ways of using it but I still got the same exception
I tried to indicate the 4 templates we have, as well as only the "modiscojavatabs", with and without stars (*)
Case sensitivity for template's name doesn't solve the problem either

<mediawiki-to-eclipse-help templateExcludes=" *modiscojavatabs*"

<mediawiki-to-eclipse-help templateExcludes="*modiscoinfobox* , *modiscojavatabs* , *modiscotab* , *modiscotabs*"

I'm using your latest weekly build 1.3.0.I20100427-0000-e3x

Regards,

Nicolas


Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #530470 is a reply to message #530271] Thu, 29 April 2010 17:48 Go to previous messageGo to next message
David Green is currently offline David GreenFriend
Messages: 135
Registered: July 2009
Senior Member
Nicolas,

On 10-04-29 12:42 AM, Nicolas Guyomar wrote:
> Hi David
>
> Thank you for your answer.
>
> I didn't know this (new ?) option, I'm glad it exists.
>
> Unfortunately I tried different ways of using it but I still got the
> same exception
> I tried to indicate the 4 templates we have, as well as only the
> "modiscojavatabs", with and without stars (*)
> Case sensitivity for template's name doesn't solve the problem either

Please file a bug and on the bug if possible either attach your Ant build script or point to the source repository.
When you've done that, I'll look into the issue.

>
> <mediawiki-to-eclipse-help templateExcludes=" *modiscojavatabs*"
>
>
> <mediawiki-to-eclipse-help templateExcludes="*modiscoinfobox* ,
> *modiscojavatabs* , *modiscotab* , *modiscotabs*"
>
> I'm using your latest weekly build 1.3.0.I20100427-0000-e3x
>
> Regards,
> Nicolas
>
Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #533859 is a reply to message #530470] Mon, 17 May 2010 10:02 Go to previous message
Nicolas Guyomar is currently offline Nicolas GuyomarFriend
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi,

For the record, this thread was resolved in bug 311132 :
https://bugs.eclipse.org/bugs/show_bug.cgi?id=311132

Thanks again

Regards

Nicolas


Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #601311 is a reply to message #530250] Thu, 29 April 2010 07:42 Go to previous message
Nicolas Guyomar is currently offline Nicolas GuyomarFriend
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi David

Thank you for your answer.

I didn't know this (new ?) option, I'm glad it exists.

Unfortunately I tried different ways of using it but I still got the same exception
I tried to indicate the 4 templates we have, as well as only the "modiscojavatabs", with and without stars (*)
Case sensitivity for template's name doesn't solve the problem either


<mediawiki-to-eclipse-help templateExcludes=" *modiscojavatabs*"


<mediawiki-to-eclipse-help templateExcludes="*modiscoinfobox* , *modiscojavatabs* , *modiscotab* , *modiscotabs*"

I'm using your latest weekly build 1.3.0.I20100427-0000-e3x

Regards,

Nicolas


Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #601324 is a reply to message #530271] Thu, 29 April 2010 17:48 Go to previous message
David Green is currently offline David GreenFriend
Messages: 96
Registered: July 2009
Member
Nicolas,

On 10-04-29 12:42 AM, Nicolas Guyomar wrote:
> Hi David
>
> Thank you for your answer.
>
> I didn't know this (new ?) option, I'm glad it exists.
>
> Unfortunately I tried different ways of using it but I still got the
> same exception
> I tried to indicate the 4 templates we have, as well as only the
> "modiscojavatabs", with and without stars (*)
> Case sensitivity for template's name doesn't solve the problem either

Please file a bug and on the bug if possible either attach your Ant build script or point to the source repository.
When you've done that, I'll look into the issue.

>
> <mediawiki-to-eclipse-help templateExcludes=" *modiscojavatabs*"
>
>
> <mediawiki-to-eclipse-help templateExcludes="*modiscoinfobox* ,
> *modiscojavatabs* , *modiscotab* , *modiscotabs*"
>
> I'm using your latest weekly build 1.3.0.I20100427-0000-e3x
>
> Regards,
> Nicolas
>
Re: [Mediawiki] Errors with mediawiki-to-eclipse-help [message #601409 is a reply to message #530470] Mon, 17 May 2010 10:02 Go to previous message
Nicolas Guyomar is currently offline Nicolas GuyomarFriend
Messages: 29
Registered: February 2010
Location: Nantes (France)
Junior Member
Hi,

For the record, this thread was resolved in bug 311132 :
https://bugs.eclipse.org/bugs/show_bug.cgi?id=311132

Thanks again

Regards

Nicolas


Previous Topic:Trac Connector update failure
Next Topic:Trac Connector update failure
Goto Forum:
  


Current Time: Fri Nov 28 00:49:56 GMT 2014

Powered by FUDForum. Page generated in 0.02109 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software