Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Egit failing to install for Eclipse 3.4.2 (Dependency requirements fail)
icon4.gif  Egit failing to install for Eclipse 3.4.2 [message #529972] Tue, 27 April 2010 16:55 Go to next message
Jeff  is currently offline Jeff
Messages: 2
Registered: April 2010
Junior Member
When using the Software Updates manager to install the Egit plugin (0.8.0) on Eclipse 3.4.2 for windows I get dependency errors. I'm not sure what the problem is... any suggestions?

Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/com.jcraft.jsch/[0.1.41,1.0.0)
Unsatisfied dependency: [org.eclipse.jgit 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Unsatisfied dependency: [org.eclipse.jgit 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Cannot find a solution where both "com.jcraft.jsch [0.1.41,1.0.0)" and "com.jcraft.jsch [0.1.37.v200803061811]" are satisfied.
Unsatisfied dependency: [org.eclipse.jgit 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revwalk/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.dircache/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.util/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.lib/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.transport/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.errors/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.core 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk.filter/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/com.jcraft.jsch/[0.1.41,1.0.0)
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.egit.core/0.0.0
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.egit.ui/0.0.0
Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jgit.feature.group/[0. 7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.errors/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.diff/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.patch/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.internal.storage/[0.7.1,0 .8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/com.jcraft.jsch/[0.1.41,0.2.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revwalk/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revwalk.filter/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.merge/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.transport/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.revplot/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.lib/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.project/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.util/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.op/[0.7.1,0.8.0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.treewalk.filter/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.fnmatch/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.egit.core.internal.util/[0.7.1,0.8. 0)
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.util.io/0.6.0
Unsatisfied dependency: [org.eclipse.egit.ui 0.7.1] requiredCapability: java.package/org.eclipse.jgit.dircache/0.6.0
Unsatisfied dependency: [org.eclipse.jgit.feature.group 0.7.1] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jgit/0.0.0
Re: Egit failing to install for Eclipse 3.4.2 [message #530183 is a reply to message #529972] Wed, 28 April 2010 14:29 Go to previous message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 319
Registered: July 2009
Senior Member
Jeff wrote:

> When using the Software Updates manager to install the Egit plugin
> (0.8.0) on Eclipse 3.4.2 for windows I get dependency errors. I'm not
> sure what the problem is... any suggestions?
>
> Cannot complete the request. See the details.
> Unsatisfied dependency: [org.eclipse.egit.feature.group 0.7.1]
> requiredCapability:

As this messages says, this is an error from trying to install 0.7.1
not 0.8.something.

-- robin
Previous Topic:Missing dependency on JSch when installing EGit on 3.5.2
Next Topic:EGit Download
Goto Forum:
  


Current Time: Mon Sep 01 22:03:25 EDT 2014

Powered by FUDForum. Page generated in 0.01602 seconds