Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Tomcat-6.0.26 initiation fails via Eclipse-jee-galileo-SR2-win32
icon5.gif  Tomcat-6.0.26 initiation fails via Eclipse-jee-galileo-SR2-win32 [message #529713] Mon, 26 April 2010 17:37 Go to next message
Oğuz Çavlı is currently offline Oğuz Çavlı
Messages: 4
Registered: April 2010
Junior Member
Hi,

I am not able to initiate Tomcat via Eclipse.
I am on
* Windows 7 64 bit
* Apache-tomcat-6.0.26
* jdk1.6.0_20
* Eclipse-jee-galileo-SR2-win32

I am able to launch Tomcat via C:\apache-tomcat-6.0.26\bin\start batch file. I can see the default Tomcat welcome page.
When I New --> Server --> Tomcat v6.0 Server via Eclipse, "Tomcat v6.0 Server at localhost [Stopped]" line appears at the server tab.
I right click and start the server, it does not prompt any errors but Tomcat is not running -console output is as follows, Tomcat welcome page throws" HTTP Status 404 - / The requested resource (/) is not available." error.

Apr 27, 2010 12:21:11 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files (x86)\Java\jre6\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\sys tem32;C:\Windows;C:/Program Files (x86)/Java/jre6/bin/client;C:/Program Files (x86)/Java/jre6/bin;C:\Windows\system32;C:\Windows;C:\Window s\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\
Apr 27, 2010 12:21:12 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Apr 27, 2010 12:21:12 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 411 ms
Apr 27, 2010 12:21:12 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Apr 27, 2010 12:21:12 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.26
Apr 27, 2010 12:21:12 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Apr 27, 2010 12:21:12 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Apr 27, 2010 12:21:12 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/20 config=null
Apr 27, 2010 12:21:12 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 266 ms


When analyse my Tomcat arguments, I have the following line.
Arguments --> VM Arguments
-Dcatalina.base=" C:\workspace\jee\.metadata\.plugins\org.eclipse.wst.server.c ore\tmp0 " -Dcatalina.home="C:\apache-tomcat-6.0.26" -Dwtp.deploy=" C:\workspace\jee\.metadata\.plugins\org.eclipse.wst.server.c ore\tmp0\wtpwebapps " -Djava.endorsed.dirs="C:\apache-tomcat-6.0.26\endorsed"

Could not find anything under
* <workspace>/.metadata/.log
* <eclipse install>/configuration/<sometimestamp>.log
* <eclipse install>/configuration/org.eclipse.update/install.log --this one exist

I believe I am missing a very simple point but I couldn't detect it yet.

Regards,
Oğuz

[Updated on: Mon, 26 April 2010 17:44]

Report message to a moderator

Re: Tomcat-6.0.26 initiation fails via Eclipse-jee-galileo-SR2-win32 [message #553177 is a reply to message #529713] Mon, 16 August 2010 11:33 Go to previous messageGo to next message
Rajashekharam is currently offline Rajashekharam
Messages: 1
Registered: August 2010
Junior Member
Dear Oğuz
Did you get a solution for this problem. I am facing the same problem
Re: Tomcat-6.0.26 initiation fails via Eclipse-jee-galileo-SR2-win32 [message #553919 is a reply to message #529713] Thu, 19 August 2010 08:19 Go to previous messageGo to next message
Oğuz Çavlı is currently offline Oğuz Çavlı
Messages: 4
Registered: April 2010
Junior Member
Dear Rajashekharam,

What version of JDK do you have? Try with 32-bit and let me know.

Regards,
Oğuz
Re: Tomcat-6.0.26 initiation fails via Eclipse-jee-galileo-SR2-win32 [message #554392 is a reply to message #553919] Sun, 22 August 2010 15:17 Go to previous messageGo to next message
Marky Goldstein is currently offline Marky Goldstein
Messages: 1
Registered: July 2009
Junior Member
Hello,

I am running x64 of OpenJDK because I run on a Linux x64 (Red Hat) machine (which needs to be x64 because I also use KVM).

Would it not work on x64 ?
Re: Tomcat-6.0.26 initiation fails via Eclipse-jee-galileo-SR2-win32 [message #555222 is a reply to message #554392] Wed, 25 August 2010 18:23 Go to previous message
Oğuz Çavlı is currently offline Oğuz Çavlı
Messages: 4
Registered: April 2010
Junior Member
To the best knowledge of mine, it should work. However, you should be careful with setting-up your environment.

Regards,
Oğuz

[Updated on: Wed, 25 August 2010 18:31]

Report message to a moderator

Previous Topic:eclipse goes mental with garbage collection
Next Topic:How to link to a cheat sheet?
Goto Forum:
  


Current Time: Thu Apr 24 06:30:30 EDT 2014

Powered by FUDForum. Page generated in 0.01629 seconds