Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Using generics in xml jsp
Using generics in xml jsp [message #529425] Sun, 25 April 2010 04:49 Go to next message
Frantisek Rezac is currently offline Frantisek Rezac
Messages: 3
Registered: April 2010
Junior Member
Hi,
I tried to use generics in jsp:useBean type attribute but there is problem with validation. If I use
type="java.util.List<example.Page>"
then eclipse is ok, but it obviously can't work in servlet container and if I use
type="java.util.List&lt;example.Page&gt;"
then it works in servlet container but Eclipse don't understand it. I would like to ask what is the solution to this problem.
Re: Using generics in xml jsp [message #529538 is a reply to message #529425] Mon, 26 April 2010 06:14 Go to previous messageGo to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 277
Registered: July 2009
Senior Member
Il 25/04/2010 10.49, Frantisek Rezac ha scritto:
> type="java.util.List<example.Page>"
[cut]
> type="java.util.List<example.Page>"

I must be blind, but I don't see any difference on the two cases! :-D

Anyway, if you feel there's a bug in Eclipse WTP, you should open it on
http://bugs.eclipse.org

Mauro.
Re: Using generics in xml jsp [message #529540 is a reply to message #529538] Mon, 26 April 2010 06:24 Go to previous messageGo to next message
Frantisek Rezac is currently offline Frantisek Rezac
Messages: 3
Registered: April 2010
Junior Member
I'm confused (unless it's a joke). There are xml entities gt and lt instead of < and > in the second example. I will definitely fill a bug report, I just wanted to be sure that there is no standard way or hidden setting to solve this.
Re: Using generics in xml jsp [message #529672 is a reply to message #529425] Mon, 26 April 2010 13:17 Go to previous messageGo to next message
Frantisek Rezac is currently offline Frantisek Rezac
Messages: 3
Registered: April 2010
Junior Member
Bug filled:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=310502
Re: Using generics in xml jsp [message #529775 is a reply to message #529540] Tue, 27 April 2010 03:47 Go to previous message
Mauro Molinari is currently offline Mauro Molinari
Messages: 277
Registered: July 2009
Senior Member
Il 26/04/2010 12.24, Frantisek Rezac ha scritto:
> I'm confused (unless it's a joke). There are xml entities gt and lt
> instead of < and > in the second example.

My news reader (Thunderbird) shows "<" and ">" in both examples of your
previous message.

Mauro.
Previous Topic:Galileo - Axis2 Problems
Next Topic:Content Assist exstension in JSP editor
Goto Forum:
  


Current Time: Sun Apr 20 18:00:17 EDT 2014

Powered by FUDForum. Page generated in 0.02275 seconds