Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Problem installing EclipseLink 2.0.2 in Eclipse 3.5/Galileo
Problem installing EclipseLink 2.0.2 in Eclipse 3.5/Galileo [message #529417] Sat, 24 April 2010 23:57 Go to next message
Rory Douglas is currently offline Rory DouglasFriend
Messages: 2
Registered: April 2010
Junior Member
I'm trying to install EclipseLink 2.0.2 into Eclipse 3.5/Galileo using the update site from the download page (http://download.eclipse.org/rt/eclipselink/updates/2.0.2/).

Eclipse recognizes that I already have ealier versions of the 3 components (1.1.3) installed & says "an upgrade will be performed". However, it also displays an error saying "operation cannot be completed" since it is missing the javax.persistence dependency.

The listed version it requires is 2.0.0.v200911271158. Where can I obtain this? Is this be available on an update site somewhere?

I tried grabbing the javax.persistence.jar from the OSGI bundles ZIP download (it is a later version, 2.0.0.v201002051058) and installing it in /plugins & restarting with -clean, but the update still doesn't complete.
Re: Problem installing EclipseLink 2.0.2 in Eclipse 3.5/Galileo [message #530000 is a reply to message #529417] Wed, 28 April 2010 02:22 Go to previous messageGo to next message
Shaun Smith is currently offline Shaun SmithFriend
Messages: 197
Registered: July 2009
Senior Member
Hi Rory,

I'm not sure what's going on myself but I've forwarded your posting
to Eric Gwin, the EclipseLink build engineer, to investigate.

--Shaun

On 24/4/2010 7:57 PM, Rory Douglas wrote:
> I'm trying to install EclipseLink 2.0.2 into Eclipse 3.5/Galileo using
> the update site from the download page
> (http://download.eclipse.org/rt/eclipselink/updates/2.0.2/).
>
> Eclipse recognizes that I already have ealier versions of the 3
> components (1.1.3) installed & says "an upgrade will be performed".
> However, it also displays an error saying "operation cannot be
> completed" since it is missing the javax.persistence dependency.
>
> The listed version it requires is 2.0.0.v200911271158. Where can I
> obtain this? Is this be available on an update site somewhere?
>
> I tried grabbing the javax.persistence.jar from the OSGI bundles ZIP
> download (it is a later version, 2.0.0.v201002051058) and installing it
> in /plugins & restarting with -clean, but the update still doesn't
> complete.


--
Oracle <http://www.oracle.com>
Shaun Smith | Principal Product Manager
Phone: +19055023094
Oracle Server Technologies, Oracle TopLink
ORACLE Canada | 110 Matheson Boulevard West, Suite 100, Mississauga,
Ontario | L5R 3P4
Green Oracle <http://www.oracle.com/commitment> Oracle is committed to
developing practices and products that help protect the environment
Re: Problem installing EclipseLink 2.0.2 in Eclipse 3.5/Galileo [message #531444 is a reply to message #530000] Tue, 04 May 2010 23:13 Go to previous message
Larry Rogers is currently offline Larry RogersFriend
Messages: 2
Registered: July 2009
Junior Member
I'm receiving the exact same error (and have been during each of my various attempts to update over the past 3 weeks).

Has anyone yet figured out a solution? (I'm very anxious to get up and running on 2.0. Smile)
Previous Topic:How to map an association with an Enum
Next Topic:Communication failure
Goto Forum:
  


Current Time: Sun Dec 21 09:17:29 GMT 2014

Powered by FUDForum. Page generated in 0.02152 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software