Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Running all test cases included in Mylyn fails(Testing Mylyn with automatic test suite)
Running all test cases included in Mylyn fails [message #528946] Thu, 22 April 2010 13:36 Go to next message
Ela is currently offline Ela
Messages: 4
Registered: April 2010
Junior Member
Hello,

I am investigating the Mylyn plugin and how it is tested. Therefore I followed the wiki description at http://wiki.eclipse.org/index.php/Mylyn/Contributor_Referenc e .
I downloaded the cvs source and started to run the test cases, after creating the property file and changing the VM Arguments.

In the documentation it is written that all test cases should pass, but this is not the case in my set-up.

Even stranger, I get different numbers of pass and fail for the first 1500 test cases, each time I run them (around 6-26 error and even more failures), and at test case 1811 I get a OutOfMemory error (java.lang.OutOfMemoryError: PermGen space errors like described in http://wiki.eclipse.org/Mylyn/FAQ#Why_am_seeing_java.lang.Ou tOfMemoryError:_PermGen_space_errors.3F).

Does anybody know what could be wrong? Configuration? Did I miss something in my set-up? Are those tests really all passing?

Thanks in advance.

Michaela
Re: Running all test cases included in Mylyn fails [message #529030 is a reply to message #528946] Thu, 22 April 2010 16:52 Go to previous message
Ela is currently offline Ela
Messages: 4
Registered: April 2010
Junior Member
After running the test cases another 3 times, I hope I can provide a bit more specific information on my problem. I also changed now my VM Arguments to -enableassertions -Xmx768M -XX:MaxPermSize=128M

The first 1790 test cases are almost always reporting 12 Failures and 2 Errors. I added the list below.

When starting testing org.eclipse.mylyn.xplanner the misery starts. First, I get an authentication failure. Then test case 3 of Test for org.eclipse.mylyn.xplanner.tests
org.eclipse.mylyn.xplanner.tests.XPlannerRepositoryUtilsTest testGetNewRepositoryTaskData (No. 1796) takes forever (>50 minutes)

I hope I could give a more clear picture and would be glad if somebody could help.


Test Report (without detail description of linenumbers):
org.eclipse.mylyn.tests
All Non-Connector Tests for org.eclipse.mylyn.tests
Test for org.eclipse.mylyn.monitor.ui.tests
org.eclipse.mylyn.monitor.tests.CheckActivityJobTest

testInactivityTimeout(org.eclipse.mylyn.monitor.tests.CheckA ctivityJobTest)
junit.framework.AssertionFailedError: expected less than 5 < activeTime < 40, got 0 (slept 0 ms)

testResumeFromSleepTimeoutEventDiscarded(org.eclipse.mylyn.m onitor.tests.CheckActivityJobTest)
junit.framework.AssertionFailedError: expected less than 5 < activeTime < 10, got 0

Test for org.eclipse.mylyn.tasks.tests
org.eclipse.mylyn.tasks.tests.ui.TaskAttributeDiffTest
testDateDiff(org.eclipse.mylyn.tasks.tests.ui.TaskAttributeD iffTest)
junit.framework.ComparisonFailure: expected:< someDate: 2010/02/0[1] -> 2010/05/28> but was:< someDate: 2010/02/0[2] -> 2010/05/28>

Test for org.eclipse.mylyn.wikitext.tests Headless Tests Stand-Alone
org.eclipse.mylyn.wikitext.core.parser.builder.HtmlDocumentB uilderTest
testRelativeUrlWithFileBase(org.eclipse.mylyn.wikitext.core. parser.builder.HtmlDocumentBuilderTest)
junit.framework.AssertionFailedError

testCssStylesheetEmbedded(org.eclipse.mylyn.wikitext.core.pa rser.builder.HtmlDocumentBuilderTest)
junit.framework.AssertionFailedError


org.eclipse.mylyn.wikitext.core.parser.HtmlDocumentBuilderTe st
testRelativeUrlWithFileBase(org.eclipse.mylyn.wikitext.core. parser.HtmlDocumentBuilderTest)
junit.framework.AssertionFailedError



All Connector Tests for org.eclipse.mylyn.tests
Tests for org.eclipse.mylyn.bugzilla.tests
Headless Standalone Tests for org.eclipse.mylyn.bugzilla.tests
Testing on Bugzilla 3.5.2+
org.eclipse.mylyn.bugzilla.tests.core.BugzillaRepositoryConn ectorStandaloneTest
testPerformQuery(org.eclipse.mylyn.bugzilla.tests.core.Bugzi llaRepositoryConnectorStandaloneTest)
org.eclipse.core.runtime.CoreException: An unknown repository error has occurred:


Testing on Bugzilla 3.5.2+
org.eclipse.mylyn.bugzilla.tests.RepositoryReportFactoryTest
testPostingAndReadingAttributes(org.eclipse.mylyn.bugzilla.t ests.RepositoryReportFactoryTest)
org.eclipse.core.runtime.CoreException: An unknown repository error has occurred:



Tests for org.eclipse.mylyn.trac.tests
Headless Standalone Tests for org.eclipse.mylyn.trac.tests
Testing on Trac 0.9/Web
org.eclipse.mylyn.trac.tests.client.TracClientTest
testSearchEmpty(org.eclipse.mylyn.trac.tests.client.TracClie ntTest)
junit.framework.AssertionFailedError: expected:<0> but was:<1>



testSearchExactMatch(org.eclipse.mylyn.trac.tests.client.Tra cClientTest)
junit.framework.AssertionFailedError: expected:<1> but was:<2>



testSearchMilestone1(org.eclipse.mylyn.trac.tests.client.Tra cClientTest)
junit.framework.AssertionFailedError: expected:<1> but was:<2>

testSearchMilestone2(org.eclipse.mylyn.trac.tests.client.Tra cClientTest)
junit.framework.AssertionFailedError: expected:<3> but was:<4>



testSearchMilestoneAmpersand(org.eclipse.mylyn.trac.tests.cl ient.TracClientTest)
junit.framework.AssertionFailedError: expected:<1> but was:<2>



Testing on Trac 0.9/Web
org.eclipse.mylyn.trac.tests.core.TracRepositoryConnectorTes t
testPerformQuery(org.eclipse.mylyn.trac.tests.core.TracRepos itoryConnectorTest)
junit.framework.AssertionFailedError: expected:<3> but was:<4>


Test for org.eclipse.mylyn.xplanner.tests
org.eclipse.mylyn.xplanner.tests.XPlannerRepositoryUtilsTest
testIsCompleted(org.eclipse.mylyn.xplanner.tests.XPlannerRep ositoryUtilsTest)
org.eclipse.core.runtime.CoreException: Error connecting to XPlanner Server: The supplied credentials are invalid:


testSetupTaskAttributes(org.eclipse.mylyn.xplanner.tests.XPl annerRepositoryUtilsTest)
org.eclipse.core.runtime.CoreException: Error connecting to XPlanner Server: The supplied credentials are invalid:
Previous Topic:How to prevent resources from fading away too quickly?
Next Topic:Running all test cases included in Mylyn fails
Goto Forum:
  


Current Time: Tue Oct 21 09:00:38 GMT 2014

Powered by FUDForum. Page generated in 0.01641 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software