Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Moving an RCP product from eclipce 3.3 to 3.5 (P2 auto update, RCP 3.3 to RCP 3.5)
Moving an RCP product from eclipce 3.3 to 3.5 [message #527899] Fri, 16 April 2010 16:23
Christophe Olivier is currently offline Christophe Olivier
Messages: 6
Registered: April 2010
Location: Montpellier France
Junior Member
I have an application based on eclipse rcp 3.3 using auto update and currently used by almost 20 people.
I need now to move on eclipse 3.5.
I already have generated my application on eclipse 3.5 implementing autoupdate with p2 and everything is working well.

However if I download this new version throw the 3.3 autoupdate, the final product get all new functionnalities but not all the p2 bundles.
So this final product is now working but not able to update itself.

Before googleling I would like to know if it's possible to update a 3.3 rcp product to 3.5 using the 3.3 update and getting p2 installed correctly or should I replace manually all old version of the application ?

Thanks for your help.
Previous Topic:Replace/overwrite resource files of another plugin
Next Topic:Signed Jar or JNLP issue
Goto Forum:
  


Current Time: Sun Apr 20 19:41:37 EDT 2014

Powered by FUDForum. Page generated in 0.18037 seconds