Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Running different Eclipse versions
Running different Eclipse versions [message #527681] Fri, 16 April 2010 06:24 Go to next message
Thomas Wiedmann is currently offline Thomas Wiedmann
Messages: 69
Registered: July 2009
Member
Hello,

the eclipse installation files usually are archived with path entries with
'eclipse' as root subdirectory.

Is it possible to install and run different Eclipse versions simultaneously?
If yes: How has an Eclipse version to be installed or modified for this
purpose?


And by the way (or as alternative to the option , mentioned above, running 2
Eclipse versions parallel):
How to upgrade Eclipse quickly, i. e. maintaining old preference and project
settings, without removing the old version and installing and reconfiguring
the new version?


Thomas Wiedmann
Re: Running different Eclipse versions [message #527853 is a reply to message #527681] Fri, 16 April 2010 16:31 Go to previous message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
Eclipse looks for things relative to the directory eclipse is started in.
You can have this anywhere in your file system. You just need to make sure
that you start Eclipse from the eclipse directory for the version you want
to run..

For example, you can have an eclipse3.5/eclipse directory with the 3.5
version and an eclipse3.6/eclipse directory with the 3.6 version.


"Thomas Wiedmann" <th.wm@gmx.de> wrote in message
news:hq8vrq$6g6$1@build.eclipse.org...
> Hello,
>
> the eclipse installation files usually are archived with path entries with
> 'eclipse' as root subdirectory.
>
> Is it possible to install and run different Eclipse versions
> simultaneously?
> If yes: How has an Eclipse version to be installed or modified for this
> purpose?
>
>
> And by the way (or as alternative to the option , mentioned above, running
> 2 Eclipse versions parallel):
> How to upgrade Eclipse quickly, i. e. maintaining old preference and
> project settings, without removing the old version and installing and
> reconfiguring the new version?
>
>
> Thomas Wiedmann
Previous Topic:Tabs in texteditor do not indent
Next Topic:programmatically synchronize projects in workspace
Goto Forum:
  


Current Time: Tue Sep 23 14:38:49 GMT 2014

Powered by FUDForum. Page generated in 0.02155 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software