Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » latest saxon not working with wtp xslt plugin(latest saxon not working with wtp xslt plugin)
latest saxon not working with wtp xslt plugin [message #526450] Sun, 11 April 2010 09:05 Go to next message
fehrin2  is currently offline fehrin2 Friend
Messages: 4
Registered: April 2010
Junior Member
Hi all,

I cannot get saxon9he (saxonhe9-2-0-6j.zip) to work with the wtp xslt eclipse plugin (i tried both 3.5.2 and 3.6.0M6 with the corresponding plugin versions).
To cite my posting on saxon-help:

I have the same problem as described on
http://sourceforge.net/tracker/index.php?func=detail&aid =2910299&group_id=29872&atid=397617
It is not possible to use saxon 9 HE with the xslt plugin of eclipse
wtp, because edition.properties is not found in the classpath.
Michael Kay says about this:
"This looks like a fairly complex issue relating to the unusual class
loader structure in Eclipse. "
Do i have any chance to succeed with the saxon9he/eclipse combo?
I already put edition.properties everywhere in the classpath but no luck.

And Michael Michael Kay responded:

Have you tried raising this on an Eclipse forum? They did the integration of
Saxon into Eclipse in the first place, they know how it was done, and
presumably if anyone does it anew for a new Saxon release, it will be them
that does it. Generally, I don't get involved in integrating Saxon into the
many different environments where people run it, as one can't be expert in
all of them.

I'm afraid with integration issues like this (for the open source product) I
have to fall back on the community to provide the answers. Eclipse isn't
something I use or understand myself. I know it's an important platform for
a significant number of users, but it's also a very complex one.

Any progress or help on this one?

Thanks and best regards

Franz



Re: latest saxon not working with wtp xslt plugin [message #527038 is a reply to message #526450] Tue, 13 April 2010 19:29 Go to previous messageGo to next message
David Carver is currently offline David CarverFriend
Messages: 174
Registered: July 2009
Senior Member
This is a Saxon issue. He changed the way he uses the classloader to get some code, and it has caused numerous compatibility problems with tools like eXist and eclipse.

The only option we have, is to make an OSGI plugin, but that has to come from Michael Kay. This way it would get the appropriate classloader from OSGI for that particular bundle.

Again, versions prior to Saxon/HE work fine, so unless you need specifically Saxon/HE's features and bug fixes, you should try a prior version, and I think you will work.
Re: latest saxon not working with wtp xslt plugin [message #531159 is a reply to message #527038] Mon, 03 May 2010 23:34 Go to previous messageGo to next message
Adrian Aichner is currently offline Adrian AichnerFriend
Messages: 14
Registered: March 2010
Junior Member
Hi Dave, All,

I just wanted to confirm that
saxonb9-1-0-8j
from sf.net download area works fine for me to give me XSLT 2.0 processing in Galileo.

I added a
SAXON 2.0
entry pointing to
c:\eclipse-modeling-galileo-SR2-incubation-win32\eclipse\plu gins\saxon9.jar
via
eclipse->Window->Preferences->XML->XSL->Java Processors

I'm still looking for a way to get XSD 1.1 alternate types support in eclipse to tackle a practical challenge at hand.

I got the impression that an upcoming xerces-j release will provide this functionality.

Do you have any advice how I can play with that today, probably based on some nightly build .jar files?

Thanks!

Adrian
Re: latest saxon not working with wtp xslt plugin [message #536530 is a reply to message #531159] Fri, 28 May 2010 15:12 Go to previous message
David Carver is currently offline David CarverFriend
Messages: 174
Registered: July 2009
Senior Member
Adrian wrote on Mon, 03 May 2010 19:34
Hi Dave, All,

I just wanted to confirm that

I'm still looking for a way to get XSD 1.1 alternate types support in eclipse to tackle a practical challenge at hand.

I got the impression that an upcoming xerces-j release will provide this functionality.

Do you have any advice how I can play with that today, probably based on some nightly build .jar files?

Adrian


Xerces-J 2.10 when it is released will allow for the XSD 1.1 validation support. Unfortunately you'll have to use the Ant tasks currently to test it out, as the built in Xerces-J in eclipse is 2.9, and doesn't support the validation. The validator will need to be updated to work with Xerces-J 2.10 when it is available.

Xerces-J 2.10 will also allow the use of the PsychoPath XPath 2.0 processor which is part of the wst.xsl component for validating Assertions in XSD 1.1.

Previous Topic:How to ignore a symlinked folder in a validator
Next Topic:Eclipse is trying to access port 80 when before compile
Goto Forum:
  


Current Time: Sat Dec 20 07:32:41 GMT 2014

Powered by FUDForum. Page generated in 0.01776 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software