Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » update RCP application problem
update RCP application problem [message #526207] Fri, 09 April 2010 09:00 Go to next message
Bernd van Velsen is currently offline Bernd van Velsen
Messages: 19
Registered: November 2009
Junior Member
Hi again

I have a problem with using the update system. I can provide new updates to my app by updating my feature and it's plugins. My application finds the update on the update site and installs the update. But after the restart my app still uses the old version... if i go check the features and plugin folder i see all my features(actually just one feature that is update 3 times, so i see 3 feature folders) and in my plugins folder i see my updated plugin, but also the old plugin that is still used, but shouldn't be used anymore...

can anyone help me with solving my problem?
Re: update RCP application problem [message #526912 is a reply to message #526207] Tue, 13 April 2010 13:34 Go to previous messageGo to next message
Bernd van Velsen is currently offline Bernd van Velsen
Messages: 19
Registered: November 2009
Junior Member
anyone?
Re: update RCP application problem [message #526936 is a reply to message #526207] Tue, 13 April 2010 14:18 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Bernd van Velsen wrote:
> can anyone help me with solving my problem?

After the restart, is there anything in your error log? Are you using
Help>Check For Updates to update your RCP app? Are you using p2, or the
legacy update manager?

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Re: update RCP application problem [message #527421 is a reply to message #526207] Thu, 15 April 2010 08:38 Go to previous message
Bernd van Velsen is currently offline Bernd van Velsen
Messages: 19
Registered: November 2009
Junior Member
I am using the legacy update manager.

the only relevant message related to update in my log is:

!ENTRY org.eclipse.update.configurator 4 0 2010-04-09 10:05:45.857
!MESSAGE Could not install bundle plugins/com.entol.bl.common_1.0.0.jar Bundle "com.entol.bl.common" version "1.0.0" has already been installed from: reference:file:plugins/com.entol.bl.common_1.0.0.jar
Previous Topic:Widgets inside a view
Next Topic:How to share plugins between several applications?
Goto Forum:
  


Current Time: Thu Oct 23 15:22:42 GMT 2014

Powered by FUDForum. Page generated in 0.04340 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software