Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » p2:contributing -vm argument to launcher INI file(Problem when contributing -vm argument to INI file)
p2:contributing -vm argument to launcher INI file [message #525583] Wed, 07 April 2010 01:48 Go to next message
Alex Smirnoff is currently offline Alex Smirnoff
Messages: 28
Registered: July 2009
Junior Member
I have requirement to set explicitly -vm option with p2 build. I have next p2.inf collocated with .product file:
instructions.configure = \
           addProgramArg(programArg:-vm);\
           addProgramArg(programArg:jre/bin/javaw.exe);
instructions.unconfigure= \
           removeProgramArg(programArg:-vm);\
           removeProgramArg(programArg:jre/bin/javaw.exe);

Everything works fine, however, after the build finishes, the option is located in the wrong place:
-startup
plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-vmargs
-vm
jre/bin/javaw.exe
-Xms32m
-Xmx1024m
-XX:PermSize=64M
-XX:MaxPermSize=256M

which causes the product not to start. The only way it starts is if -vm is moved above -vmargs option (that is obvious). So the question is: how can I make it appear on the first line. Now it seems to "append" to the program options.

Thanks,
Alex.

[Updated on: Wed, 07 April 2010 21:30]

Report message to a moderator

Re: p2:contributing -vm argument to launcher INI file [message #525780 is a reply to message #525583] Wed, 07 April 2010 18:58 Go to previous messageGo to next message
Alex Smirnoff is currently offline Alex Smirnoff
Messages: 28
Registered: July 2009
Junior Member
Weird, with p2 enabled PDE build, when I place -vm option in Program Arguments section in product file, it never ends up in launch ini file. The -vmargs section is specified above appears in launch ini file without a problem.

One more detail I am using 3.5.2.

[Updated on: Wed, 07 April 2010 21:30]

Report message to a moderator

Re: p2:contributing -vm argument to launcher INI file [message #698101 is a reply to message #525780] Mon, 18 July 2011 19:06 Go to previous messageGo to next message
Zuber Saiyed is currently offline Zuber Saiyed
Messages: 2
Registered: July 2009
Junior Member
I am facing the same issue. Have you found out how to resolve it?
Re: p2:contributing -vm argument to launcher INI file [message #698549 is a reply to message #698101] Tue, 19 July 2011 16:49 Go to previous message
Alex Smirnoff is currently offline Alex Smirnoff
Messages: 28
Registered: July 2009
Junior Member
I have put my jre into jre sub folder. Eclipse will automatically test one if nothing else available. But explicitly setting VM location for me never worked. As far as I remember. May be now it is different.
Previous Topic:Confused about IProject and IJavaProject
Next Topic:org.w3c.dom.Node method calls returning null values
Goto Forum:
  


Current Time: Wed Oct 22 06:31:11 GMT 2014

Powered by FUDForum. Page generated in 0.09102 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software