Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMP » Install problems, missing items
Install problems, missing items [message #525468] Tue, 06 April 2010 12:33 Go to next message
No real name is currently offline No real name
Messages: 2
Registered: April 2010
Junior Member
Hi,

I got some installation problems, it seems that some stuff is missing or unreachable. But the precise understanding of the error message is beyond my competence i'm afraid. Could someone give me some light about it?

Thanks a lot.

Here is the error message:
Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: AMF IDE Integration and Generation for Escape (Incubation) 0.5.0.HEAD-179-7aVNT (org.eclipse.amp.amf.target.escape.feature.group 0.5.0.HEAD-179-7aVNT)
Missing requirement: AMF IDE Integration and Generation for Escape (Incubation) 0.5.0.HEAD-179-7aVNT (org.eclipse.amp.amf.target.escape.feature.group 0.5.0.HEAD-179-7aVNT) requires 'org.eclipse.xtext 0.7.0' but it could not be found
Re: Install problems, missing items [message #525520 is a reply to message #525468] Tue, 06 April 2010 14:01 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member

Hi "No Real Name" Smile,

Please see below..

No Real Name wrote on Tue, 06 April 2010 12:33
Hi,

I got some installation problems, it seems that some stuff is missing or unreachable. But the precise understanding of the error message is beyond my competence i'm afraid. Could someone give me some light about it?

Thanks a lot.

Here is the error message:
Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: AMF IDE Integration and Generation for Escape (Incubation) 0.5.0.HEAD-179-7aVNT (org.eclipse.amp.amf.target.escape.feature.group 0.5.0.HEAD-179-7aVNT)
Missing requirement: AMF IDE Integration and Generation for Escape (Incubation) 0.5.0.HEAD-179-7aVNT (org.eclipse.amp.amf.target.escape.feature.group 0.5.0.HEAD-179-7aVNT) requires 'org.eclipse.xtext 0.7.0' but it could not be found



What update site are you using? Unfortunately, there are some issues with the XText dependencies that have just cropped up on our latest builds, but that should only be a problem if something has been changed on the other site.

Here are two things to try:

1. Make sure that you have "all available sites" selected when you pick out the AMP features. This will give you a long list of different feature categories and will ensure that Ec;ipse looks everywhere for the dependencies.

2. Install XText first. Go to the Gallileo update site and find Xtext SDK in the "Modeling" category.

Let me know if either of these solutions don't work.

cheers,

Miles
Re: Install problems, missing items [message #525638 is a reply to message #525520] Wed, 07 April 2010 06:04 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 2
Registered: April 2010
Junior Member
Hi,

I just tried the two, and it did not change anythig. Still the same error message. I've been using the milestone update site, but i also gave a try with the interim, and same story. It's the first time I have such a problem with extension installation.

Thanks for helping.

Thomas.
Re: Install problems, missing items [message #525771 is a reply to message #525468] Wed, 07 April 2010 14:00 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Thomas,

Hi, do you mean that you already have AMP installed and are now updating?

Is it possible that you have a *newer* version of Xtext installed? We've had to stick with 0.7.2, so that could cause issues if say you have Helios and other newer stuff. But not coincidentally I'm in the middle of upgrading our dependencies to XText and XPand 1.0 so that should make everything work well with the latest version.

Will you please send me a copy of your configuration file? It's too big to post here probably but you can just email it to me at "milesparker[-----gmail-dot-com]". Or you could just open a bugzilla report.

Sorry you are having problems, this is something we've spent a lot of time to try to get working well..

Miles
Re: Install problems, missing items [message #527885 is a reply to message #525771] Fri, 16 April 2010 14:51 Go to previous message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
The nightly version now is updated to work with the version 1.0.0 candidates of the XText build, so you might try that one instead. It is probably not quite as stable as the interim build bu should be in pretty good shape.
Previous Topic:Modelers Documentation
Next Topic:Installing AGF3D
Goto Forum:
  


Current Time: Wed Jul 23 01:59:18 EDT 2014

Powered by FUDForum. Page generated in 0.02018 seconds