Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » problems with layout providers
problems with layout providers [message #525218] Tue, 29 September 2009 11:39
Lorenzo Bettini is currently offline Lorenzo Bettini
Messages: 1307
Registered: July 2009
Senior Member
Hi

I'm trying the customized MindmapDefaultLayoutProvider (extends
LeftRightProvider) of the book (on page 83).

It looks like the generated diagram editor sticks with the default
provider (Top-to-bottom) if I keep proprity to "Low" (as in the book).

Putting it to "Medium" solved the problem, but, now, after some other
modification to the diagram.custom (e.g., adding the "insert subtopic"
action) "Medium" is not enough... and I had to turned it to "High" to
have the Left-to-Right again...

is this some kind of bug?

thanks in advance
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Previous Topic:examples of the book?
Next Topic:problems with layout providers
Goto Forum:
  


Current Time: Thu Jul 31 09:41:45 EDT 2014

Powered by FUDForum. Page generated in 0.02339 seconds