Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » Amalgam update site for Galileo?
Amalgam update site for Galileo? [message #525210] Sun, 13 September 2009 21:12 Go to next message
Michael Moser is currently offline Michael Moser
Messages: 914
Registered: July 2009
Senior Member
I have started reading Richards book "The Eclipse Modeling Project" but I have a problem the Amalgam update site referred to in the book.

I found the project's home page (http://www.eclipse.org/modeling/amalgam/). The download page ( http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/S20090703-0844/index.php) provides a .zip file which seems to contain a stand-alone DSL toolkit.

However, I would prefer to add/integrate that DSL toolkit to my already existing Galileo setup and I would prefer to handle that installation using the Eclipse update manager.

However, neither the amalgam page nor the page behind the link "Update Manager" (http://www.eclipse.org/modeling/amalgam/updates/) seems to point to a valid Eclipse update site. I always only get the message "No repository found at ....". Also the link provided on the 1.0.0M8 download page behind the word "URL" in "... the DSL Toolkit may be installed using p2 by pointing to this URL " yields the same error message only.

Is there a valid Eclipse update site somewhere to download and install that DSL toolkit and the examples into an existing Eclipse Galileo release?

Or some instructions on how and where from to collect the equivalent of all the described tools and install them in Galileo?

Michael
Re: Amalgam update site for Galileo? [message #525211 is a reply to message #525210] Tue, 15 September 2009 18:18 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26050
Registered: July 2009
Senior Member
Michael,

The Amalgam project needs some new committers since Rich gave up his
role... I think all the component technologies for each of the
different Amalgam packages are all available in the Galileo repo so look
for them in the main repo. I'm not sure there is a documented list
anywhere. I'd have to look for it just like you would...


Michael Moser wrote:
> I have started reading Richards book "The Eclipse Modeling Project" but I have a problem the Amalgam update site referred to in the book.
>
> I found the project's home page (http://www.eclipse.org/modeling/amalgam/). The download page ( http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/S20090703-0844/index.php) provides a .zip file which seems to contain a stand-alone DSL toolkit.
>
> However, I would prefer to add/integrate that DSL toolkit to my already existing Galileo setup and I would prefer to handle that installation using the Eclipse update manager.
>
> However, neither the amalgam page nor the page behind the link "Update Manager" (http://www.eclipse.org/modeling/amalgam/updates/) seems to point to a valid Eclipse update site. I always only get the message "No repository found at ....". Also the link provided on the 1.0.0M8 download page behind the word "URL" in "... the DSL Toolkit may be installed using p2 by pointing to this URL " yields the same error message only.
>
> Is there a valid Eclipse update site somewhere to download and install that DSL toolkit and the examples into an existing Eclipse Galileo release?
>
> Or some instructions on how and where from to collect the equivalent of all the described tools and install them in Galileo?
>
> Michael
>
>
Re: Amalgam update site for Galileo? [message #525224 is a reply to message #525211] Wed, 21 October 2009 10:56 Go to previous message
Richard Gronback is currently offline Richard Gronback
Messages: 23
Registered: July 2009
Junior Member
Sorry, there were changes in Galileo that make the book's examples not
usable in this version of Eclipse. Stick to the Ganymede release
version of the DSL Toolkit for the book.

Best,
Rich
Re: Amalgam update site for Galileo? [message #583956 is a reply to message #525210] Tue, 15 September 2009 18:18 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26050
Registered: July 2009
Senior Member
Michael,

The Amalgam project needs some new committers since Rich gave up his
role... I think all the component technologies for each of the
different Amalgam packages are all available in the Galileo repo so look
for them in the main repo. I'm not sure there is a documented list
anywhere. I'd have to look for it just like you would...


Michael Moser wrote:
> I have started reading Richards book "The Eclipse Modeling Project" but I have a problem the Amalgam update site referred to in the book.
>
> I found the project's home page (http://www.eclipse.org/modeling/amalgam/). The download page ( http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/S20090703-0844/index.php) provides a .zip file which seems to contain a stand-alone DSL toolkit.
>
> However, I would prefer to add/integrate that DSL toolkit to my already existing Galileo setup and I would prefer to handle that installation using the Eclipse update manager.
>
> However, neither the amalgam page nor the page behind the link "Update Manager" (http://www.eclipse.org/modeling/amalgam/updates/) seems to point to a valid Eclipse update site. I always only get the message "No repository found at ....". Also the link provided on the 1.0.0M8 download page behind the word "URL" in "... the DSL Toolkit may be installed using p2 by pointing to this URL " yields the same error message only.
>
> Is there a valid Eclipse update site somewhere to download and install that DSL toolkit and the examples into an existing Eclipse Galileo release?
>
> Or some instructions on how and where from to collect the equivalent of all the described tools and install them in Galileo?
>
> Michael
>
>
Re: Amalgam update site for Galileo? [message #587194 is a reply to message #525211] Wed, 21 October 2009 10:56 Go to previous message
Richard Gronback is currently offline Richard Gronback
Messages: 23
Registered: July 2009
Junior Member
Sorry, there were changes in Galileo that make the book's examples not
usable in this version of Eclipse. Stick to the Ganymede release
version of the DSL Toolkit for the book.

Best,
Rich
Previous Topic:DSL Toolkit Build Problems
Next Topic:[Announce] Eclipse/OMG Symposium 2010
Goto Forum:
  


Current Time: Fri Sep 19 05:57:35 GMT 2014

Powered by FUDForum. Page generated in 0.05153 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software