Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » Unable to install DSL Toolkit
Unable to install DSL Toolkit [message #525187] Wed, 01 July 2009 16:54 Go to next message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
I am running Galileo and trying to follow some examples in the book,
"eclipse Modeling Project: A Domain-Specific Language (DSL) Toolkit".

As part of that, I'm trying to install the DSL Toolkit from the Amalgam
project, but I get the following error:

Cannot complete the install because one or more required items could not
be found.
Software being installed: DSL Toolkit 1.0.0.v200905210858
(org.eclipse.amalgam.dsltk.product 1.0.0.v200905210858)
Missing requirement for filter
(&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=x86_64)): Eclipse RCP
3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC (org.eclipse.rcp.feature.group
3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC) requires
'org.eclipse.swt.gtk.linux.x86_64 [3.5.0.v3548c]' but it could not be found
Cannot satisfy dependency:
From: DSL Toolkit 1.0.0.v200905210858
(org.eclipse.amalgam.dsltk.product 1.0.0.v200905210858)
To: org.eclipse.platform.feature.group
[3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD]
Cannot satisfy dependency:
From: Eclipse Platform
3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD
(org.eclipse.platform.feature.group
3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD)
To: org.eclipse.rcp.feature.group
[3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC]

Please be aware that I am running on ubuntu 9.04 AMD64 and have eclipse
for Linux 64-bit installed. I'm also a newbie to eclipse, so if that's
part of the problem, then some detail on how to correct the problem would
be much appreciated.

Many thanks, both for the solution, and your patience!
Re: Unable to install DSL Toolkit [message #525188 is a reply to message #525187] Wed, 01 July 2009 16:58 Go to previous messageGo to next message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
If you're following the book, you should use the Ganymede edition:
http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/I20081128
-0606/index.php

Unfortunately, there is no 64 bit version for Linux. I have built one for
M8 based on Galileo, but it's not promoted yet.

Best,
Rich


On 7/1/09 4:54 PM, in article
dd872609a93892e1ab06a84c944419bc$1@www.eclipse.org, "Flavelle Ballem"
<fballem@ballemco.com> wrote:

> I am running Galileo and trying to follow some examples in the book,
> "eclipse Modeling Project: A Domain-Specific Language (DSL) Toolkit".
>
> As part of that, I'm trying to install the DSL Toolkit from the Amalgam
> project, but I get the following error:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: DSL Toolkit 1.0.0.v200905210858
> (org.eclipse.amalgam.dsltk.product 1.0.0.v200905210858)
> Missing requirement for filter
> (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=x86_64)): Eclipse RCP
> 3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC (org.eclipse.rcp.feature.group
> 3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC) requires
> 'org.eclipse.swt.gtk.linux.x86_64 [3.5.0.v3548c]' but it could not be found
> Cannot satisfy dependency:
> From: DSL Toolkit 1.0.0.v200905210858
> (org.eclipse.amalgam.dsltk.product 1.0.0.v200905210858)
> To: org.eclipse.platform.feature.group
> [3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD
> (org.eclipse.platform.feature.group
> 3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD)
> To: org.eclipse.rcp.feature.group
> [3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC]
>
> Please be aware that I am running on ubuntu 9.04 AMD64 and have eclipse
> for Linux 64-bit installed. I'm also a newbie to eclipse, so if that's
> part of the problem, then some detail on how to correct the problem would
> be much appreciated.
>
> Many thanks, both for the solution, and your patience!
>
>

--
Thanks,
Rich
Re: Unable to install DSL Toolkit [message #525189 is a reply to message #525188] Wed, 01 July 2009 19:25 Go to previous messageGo to next message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
Richard Gronback wrote:

> If you're following the book, you should use the Ganymede edition:
> http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/I20081128
> -0606/index.php

> Unfortunately, there is no 64 bit version for Linux. I have built one for
> M8 based on Galileo, but it's not promoted yet.

> Best,
> Rich

Rich:

I'm sorry, I am new to eclipse. Could you please tell me what M8 is? Is
there anyway that I could get a preview of the new code - happy to be the
tester. I have found advantages to staying with the 64-bit environment for
my applications, and I gather that 32-bit and 64-bit plugins don't mix
well.

Many thanks,
Flavelle
Re: Unable to install DSL Toolkit [message #525190 is a reply to message #525189] Wed, 01 July 2009 20:13 Go to previous messageGo to next message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
Rich:

A small further thought - is there a different approach using existing
Galileo components that will allow me to proceed further with your book?

Thanks,
Flavelle
Re: Unable to install DSL Toolkit [message #525191 is a reply to message #525189] Thu, 02 July 2009 06:39 Go to previous messageGo to next message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
M8 = Milestone 8

You can try the linux x86_64 download of the Modeling package from EPP:
http://www.eclipse.org/epp/download.php It contains most of what's in the
Amalgam DSL Toolkit, less some UI elements.

There are some differences in the Galileo version of the modeling
components, as compared to the Ganymede version the book is based on.
Mostly, things should work, but the solutions are not yet updated. The main
thing to do is replace references to the "legacy" Xpand model-to-text engine
with the new one in GMF that uses OCL and QVTO.

Best,
Rich


On 7/1/09 7:25 PM, in article
c52a18f8944b602a7a8b198ffbd46ea4$1@www.eclipse.org, "Flavelle Ballem"
<fballem@ballemco.com> wrote:

> Richard Gronback wrote:
>
>> If you're following the book, you should use the Ganymede edition:
>> http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/I20081128
>> -0606/index.php
>
>> Unfortunately, there is no 64 bit version for Linux. I have built one for
>> M8 based on Galileo, but it's not promoted yet.
>
>> Best,
>> Rich
>
> Rich:
>
> I'm sorry, I am new to eclipse. Could you please tell me what M8 is? Is
> there anyway that I could get a preview of the new code - happy to be the
> tester. I have found advantages to staying with the 64-bit environment for
> my applications, and I gather that 32-bit and 64-bit plugins don't mix
> well.
>
> Many thanks,
> Flavelle
>

--
Thanks,
Rich
Re: Unable to install DSL Toolkit [message #525192 is a reply to message #525190] Thu, 02 July 2009 06:39 Go to previous messageGo to next message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
See previous reply...


On 7/1/09 8:13 PM, in article
5399f1a4c1330b270649662a7bfc47b8$1@www.eclipse.org, "Flavelle Ballem"
<fballem@ballemco.com> wrote:

> Rich:
>
> A small further thought - is there a different approach using existing
> Galileo components that will allow me to proceed further with your book?
>
> Thanks,
> Flavelle
>

--
Thanks,
Rich
Re: Unable to install DSL Toolkit [message #525193 is a reply to message #525191] Thu, 02 July 2009 07:26 Go to previous message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
Rich:

Thanks so much - I'll give these a try!

Flavelle
Re: Unable to install DSL Toolkit [message #577362 is a reply to message #525187] Wed, 01 July 2009 16:58 Go to previous message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
If you're following the book, you should use the Ganymede edition:
http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/I20081128
-0606/index.php

Unfortunately, there is no 64 bit version for Linux. I have built one for
M8 based on Galileo, but it's not promoted yet.

Best,
Rich


On 7/1/09 4:54 PM, in article
dd872609a93892e1ab06a84c944419bc$1@www.eclipse.org, "Flavelle Ballem"
<fballem@ballemco.com> wrote:

> I am running Galileo and trying to follow some examples in the book,
> "eclipse Modeling Project: A Domain-Specific Language (DSL) Toolkit".
>
> As part of that, I'm trying to install the DSL Toolkit from the Amalgam
> project, but I get the following error:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: DSL Toolkit 1.0.0.v200905210858
> (org.eclipse.amalgam.dsltk.product 1.0.0.v200905210858)
> Missing requirement for filter
> (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=x86_64)): Eclipse RCP
> 3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC (org.eclipse.rcp.feature.group
> 3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC) requires
> 'org.eclipse.swt.gtk.linux.x86_64 [3.5.0.v3548c]' but it could not be found
> Cannot satisfy dependency:
> From: DSL Toolkit 1.0.0.v200905210858
> (org.eclipse.amalgam.dsltk.product 1.0.0.v200905210858)
> To: org.eclipse.platform.feature.group
> [3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD
> (org.eclipse.platform.feature.group
> 3.5.0.v20090513-9fEdG1HFtGcZlCVLSVqmsTcdv4RgTlPeD)
> To: org.eclipse.rcp.feature.group
> [3.5.0.v20090506-9SA-FwxFtqHA7O_ZPyAv-cGC]
>
> Please be aware that I am running on ubuntu 9.04 AMD64 and have eclipse
> for Linux 64-bit installed. I'm also a newbie to eclipse, so if that's
> part of the problem, then some detail on how to correct the problem would
> be much appreciated.
>
> Many thanks, both for the solution, and your patience!
>
>

--
Thanks,
Rich
Re: Unable to install DSL Toolkit [message #577380 is a reply to message #525188] Wed, 01 July 2009 19:25 Go to previous message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
Richard Gronback wrote:

> If you're following the book, you should use the Ganymede edition:
> http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/I20081128
> -0606/index.php

> Unfortunately, there is no 64 bit version for Linux. I have built one for
> M8 based on Galileo, but it's not promoted yet.

> Best,
> Rich

Rich:

I'm sorry, I am new to eclipse. Could you please tell me what M8 is? Is
there anyway that I could get a preview of the new code - happy to be the
tester. I have found advantages to staying with the 64-bit environment for
my applications, and I gather that 32-bit and 64-bit plugins don't mix
well.

Many thanks,
Flavelle
Re: Unable to install DSL Toolkit [message #577400 is a reply to message #525189] Wed, 01 July 2009 20:13 Go to previous message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
Rich:

A small further thought - is there a different approach using existing
Galileo components that will allow me to proceed further with your book?

Thanks,
Flavelle
Re: Unable to install DSL Toolkit [message #577418 is a reply to message #525189] Thu, 02 July 2009 06:39 Go to previous message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
M8 = Milestone 8

You can try the linux x86_64 download of the Modeling package from EPP:
http://www.eclipse.org/epp/download.php It contains most of what's in the
Amalgam DSL Toolkit, less some UI elements.

There are some differences in the Galileo version of the modeling
components, as compared to the Ganymede version the book is based on.
Mostly, things should work, but the solutions are not yet updated. The main
thing to do is replace references to the "legacy" Xpand model-to-text engine
with the new one in GMF that uses OCL and QVTO.

Best,
Rich


On 7/1/09 7:25 PM, in article
c52a18f8944b602a7a8b198ffbd46ea4$1@www.eclipse.org, "Flavelle Ballem"
<fballem@ballemco.com> wrote:

> Richard Gronback wrote:
>
>> If you're following the book, you should use the Ganymede edition:
>> http://download.eclipse.org/modeling/amalgam/dsltk/downloads /drops/I20081128
>> -0606/index.php
>
>> Unfortunately, there is no 64 bit version for Linux. I have built one for
>> M8 based on Galileo, but it's not promoted yet.
>
>> Best,
>> Rich
>
> Rich:
>
> I'm sorry, I am new to eclipse. Could you please tell me what M8 is? Is
> there anyway that I could get a preview of the new code - happy to be the
> tester. I have found advantages to staying with the 64-bit environment for
> my applications, and I gather that 32-bit and 64-bit plugins don't mix
> well.
>
> Many thanks,
> Flavelle
>

--
Thanks,
Rich
Re: Unable to install DSL Toolkit [message #577438 is a reply to message #525190] Thu, 02 July 2009 06:39 Go to previous message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
See previous reply...


On 7/1/09 8:13 PM, in article
5399f1a4c1330b270649662a7bfc47b8$1@www.eclipse.org, "Flavelle Ballem"
<fballem@ballemco.com> wrote:

> Rich:
>
> A small further thought - is there a different approach using existing
> Galileo components that will allow me to proceed further with your book?
>
> Thanks,
> Flavelle
>

--
Thanks,
Rich
Re: Unable to install DSL Toolkit [message #577457 is a reply to message #525191] Thu, 02 July 2009 07:26 Go to previous message
Flavelle Ballem is currently offline Flavelle Ballem
Messages: 39
Registered: July 2009
Member
Rich:

Thanks so much - I'll give these a try!

Flavelle
Previous Topic:Unable to install DSL Toolkit
Next Topic:DSL Book - problems with java code pg 81
Goto Forum:
  


Current Time: Sat Apr 19 02:52:39 EDT 2014

Powered by FUDForum. Page generated in 0.02996 seconds