Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Amalgam » DSL Toolkit M1 - Extension/New
DSL Toolkit M1 - Extension/New [message #525102] Wed, 04 February 2009 18:19 Go to next message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 64
Registered: July 2009
Location: Toronto
Member

I am working with DSL Toolkit M1 and I noticed that after you add a new
Extension and you want to add some child elements using mouse right click
/New... , the only option is Generic, no matter what extension I am using.
Working with Classic Eclipse, I can see more options. Is this a bug or
something is missing on dsltk M1 archive distribution?

Thanks
Re: DSL Toolkit M1 - Extension/New [message #525103 is a reply to message #525102] Wed, 04 February 2009 18:49 Go to previous messageGo to next message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
It's a bug. The reason is that I didn't include the org.eclipse.sdk plug-in
in the Amalgam builds as they define their own product extensions. The
trouble is, other things are defined within this SDK branding plug-in, e.g.
Java and Plug-in Development capabilities.

Can you please open a bug?

Thanks,
Rich


On 2/4/09 1:19 PM, in article
3ae04283e4ea3b24086146bc2b8bf507$1@www.eclipse.org, "Ioan"
<ioan.salau@insighteck.com> wrote:

> I am working with DSL Toolkit M1 and I noticed that after you add a new
> Extension and you want to add some child elements using mouse right click
> /New... , the only option is Generic, no matter what extension I am using.
> Working with Classic Eclipse, I can see more options. Is this a bug or
> something is missing on dsltk M1 archive distribution?
>
> Thanks
>
Re: DSL Toolkit M1 - Extension/New [message #525104 is a reply to message #525103] Wed, 04 February 2009 19:20 Go to previous messageGo to next message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 64
Registered: July 2009
Location: Toronto
Member

Recorded as bug 263684.
Re: DSL Toolkit M1 - Extension/New [message #525105 is a reply to message #525104] Sat, 07 February 2009 12:34 Go to previous message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
Thanks!

Just for the benefit of others, the reason for this was that the platform
sources are not included in the DSL Toolkit. If you install them from the
platform update site, the editor will behave as in the Eclipse SDK.

- Rich


On 2/4/09 2:20 PM, in article
570f22a59b2b56c8a0cd32ba95788020$1@www.eclipse.org, "Ioan"
<ioan.salau@insighteck.com> wrote:

> Recorded as bug 263684.
>
Re: DSL Toolkit M1 - Extension/New [message #561280 is a reply to message #525102] Wed, 04 February 2009 18:49 Go to previous message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
It's a bug. The reason is that I didn't include the org.eclipse.sdk plug-in
in the Amalgam builds as they define their own product extensions. The
trouble is, other things are defined within this SDK branding plug-in, e.g.
Java and Plug-in Development capabilities.

Can you please open a bug?

Thanks,
Rich


On 2/4/09 1:19 PM, in article
3ae04283e4ea3b24086146bc2b8bf507$1@www.eclipse.org, "Ioan"
<ioan.salau@insighteck.com> wrote:

> I am working with DSL Toolkit M1 and I noticed that after you add a new
> Extension and you want to add some child elements using mouse right click
> /New... , the only option is Generic, no matter what extension I am using.
> Working with Classic Eclipse, I can see more options. Is this a bug or
> something is missing on dsltk M1 archive distribution?
>
> Thanks
>
Re: DSL Toolkit M1 - Extension/New [message #561295 is a reply to message #525103] Wed, 04 February 2009 19:20 Go to previous message
Ioan Salau is currently offline Ioan SalauFriend
Messages: 64
Registered: July 2009
Location: Toronto
Member

Recorded as bug 263684.
Re: DSL Toolkit M1 - Extension/New [message #561310 is a reply to message #525104] Sat, 07 February 2009 12:34 Go to previous message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
Thanks!

Just for the benefit of others, the reason for this was that the platform
sources are not included in the DSL Toolkit. If you install them from the
platform update site, the editor will behave as in the Eclipse SDK.

- Rich


On 2/4/09 2:20 PM, in article
570f22a59b2b56c8a0cd32ba95788020$1@www.eclipse.org, "Ioan"
<ioan.salau@insighteck.com> wrote:

> Recorded as bug 263684.
>
Previous Topic:DSL Toolkit M1 - Extension/New
Next Topic:Amalgam update site
Goto Forum:
  


Current Time: Fri Dec 19 17:40:41 GMT 2014

Powered by FUDForum. Page generated in 0.02116 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software