Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Eclipse Foundation » Ant Task implementing BuildListener does not work from eclipse???
Ant Task implementing BuildListener does not work from eclipse??? [message #52971] Mon, 31 March 2008 15:16 Go to next message
Eclipse User
Originally posted by: patrick.laplante.cmcelectronics.ca

Hi,

I have a plugin that contains ANT tasks. One of these task implement
org.apache.tools.ant.BuildListener

All the tasks are working fine except the one implementing BuildListener.
I receive:
BUILD FAILED
Test.xml:18: The following error occurred while executing this line:
java.lang.LinkageError: org/apache/tools/ant/BuildEvent

when launching the target inside eclipse. Some interesting observation:
This task works when the target is launched from outside eclipse.

Hope someone can help

thanks
Re: Ant Task implementing BuildListener does not work from eclipse??? [message #52994 is a reply to message #52971] Mon, 31 March 2008 20:25 Go to previous message
Eclipse User
Originally posted by: merks.ca.ibm.com

Patrick,

Please ask using the eclipse.platform newsgroup. This newsgroup is for
asking questions about the operations of the Eclipse foundation.


Patrick laplante wrote:
> Hi,
>
> I have a plugin that contains ANT tasks. One of these task implement
> org.apache.tools.ant.BuildListener
>
> All the tasks are working fine except the one implementing
> BuildListener. I receive:
> BUILD FAILED
> Test.xml:18: The following error occurred while executing this line:
> java.lang.LinkageError: org/apache/tools/ant/BuildEvent
>
> when launching the target inside eclipse. Some interesting
> observation: This task works when the target is launched from outside
> eclipse.
>
> Hope someone can help
>
> thanks
>
Previous Topic:Cannot Install Any Plugins, Weird Dependency Error
Next Topic:ddf
Goto Forum:
  


Current Time: Wed Apr 16 06:58:50 EDT 2014

Powered by FUDForum. Page generated in 0.02168 seconds