Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » XWT. May be not accurate handling of element properties
XWT. May be not accurate handling of element properties [message #524566] Thu, 01 April 2010 08:43 Go to next message
Konstantin Scheglov is currently offline Konstantin Scheglov
Messages: 554
Registered: July 2009
Senior Member
This code is incorrect, because "items" property value was set inside of "layoutData", but it still was rendered!
Is this feature or bug?

<Shell xmlns="http://www.eclipse.org/xwt/presentation" xmlns:x="http://www.eclipse.org/xwt" xmlns:j="clr-namespace:java.lang">
	<Shell.layout>
		<RowLayout/>
	</Shell.layout>
	<List x:style="BORDER">
		<List.layoutData>
			<RowData width="302" height="233"/>
			<List.items>
				<j:String>000</j:String>
				<j:String>111</j:String>
				<j:String>222</j:String>
			</List.items>
		</List.layoutData>
	</List>
</Shell>


Konstantin Scheglov,
Google, Inc.
Re: XWT. May be not accurate handling of element properties [message #524755 is a reply to message #524566] Fri, 02 April 2010 06:24 Go to previous messageGo to next message
Yves YANG is currently offline Yves YANG
Messages: 687
Registered: July 2009
Senior Member
It is a bug. Please report in bugzilla.

Best regards
Yves YANG
"Konstantin Scheglov" <Konstantin.Scheglov@gmail.com> wrote in message
news:hp24e1$glq$1@build.eclipse.org...
> This code is incorrect, because "items" property value was set inside of
> "layoutData", but it still was rendered!
> Is this feature or bug?
>
> <Shell xmlns="http://www.eclipse.org/xwt/presentation"
> xmlns:x="http://www.eclipse.org/xwt" xmlns:j="clr-namespace:java.lang">
> <Shell.layout>
> <RowLayout/>
> </Shell.layout>
> <List x:style="BORDER">
> <List.layoutData>
> <RowData width="302" height="233"/>
> <List.items>
> <j:String>000</j:String>
> <j:String>111</j:String>
> <j:String>222</j:String>
> </List.items>
> </List.layoutData>
> </List>
> </Shell>
> --
> Konstantin Scheglov,
> Instantiations, Inc.
Re: XWT. May be not accurate handling of element properties [message #524757 is a reply to message #524755] Fri, 02 April 2010 06:37 Go to previous messageGo to next message
Konstantin Scheglov is currently offline Konstantin Scheglov
Messages: 554
Registered: July 2009
Senior Member
Yves YANG wrote on Fri, 02 April 2010 14:24
It is a bug. Please report in bugzilla.



Done.
Bug 307980


Konstantin Scheglov,
Google, Inc.
Re: XWT. May be not accurate handling of element properties [message #572625 is a reply to message #524755] Fri, 02 April 2010 06:37 Go to previous message
Konstantin Scheglov is currently offline Konstantin Scheglov
Messages: 554
Registered: July 2009
Senior Member
Yves YANG wrote on Fri, 02 April 2010 14:24
> It is a bug. Please report in bugzilla.


Done.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=307980

--
Konstantin Scheglov,
Instantiations, Inc.


Konstantin Scheglov,
Google, Inc.
Previous Topic:XWT. May be not accurate handling of element properties
Next Topic:DI Question
Goto Forum:
  


Current Time: Sat Aug 30 10:42:40 EDT 2014

Powered by FUDForum. Page generated in 0.01636 seconds