Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Real-Time Software Components (RTSC) » Warning: xdc.cfg.INCOMPATIBLE_TARGET_VERSION
Warning: xdc.cfg.INCOMPATIBLE_TARGET_VERSION [message #524354] Wed, 31 March 2010 06:48 Go to next message
Patrick Geremia is currently offline Patrick Geremia
Messages: 79
Registered: July 2009
Member
I tried to build on a linux 64-bit machine (32-bit build) and I get the
following warning:

Warning: xdc.cfg.INCOMPATIBLE_TARGET_VERSION: current target
gnu.targets.Linux86' [1,0,3.4,6] is not compatible with targets used to
build the following packages; package gnu.targets.rts86U [in
/db/wisap/tools/ti/rtsc/xdctools_3_16_02_32/packages/gnu/tar gets/rts86U/]
was built using 'gnu.targets.Linux86' [1,0,4.1,0]

I used XDCtools version 3_16_02_32

From this I understand that I use version gcc 3.4.6 but the RTS
shippped with this version of XDC was build using gcc 4.1.0

Is my understanding correct?

I am surprised version 4.1.0 was used because the release notes mention
that the supported host includes RedHat Enterprise Linux 3 and I am
pretty sure that this RHEL release does not have gcc 4.1.0
Any comments?

--
Patrick Geremia
Texas Instruments (http://www.ti.com)
Phone: +33 4 93 22 26 33
Email: p-geremia@ti.com
Availability: http://meetwith.me/patrickgeremia
Re: Warning: xdc.cfg.INCOMPATIBLE_TARGET_VERSION [message #524652 is a reply to message #524354] Thu, 01 April 2010 08:04 Go to previous message
Dave Russo is currently offline Dave Russo
Messages: 172
Registered: July 2009
Senior Member
On 3/31/2010 8:32 AM, Patrick Geremia wrote:
>
> I tried to build on a linux 64-bit machine (32-bit build) and I get the
> following warning:
>
> Warning: xdc.cfg.INCOMPATIBLE_TARGET_VERSION: current target
> gnu.targets.Linux86' [1,0,3.4,6] is not compatible with targets used to
> build the following packages; package gnu.targets.rts86U [in
> /db/wisap/tools/ti/rtsc/xdctools_3_16_02_32/packages/gnu/tar gets/rts86U/] was
> built using 'gnu.targets.Linux86' [1,0,4.1,0]
>
> I used XDCtools version 3_16_02_32
>
> From this I understand that I use version gcc 3.4.6 but the RTS
> shippped with this version of XDC was build using gcc 4.1.0
>
> Is my understanding correct?
Yes.
>
> I am surprised version 4.1.0 was used because the release notes mention
> that the supported host includes RedHat Enterprise Linux 3 and I am
> pretty sure that this RHEL release does not have gcc 4.1.0
> Any comments?
We use 4.x compilers because they have much better support for whole
program optimization and 4.x has been available fo quite some time.

It is possible to rebuild the RTS library using your compiler. See
http://rtsc.eclipse.org/docs-tip/Working_with_xdc.runtime#Re -building_xdc.runtime_Support_Packages

>
Previous Topic:Memory.staticPlace() problem
Next Topic:mapping obj files contents to sections
Goto Forum:
  


Current Time: Tue Sep 02 05:15:32 EDT 2014

Powered by FUDForum. Page generated in 0.02649 seconds