Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Most egit functionality grayed out...(All functionality that modifies local/cloned repository is gray out...)
icon5.gif  Most egit functionality grayed out... [message #523279] Thu, 25 March 2010 14:25 Go to next message
buzzkill is currently offline buzzkill
Messages: 10
Registered: March 2010
Junior Member
Obviously, I must be doing something wrong here...

All functionality that modifies a local/cloned repository is grayed out... Also, no label or icon decorators are being shown. I can do compares using Compare WIth->History... But, that's about it.

I'm trying to use a cloned remote repository that I've imported using EGit (using git+ssh). The import works fine. I can use all Git commands from the command line and git-gui on that repository, but not from egit.

Is there some kind of permission issue here? Or are there issues with EGit and CDT?

We just switched over from SVN to Git in our dev environment. It would be nice for our eclipse users to use EGit.

I'm using Eclipse 3.5 with CDT and Egit 0.7.1 using ubuntu 8.0.4.

David
Re: Most egit functionality grayed out... [message #523351 is a reply to message #523279] Fri, 26 March 2010 01:12 Go to previous messageGo to next message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Same to me, I just updated to 0.7.1 in Zend and most commands are greyed out.

And there is a crash when trying to add a folder to version control. Here I am pasting the stacktrace:

eclipse.buildId=unknown
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_NZ
Command-line arguments:  -os win32 -ws win32 -arch x86

Error
Fri Mar 26 17:09:26 NZST 2010
Add to Version Control failed

java.lang.reflect.InvocationTargetException
	at org.eclipse.egit.ui.internal.actions.Track$1.run(Track.java:45)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: org.eclipse.core.runtime.CoreException: Failed to add resource.
	at org.eclipse.egit.core.Activator.error(Activator.java:50)
	at org.eclipse.egit.core.op.TrackOperation.run(TrackOperation.java:130)
	at org.eclipse.egit.ui.internal.actions.Track$1.run(Track.java:43)
	... 1 more
Caused by: java.lang.NullPointerException
	at org.eclipse.egit.core.op.TrackOperation.run(TrackOperation.java:75)
	... 2 more


Hope you guys can apply a patch asap so that I can continue with my work. Thanks!

Michael
Re: Most egit functionality grayed out... [message #526061 is a reply to message #523279] Thu, 08 April 2010 11:30 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
"buzzkill" <destrozyk@yahoo.com> wrote in message
news:hog9rf$hra$1@build.eclipse.org...
>
> I'm trying to use a cloned remote repository that I've imported using EGit
> (using git+ssh). The import works fine. I can use all Git commands from
> the command line and git-gui on that repository, but not from egit.

Can you point us to such a repository which causes problems? I would suppose
that EGit may have problems with some special features of git.

> Is there some kind of permission issue here? Or are there issues with EGit
> and CDT?
Permission is not a problem, everything is local on your machine after
cloning. I do not know issues with CDT.

> We just switched over from SVN to Git in our dev environment. It would be
> nice for our eclipse users to use EGit.
Great!

Stefan
Re: Most egit functionality grayed out... [message #526072 is a reply to message #523351] Thu, 08 April 2010 11:33 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
"Michael Heuberger" <michael.heuberger@binarykitchen.com> wrote in message
news:hohfol$b1b$1@build.eclipse.org...
> at org.eclipse.egit.core.op.TrackOperation.run(TrackOperation.j ava:75)
> ... 2 more
This line of code (rm.getRepository().getIndex()) indicates that EGit does
not correctly configure the git repository.

Can you point us to such a repository which causes problems? One, we could
clone ourselves to reproduce the issue?
I would suppose that EGit may have problems with some special features of
git.

Stefan
Re: Most egit functionality grayed out... [message #526159 is a reply to message #526072] Thu, 08 April 2010 22:47 Go to previous messageGo to next message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Thank you but I'm afraid I can't reveal the source of the repository because it's a commercial project.

Just tell me what else you need to know and I'll collect the information for you.

Cheers

Michael
Re: Most egit functionality grayed out... [message #526302 is a reply to message #526159] Fri, 09 April 2010 10:42 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
> Thank you but I'm afraid I can't reveal the source of the repository
> because it's a commercial project.
I had already suspected that...

> Just tell me what else you need to know and I'll collect the information
> for you.
Lets try:
Does your repo use submodules?
Can you describe the folder structure of your repo: where are the .project
files and where are the .git folders?

Go to the project properties, select git: Is the Git directory path
displayed correctly?
If you unshare your project and share it again, is the correct repo found in
the dialog?

Thanks for you help,
Stefan
Re: Most egit functionality grayed out... [message #526381 is a reply to message #526302] Fri, 09 April 2010 20:29 Go to previous messageGo to next message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Re-Hi Stefan

Here my answers:

Does your repo use submodules?

I don't know what submodules are but I don't think my Project X has any submodules

Can you describe the folder structure of your repo: where are the .project files and where are the .git folders?

In this directory there are all the project files:
D:\Code\Zend Studio Workspace\Project X

And within lies the .git folder:
D:\Code\Zend Studio Workspace\Project X\.git

Go to the project properties, select git: Is the Git directory path
displayed correctly?

Yes, the working directory and git directory are correct.

If you unshare your project and share it again, is the correct repo found in the dialog?
No need, the correct repo is displayed.

By the way, for unknown reasons, the menu items aren't greyed out anymore. I think this happened after I have unshared and shared the project again ...

Cheers

Michael

PS: When is the merging functionality coming? I am waiting for it ... Smile
Re: Most egit functionality grayed out... [message #526849 is a reply to message #526381] Tue, 13 April 2010 05:40 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
Hi Michael,

so you had shared/imported your project with an older version of EGit and
after upgrade to 0.7.1 you got the problems?

Do you know which version you had before?

If you newly import the repo and the projects do you still have this
problems? Can you work now without errors?

Thanks and Regards,
Stefan
Re: Most egit functionality grayed out... [message #527087 is a reply to message #526849] Tue, 13 April 2010 20:57 Go to previous messageGo to next message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Hi Stefan

Right, previously I used EGit 0.6 and then after upgrading to 0.7.1 through the autoupdate in Zend Studio this problem happened.

I solved it myself by deleting and re-creating the repo. There are no errors anymore and I am able to work again.

When is the merging coming?

Cheers

Michael
Re: Most egit functionality grayed out... [message #527196 is a reply to message #527087] Wed, 14 April 2010 08:34 Go to previous messageGo to next message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
> Right, previously I used EGit 0.6 and then after upgrading to 0.7.1
> through the autoupdate in Zend Studio this problem happened.
We should then test this scenario.

> I solved it myself by deleting and re-creating the repo. There are no
> errors anymore and I am able to work again.
Great!

> When is the merging coming?
We plan for 0.8.0 which may be released in early June to match up with the
Eclipse Helios simultaneous release.
Re: Most egit functionality grayed out... [message #527338 is a reply to message #527196] Wed, 14 April 2010 17:21 Go to previous message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Great, thank you Smile

Happy coding!

Michael
Re: Most egit functionality grayed out... [message #578990 is a reply to message #523351] Thu, 08 April 2010 11:33 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
"Michael Heuberger" <michael.heuberger@binarykitchen.com> wrote in message
news:hohfol$b1b$1@build.eclipse.org...
> at org.eclipse.egit.core.op.TrackOperation.run(TrackOperation.j ava:75)
> ... 2 more
This line of code (rm.getRepository().getIndex()) indicates that EGit does
not correctly configure the git repository.

Can you point us to such a repository which causes problems? One, we could
clone ourselves to reproduce the issue?
I would suppose that EGit may have problems with some special features of
git.

Stefan
Re: Most egit functionality grayed out... [message #579004 is a reply to message #526072] Thu, 08 April 2010 22:47 Go to previous message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Thank you but I'm afraid I can't reveal the source of the repository because it's a commercial project.

Just tell me what else you need to know and I'll collect the information for you.

Cheers

Michael
Re: Most egit functionality grayed out... [message #579017 is a reply to message #579004] Fri, 09 April 2010 10:42 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
> Thank you but I'm afraid I can't reveal the source of the repository
> because it's a commercial project.
I had already suspected that...

> Just tell me what else you need to know and I'll collect the information
> for you.
Lets try:
Does your repo use submodules?
Can you describe the folder structure of your repo: where are the .project
files and where are the .git folders?

Go to the project properties, select git: Is the Git directory path
displayed correctly?
If you unshare your project and share it again, is the correct repo found in
the dialog?

Thanks for you help,
Stefan
Re: Most egit functionality grayed out... [message #579059 is a reply to message #526302] Fri, 09 April 2010 20:29 Go to previous message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Re-Hi Stefan

Here my answers:

Does your repo use submodules?

I don't know what submodules are but I don't think my Project X has any submodules

Can you describe the folder structure of your repo: where are the .project files and where are the .git folders?

In this directory there are all the project files:
D:\Code\Zend Studio Workspace\Project X

And within lies the .git folder:
D:\Code\Zend Studio Workspace\Project X\.git

Go to the project properties, select git: Is the Git directory path
displayed correctly?
Yes, the working directory and git directory are correct.

If you unshare your project and share it again, is the correct repo found in the dialog?
No need, the correct repo is displayed.

By the way, for unknown reasons, the menu items aren't greyed out anymore. I think this happened after I have unshared and shared the project again ...

Cheers

Michael

PS: When is the merging functionality coming? I am waiting for it ... :)
Re: Most egit functionality grayed out... [message #579317 is a reply to message #579059] Tue, 13 April 2010 05:40 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
Hi Michael,

so you had shared/imported your project with an older version of EGit and
after upgrade to 0.7.1 you got the problems?

Do you know which version you had before?

If you newly import the repo and the projects do you still have this
problems? Can you work now without errors?

Thanks and Regards,
Stefan
Re: Most egit functionality grayed out... [message #579477 is a reply to message #526849] Tue, 13 April 2010 20:57 Go to previous message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Hi Stefan

Right, previously I used EGit 0.6 and then after upgrading to 0.7.1 through the autoupdate in Zend Studio this problem happened.

I solved it myself by deleting and re-creating the repo. There are no errors anymore and I am able to work again.

When is the merging coming?

Cheers

Michael
Re: Most egit functionality grayed out... [message #579494 is a reply to message #579477] Wed, 14 April 2010 08:34 Go to previous message
Stefan Lay is currently offline Stefan Lay
Messages: 340
Registered: July 2009
Senior Member
> Right, previously I used EGit 0.6 and then after upgrading to 0.7.1
> through the autoupdate in Zend Studio this problem happened.
We should then test this scenario.

> I solved it myself by deleting and re-creating the repo. There are no
> errors anymore and I am able to work again.
Great!

> When is the merging coming?
We plan for 0.8.0 which may be released in early June to match up with the
Eclipse Helios simultaneous release.
Re: Most egit functionality grayed out... [message #579532 is a reply to message #527196] Wed, 14 April 2010 17:21 Go to previous message
Michael Heuberger is currently offline Michael Heuberger
Messages: 30
Registered: December 2009
Member
Great, thank you :)

Happy coding!

Michael
Previous Topic:EGit 'Share Project...' Failing On Remote Project
Next Topic:ERROR in org.eclipse.ui.examples.presentation.git
Goto Forum:
  


Current Time: Tue Jul 29 13:14:25 EDT 2014

Powered by FUDForum. Page generated in 0.02560 seconds