Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » IllegalArgumentException in Eclipse 3.6
IllegalArgumentException in Eclipse 3.6 [message #523014] Wed, 24 March 2010 14:48 Go to next message
Kai Schlamp is currently offline Kai Schlamp
Messages: 344
Registered: July 2009
Senior Member
Hello.

I switched from Eclipse Galileo to Eclipse 3.6M6 and installed SWTBot from http://download.eclipse.org/technology/swtbot/helios/dev-bui ld/update-site
When I run a SWTBot test now I get the below error. Any ideas why that happens?


Exception in thread "WorkbenchTestable" java.lang.IllegalArgumentException: No Classloader found for plug-in org.pubcurator.gui.test
at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getCl assLoader(RemotePluginTestRunner.java:79)
at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getTe stClassLoader(RemotePluginTestRunner.java:73)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC lass(RemoteTestRunner.java:693)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC lasses(RemoteTestRunner.java:429)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:452)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe sts(RemoteTestRunner.java:683)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R emoteTestRunner.java:390)
at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.main( RemotePluginTestRunner.java:64)
at org.eclipse.swtbot.eclipse.core.UITestApplication.runTests(U ITestApplication.java:117)
at org.eclipse.ui.internal.testing.WorkbenchTestable$1.run(Work benchTestable.java:71)
at java.lang.Thread.run(Thread.java:619)
[INFO] First start: Mar 24, 2010 7:45:43 PM

[Updated on: Wed, 24 March 2010 14:49]

Report message to a moderator

Re: IllegalArgumentException in Eclipse 3.6 [message #523024 is a reply to message #523014] Wed, 24 March 2010 10:24 Go to previous messageGo to next message
Pascal G is currently offline Pascal G
Messages: 157
Registered: July 2009
Senior Member
Kai Schlamp wrote:
> Hello.
>
> I switched from Eclipse Galileo to Eclipse 3.6M6 and installed SWTBot
> from
> http://download.eclipse.org/technology/swtbot/helios/dev-bui ld/update-site
> When I run a SWTBot test now I get the below error. Any ideas why that
> happens?
>
> !ENTRY org.eclipse.ui 4 4 2010-03-24 19:45:39.965
> !MESSAGE Referenced part does not exist yet:
> org.pubcurator.core.views.form.
> Exception in thread "WorkbenchTestable"
> java.lang.IllegalArgumentException: No Classloader found for plug-in
> org.pubcurator.gui.test
> at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getCl
> assLoader(RemotePluginTestRunner.java:79)
> at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.getTe
> stClassLoader(RemotePluginTestRunner.java:73)
> at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC
> lass(RemoteTestRunner.java:693)
> at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadC
> lasses(RemoteTestRunner.java:429)
> at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe
> sts(RemoteTestRunner.java:452)
> at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTe
> sts(RemoteTestRunner.java:683)
> at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(R
> emoteTestRunner.java:390)
> at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.main(
> RemotePluginTestRunner.java:64)
> at org.eclipse.swtbot.eclipse.core.UITestApplication.runTests(U
> ITestApplication.java:117)
> at org.eclipse.ui.internal.testing.WorkbenchTestable$1.run(Work
> benchTestable.java:71)
> at java.lang.Thread.run(Thread.java:619)
> [INFO] First start: Mar 24, 2010 7:45:43 PM

The plug-in org.pubcurator.gui.test doesn't exist in your Eclipse
runtime? This is only a guess... here is the snippet that fails:

Bundle bundle = Platform.getBundle(pluginId);
if (bundle == null)
throw new IllegalArgumentException("No Classloader found for
plug-in " + pluginId); //$NON-NLS-1$

Other then that, no clue...
--
Pascal GĂ©linas | Software Developer
*Nu Echo Inc.*
http://www.nuecho.com/ | http://blog.nuecho.com/

*Because performance matters.*
Re: IllegalArgumentException in Eclipse 3.6 [message #523039 is a reply to message #523024] Wed, 24 March 2010 16:27 Go to previous message
Kai Schlamp is currently offline Kai Schlamp
Messages: 344
Registered: July 2009
Senior Member
Uups, you are right. Everything is fine ... thanks a lot.
Previous Topic:SWTBot Tutorial on Project Wiki don't work
Next Topic:Please ignore ... wrong group
Goto Forum:
  


Current Time: Tue Jul 22 05:28:11 EDT 2014

Powered by FUDForum. Page generated in 0.02335 seconds