Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP and OSGi(Profile OSGi based applicaiton.)
TPTP and OSGi [message #522894] Wed, 24 March 2010 12:04 Go to next message
lsq  is currently offline lsq
Messages: 40
Registered: July 2009
Member
I got a OSGi configuration and it was running ok. I try to use tptp as the profiling tool.
When I tried to start by run the OSGi configuration from the profile drop-down,, it is running to the completion and stoped and the monitor seemed to have been detached automatically. I did change some of the default filters and make profilling to start automatically.
I am fine with running an simple java application and I am fine with an external application, all I try to do is to profile an osgi based application (eclipse rap) and i found that there is no clear support for configuration type like rap application and I am bit confused with where to start with, as a set of eclipse plugins(seems not working to me!), deploy them in an tomcat server everytime would be very cumbersome. Thanks for any clues.
Re: TPTP and OSGi [message #523072 is a reply to message #522894] Wed, 24 March 2010 23:44 Go to previous messageGo to next message
lsq  is currently offline lsq
Messages: 40
Registered: July 2009
Member
I am using Eclipse 3.5 SR1 + TPTP 4.6.2, I can't test eclipse applications as well. when I start by profiling an eclipse application, it stoped and the agent detached quietly. Should I try other combinations?
Re: TPTP and OSGi [message #523620 is a reply to message #523072] Sat, 27 March 2010 12:35 Go to previous message
lsq  is currently offline lsq
Messages: 40
Registered: July 2009
Member
It is not too bad as we can start an rap application normally as an "RAP Application" with vm argument such as " -agentlib:JPIBootLoader=JPIAgent:server=enabled;CGProf:execd etails=true " or "-XrunpiAgent:server=enabled", and then start to " Attach to Agent" to localhost. I still can not profile an "OSGi Framework" directly as it is supposed to be, anyone knows the way out ?
Previous Topic:Build path contains duplicate entry
Next Topic:RPT - Error connecting to citrix servers
Goto Forum:
  


Current Time: Wed Sep 17 07:33:15 GMT 2014

Powered by FUDForum. Page generated in 0.02311 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software