Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » ETL, problem with a data type
ETL, problem with a data type [message #522483] Mon, 22 March 2010 14:29 Go to next message
José Miguel P. is currently offline José Miguel P.
Messages: 62
Registered: March 2010
Member

Hello everybody:

First to all, than you for your attention.

I have a problem with new types.

In the Emfatic file, I create a new type, this one:

@ExtendedMetaData(name="ipType", baseType="http://www.eclipse.org/emf/2003/XMLType#string", 
pattern="((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(/[0-3]?[0-9])?)")
datatype IpType : java.lang.String;


I'm using it with Eugenia, and EVL whitout problems, but, when I try to
execute a ETL rule, it returned to me that:

Internal error: org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Value '150.214.1.0/24' is not legal. [platform:/resource/prueba/miRed.fws, 3, 62]
....
....
...


This is very rare, because /resource/prueba/miRed.fws has been created by the editor, and
in the editor when I put value to this attribute check the pattern ok.

I have try changing the attribute to a String, and the problem is
solved, but, I need use this type. What is happening?


Thank you very much for your help!!
Re: ETL, problem with a data type [message #522485 is a reply to message #522483] Mon, 22 March 2010 14:32 Go to previous messageGo to next message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Hi,

Could you please send me your metamodel, a sample input model and the
transformation at dskolovos _ gmail _ com so that I can have a look?

Cheers,
Dimitris

Jose Miguel wrote:
> Hello everybody:
>
> First to all, than you for your attention.
>
> I have a problem with new types.
>
> In the Emfatic file, I create a new type, this one:
>
> @ExtendedMetaData(name="ipType",
> baseType="http://www.eclipse.org/emf/2003/XMLType#string",
> pattern=" ((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9 ]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\ .(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(/[0-3]?[0-9])?) ")
>
> datatype IpType : java.lang.String;
>
> I'm using it with Eugenia, and EVL whitout problems, but, when I try to
> execute a ETL rule, it returned to me that:
>
> Internal error:
> org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Value
> '150.214.1.0/24' is not legal. [platform:/resource/prueba/miRed.fws, 3, 62]
> ...
> ...
> ..
>
> This is very rare, because /resource/prueba/miRed.fws has been created
> by the editor, and
> in the editor when I put value to this attribute check the pattern ok.
>
> I have try changing the attribute to a String, and the problem is
> solved, but, I need use this type. What is happening?
>
>
> Thank you very much for your help!!


--
Spread the word: http://www.eclipse.org/gmt/epsilon/spreadtheword
Follow Epsilon on Twitter: http://twitter.com/epsilonews
Re: ETL, problem with a data type [message #522817 is a reply to message #522485] Tue, 23 March 2010 21:15 Go to previous messageGo to next message
José Miguel P. is currently offline José Miguel P.
Messages: 62
Registered: March 2010
Member

Here is the bug url:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=306894

Thank you very much Dimitrios Wink
Re: ETL, problem with a data type [message #522828 is a reply to message #522817] Wed, 24 March 2010 01:35 Go to previous messageGo to next message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Thanks! A fix has been committed to the SVN and a new interim version
has been released. Could you please update and confirm that it all works
fine for you now?

Cheers,
Dimitris

Jose Miguel wrote:
> Here is the bug url:
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=306894
>
> Thank you very much Dimitrios ;)


--
Spread the word: http://www.eclipse.org/gmt/epsilon/spreadtheword
Follow Epsilon on Twitter: http://twitter.com/epsilonews
Re: ETL, problem with a data type [message #522992 is a reply to message #522828] Wed, 24 March 2010 13:04 Go to previous message
José Miguel P. is currently offline José Miguel P.
Messages: 62
Registered: March 2010
Member

It's working fantastic.

Thank you very much Dimitrios!! Wink
Re: ETL, problem with a data type [message #587631 is a reply to message #522485] Tue, 23 March 2010 21:15 Go to previous message
José Miguel P. is currently offline José Miguel P.
Messages: 62
Registered: March 2010
Member

Here is the bug url:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=306894

Thank you very much Dimitrios ;)
Re: ETL, problem with a data type [message #587637 is a reply to message #587631] Wed, 24 March 2010 01:35 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios Kolovos
Messages: 1776
Registered: July 2009
Senior Member
Thanks! A fix has been committed to the SVN and a new interim version
has been released. Could you please update and confirm that it all works
fine for you now?

Cheers,
Dimitris

Jose Miguel wrote:
> Here is the bug url:
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=306894
>
> Thank you very much Dimitrios ;)


--
Spread the word: http://www.eclipse.org/gmt/epsilon/spreadtheword
Follow Epsilon on Twitter: http://twitter.com/epsilonews
Re: ETL, problem with a data type [message #587646 is a reply to message #522828] Wed, 24 March 2010 13:04 Go to previous message
José Miguel P. is currently offline José Miguel P.
Messages: 62
Registered: March 2010
Member

It's working fantastic.

Thank you very much Dimitrios!! ;)
Previous Topic:[ETL] Accesing existing output model elements
Next Topic:Reuse of EOL operations in ETL
Goto Forum:
  


Current Time: Fri Aug 29 01:48:20 EDT 2014

Powered by FUDForum. Page generated in 0.02235 seconds