Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP not picking up modified Libraries(e.g. IvyDE. New JARs are not included on a publish, old JARs are not removed.)
WTP not picking up modified Libraries [message #521872] Fri, 19 March 2010 03:59 Go to next message
Andrew is currently offline AndrewFriend
Messages: 9
Registered: July 2009
Junior Member
I've got no idea what's going on here, but it's quite frustrating:

I use Ivy to manage dependencies for our Web Project, and IvyDE to manage them in Eclipse. Mostly, that works fine, but just recently, I've noticed that it's not publishing new/removing old JARs when I publish the project - IvyDE picks them up fine, but I can't make WTP let go of the old ones and pick up the new ones.

e.g. I have a JAR a-1.jar referenced by IvyDE. This gets published fine. If, however, I remove a-1.jar and add a-2.jar (e.g. publishing a new version), IvyDE sees that I now have a-2.jar on the classpath, but not a-1.jar.

WTP, however, does not. It still thinks I have a-1.jar on the classpath and completely ignores a-2.jar. The only way I've found around this is to close the project and reopen it. Unfortunately, this is not a fun solution. I do frequent builds of other projects, and having to do this each time would be infuriating, especially given that my computer is not all that fast (I'd be looking at 5+ minutes for each build!)

I'm fairly sure this is a regression, as I hadn't noticed the behaviour with the previous version of WTP (I downloaded Eclipse 3.5 not long after it came out, and upgrade from WTP 3.1.0 to 3.1.1 very recently).

For reference, I'm using:

Eclipse Web Developer Tools
Version: 3.1.1.v200908120400-7R77FStEVw2z07WtDz-OZrhL5C-3
Build id: 20100211202452

Eclipse Java EE IDE for Web Developers.
Version: 1.2.2.20100217-2310
Build id: 20100218-1602

Eclipse Platform
Version: 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB
Build id: M20100211-1343


With IvyDE 2.0.0 and Ivy 2.1.0, publishing to Jetty 6.1.22 on Ubuntu 9.04 32bit, and Sun Java 1.6.0_16.

Any help would be most appreciated.

EDIT: Best guess is that something is being cached somewhere, as even if I delete the file from the Ivy Cache, it still tries to publish that file (and fails, since it doesn't exist anymore!)

[Updated on: Fri, 19 March 2010 04:01]

Report message to a moderator

Re: WTP not picking up modified Libraries [message #522270 is a reply to message #521872] Mon, 22 March 2010 00:16 Go to previous message
Andrew is currently offline AndrewFriend
Messages: 9
Registered: July 2009
Junior Member
Nobody have any ideas? I've got no idea what to do...
Previous Topic:Where is the CMDateTypeHelper?
Next Topic:error when creating an EJB Project
Goto Forum:
  


Current Time: Sat Nov 22 11:57:34 GMT 2014

Powered by FUDForum. Page generated in 0.01949 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software