Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Polish users » Eclipse ME - Windows 7
Eclipse ME - Windows 7 [message #521751] Thu, 18 March 2010 12:35 Go to next message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
Zainstalowałem Windows 7 32bit i okazało się że Eclipse Me na nim coś nie działa. Postępowałem wg instrukcji http://eclipseme.org/docs/installation.html Natomiast nie mogę utworzyc nowego projektu Midletu ani też skompilować starych. Czy komuś działa Me na windows 7??
Re: Eclipse ME - Windows 7 [message #521776 is a reply to message #521751] Thu, 18 March 2010 13:31 Go to previous messageGo to next message
Mariusz P. is currently offline Mariusz P.
Messages: 85
Registered: February 2010
Member
A uruchamiasz program z uprawnieniami administratora? A swoją drogą EclipseMe przeobraziło się w Eclipse Mobile Tools for Java (MTJ) (masz nawet o tym informację na stronie głównej EclipseME). Dlatego obecnie polecałbym zainstalować zwykłe Eclipse + właśnie powyższe MTJ, Pulsar oraz oczywiście Java Platform Micro Edition Software Development Kit 3.0 for Windows. Otrzymujesz to samo, a nawet więcej (tak piszą na stronie głównej EclipseME). Zresztą mam taki zestaw u siebie (choć akurat na Viście) i polecam.

[Updated on: Thu, 18 March 2010 13:35]

Report message to a moderator

Re: Eclipse ME - Windows 7 [message #521823 is a reply to message #521751] Thu, 18 March 2010 15:41 Go to previous messageGo to next message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
Dzięki za podpowiedź. W sumie po długich bojach udało się Very Happy
Re: Eclipse ME - Windows 7 [message #521826 is a reply to message #521823] Thu, 18 March 2010 15:47 Go to previous messageGo to next message
Mariusz P. is currently offline Mariusz P.
Messages: 85
Registered: February 2010
Member
Udało Ci się z EclipseMe? Czy tak jak ja Ci doradziłem? Jak rozwiązałeś problem z EclipseMe pod Windows 7 to podziel się z innymi tutaj jak tego dokonałeś.
Re: Eclipse ME - Windows 7 [message #521915 is a reply to message #521751] Fri, 19 March 2010 05:40 Go to previous messageGo to next message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
Tak jak mi doradziłeś. Tzn nie jestem do końca przekonany czy to akurat o to chodziło, wydaje mi się że poprzednio po zainstalowanie JavaME trzeba było samemu ustawić Open Perspective. Tak też zrobiłem i działa. A tak to cały proces instalacji przebiega normalnie.
Re: Eclipse ME - Windows 7 [message #521952 is a reply to message #521915] Fri, 19 March 2010 08:35 Go to previous messageGo to next message
Mariusz P. is currently offline Mariusz P.
Messages: 85
Registered: February 2010
Member
No nie wiem. Piszesz teraz, że nie otwierała ci się odpowiednia perspektywa (Open Perspective znaczy tyle co otwórz perspektywę). Przypuszczam, ze chodzi ci o perspektywę Java ME. Podczas tworzenia nowego projektu Eclipse proponuje nam odpowiednią perspektywę i daje nam możliwość żeby ten stan zapamiętać. Poza tym każdą perspektywę możemy sobie sami wybrać ręcznie. Ty jednak wcześniej pisałeś o niemożności utworzenia nowego projektu Midletu i kompilacji starych. W każdym razie cieszę, że udało ci się dojść jakoś z tym wszystkim do ładu i składu Smile

[Updated on: Fri, 19 March 2010 08:38]

Report message to a moderator

Re: Eclipse ME - Windows 7 [message #521995 is a reply to message #521751] Fri, 19 March 2010 11:08 Go to previous messageGo to next message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
Hmm no jesem nowy w tym temacie, więc nie widziałem że trzeba to zmieniać. Na XP wydaje mi się że po zainstalowaniu EclipseME odrazu miałem możliwość wyboru Midletu. Tutaj tego nie miałem. Tak najważniejsze że się udało i że wszyscy cali i zdrowi Wink dzięki za pomoc.
Re: Eclipse ME - Windows 7 [message #522035 is a reply to message #521751] Fri, 19 March 2010 14:21 Go to previous messageGo to next message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
Mariusz, kurde jakbyłbyś jeszcze tak łaskawy...to wyjaśnij mi proszę jeszcze jedną kwestie. Ciągle jestem jeszczę rozstrzęsiony tą przesiadką na Win7, a chcąc iść za ciosem przesiadłem się na WTK 3.0 i tu kolejny raz trafiłem na ściane. Mianowicie nie moge na nim skompilować starych projektów, i praktycznie nie informuję mnie przy kompilacji że coś jest nie tak czy coś. NP. ten przykładowy "projekt" http://www.przeklej.pl/plik/desktop-rar-000ci46962mv katalog "stary" jest ustawiony na WTK 2.5.2 i wszystko Ok sie kompiluje i działa a katalog "nowy" zawiera ten projekt na WTK 3.0 i biorę RUN i się kompiluje i uruchamia niby wszystko OK. Tylko nie ten MIDLet tylko ten niebieskie ekran się ukazuje. Nie mam pojecią o co chodzi w starym WTK to mnie chociaż informował że mam źle ustawioną klase midletu czy coś. A ten nowy niby wszystko OK i ten niebieski menu włączy. I nie wiem ocb :/ Help please.
Re: Eclipse ME - Windows 7 [message #522071 is a reply to message #522035] Fri, 19 March 2010 15:36 Go to previous messageGo to next message
Mariusz P. is currently offline Mariusz P.
Messages: 85
Registered: February 2010
Member
No cóż. Nie uruchamiają się, bo nie wiadomo co ma się uruchamiać. Wypełnij zakładkę MIDlets w Application Descriptor. W polu nazwa wpisz nazwę midletu np.: Canva MIDlet Suite, a w polu class wskaż klasę uruchamiającą midlet - w twoim przypadku to: Glowna. I Save (zapisz).

[Updated on: Fri, 19 March 2010 16:27]

Report message to a moderator

Re: Eclipse ME - Windows 7 [message #522119 is a reply to message #521751] Sat, 20 March 2010 05:02 Go to previous message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
Działa! Kolejny raz dziękuje Ci za pomoc. Dzięki!
Previous Topic:Import plików w katalogu J2me
Next Topic:Eclipse + Pulsar i Problemy z instalacją SDK S60
Goto Forum:
  


Current Time: Wed Jul 23 20:30:23 EDT 2014

Powered by FUDForum. Page generated in 0.02299 seconds