Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » remote debugging with xdebug
remote debugging with xdebug [message #521567] Thu, 18 March 2010 03:53 Go to next message
geddy  is currently offline geddy Friend
Messages: 2
Registered: March 2010
Junior Member
I used pdt all in one(eclipse-php-galileo-SR2-win32.zip) to debug my php scripts on remote apache server, when I start debug, everything looks ok except remote php scripts cant be opened,the msg:
Could not open the editor: Text editor does not have a document provider
Details:
org.eclipse.core.runtime.CoreException: Text editor does not have a document provider
at org.eclipse.ui.texteditor.AbstractTextEditor.doSetInput(Abst ractTextEditor.java:4132)
at org.eclipse.ui.texteditor.StatusTextEditor.doSetInput(Status TextEditor.java:203)
at org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.doSetI nput(AbstractDecoratedTextEditor.java:1413)
at org.eclipse.ui.editors.text.TextEditor.doSetInput(TextEditor .java:166)
at org.eclipse.ui.texteditor.AbstractTextEditor$19.run(Abstract TextEditor.java:3116)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread( ModalContext.java:464)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:372)
at org.eclipse.jface.window.ApplicationWindow$1.run(Application Window.java:759)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWi ndow.java:756)
at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow. java:2579)
at org.eclipse.ui.texteditor.AbstractTextEditor.internalInit(Ab stractTextEditor.java:3134)
at org.eclipse.ui.texteditor.AbstractTextEditor.init(AbstractTe xtEditor.java:3161)
at org.eclipse.ui.internal.EditorManager.createSite(EditorManag er.java:798)
at org.eclipse.ui.internal.EditorReference.createPartHelper(Edi torReference.java:644)
at org.eclipse.ui.internal.EditorReference.createPart(EditorRef erence.java:462)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(Workb enchPartReference.java:595)
at org.eclipse.ui.internal.EditorReference.getEditor(EditorRefe rence.java:286)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched( WorkbenchPage.java:2857)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(Workben chPage.java:2762)
at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPag e.java:2754)
at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.j ava:2705)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2701)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPa ge.java:2685)
at org.eclipse.debug.internal.ui.sourcelookup.SourceLookupFacil ity$1.run(SourceLookupFacility.java:352)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at org.eclipse.debug.internal.ui.sourcelookup.SourceLookupFacil ity.openEditor(SourceLookupFacility.java:362)
at org.eclipse.debug.internal.ui.sourcelookup.SourceLookupFacil ity.openEditor(SourceLookupFacility.java:276)
at org.eclipse.debug.internal.ui.sourcelookup.SourceLookupFacil ity.display(SourceLookupFacility.java:219)
at org.eclipse.debug.ui.DebugUITools.displaySource(DebugUITools .java:792)
at org.eclipse.debug.internal.ui.elements.adapters.StackFrameSo urceDisplayAdapter$SourceDisplayJob.runInUIThread(StackFrame SourceDisplayAdapter.java:155)
at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:95)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3885)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3506)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2405)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 21)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:493)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

the title of eclipse:
source not found for /remote/path/to/phpfile : line 9, please add the file to projects .....


please help me
Re: remote debugging with xdebug [message #521568 is a reply to message #521567] Thu, 18 March 2010 03:57 Go to previous messageGo to next message
geddy  is currently offline geddy Friend
Messages: 2
Registered: March 2010
Junior Member
the screenshot as follows:
http://www.tagworld.com/Photo/a/022F6FFFF01D9DB88000700E4B216
Re: remote debugging with xdebug [message #525408 is a reply to message #521568] Tue, 06 April 2010 14:06 Go to previous messageGo to next message
Peter Kemble is currently offline Peter KembleFriend
Messages: 4
Registered: April 2010
Location: Boston
Junior Member
Was this ever resolved? I just started getting this same error. I feel like I spend more time debugging eclipse than my actual work. thinking it's time to go back to notepad++...
Re: remote debugging with xdebug [message #525442 is a reply to message #525408] Tue, 06 April 2010 14:46 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dkel50.hotremovemail.com

How are you accessing remote files from within PDT ? Are you using RSE
for example ?
Did it used to work and it has now stopped working ? Check your path
mappings for the server, maybe they contain invalid information

Dave Kelsey


On 06/04/10 15:06, Peter Kemble wrote:
> Was this ever resolved? I just started getting this same error. I feel
> like I spend more time debugging eclipse than my actual work. thinking
> it's time to go back to notepad++...
Re: remote debugging with xdebug [message #525721 is a reply to message #525442] Wed, 07 April 2010 15:02 Go to previous messageGo to next message
Peter Kemble is currently offline Peter KembleFriend
Messages: 4
Registered: April 2010
Location: Boston
Junior Member
I ended up cleaning everything out, and setting up a new workspace locally, and pointing to the project files on the server. This seemed to fix it.

I'm accessing the files through samba, as i'm using eclipse on windows, but the webserver is centOS.

Thanks for replying!
Re: remote debugging with xdebug [message #525737 is a reply to message #525721] Wed, 07 April 2010 15:40 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dkel50.hotremovemail.com

glad you got it sorted, I believe there are issues with using RSE for
remote file access which was why I was asking, also they are other
plugins which also may not work.

Dave Kelsey

On 07/04/10 16:02, Peter Kemble wrote:
> I ended up cleaning everything out, and setting up a new workspace
> locally, and pointing to the project files on the server. This seemed to
> fix it.
> I'm accessing the files through samba, as i'm using eclipse on windows,
> but the webserver is centOS.
>
> Thanks for replying!
Re: remote debugging with xdebug [message #530016 is a reply to message #521567] Wed, 28 April 2010 07:55 Go to previous messageGo to next message
Russell Cruie is currently offline Russell CruieFriend
Messages: 1
Registered: April 2010
Junior Member
Hmm nice work done man

Russell
Re: remote debugging with xdebug [message #546988 is a reply to message #521567] Wed, 14 July 2010 20:47 Go to previous messageGo to next message
kulmacet  is currently offline kulmacet Friend
Messages: 4
Registered: July 2010
Junior Member
I am still having this issue and am not using RSE.

Could not open the editor: Text editor does not have a document provider

My configure is similar using Windows accessing a Linux server using Samba.

Any support greatly appreciated.

Thanks.
Re: remote debugging with xdebug [message #546998 is a reply to message #546988] Wed, 14 July 2010 21:46 Go to previous message
Eclipse UserFriend
Originally posted by: dkel50.hotremovemail.com

I cannot find your original posts, so
which version of PDT are you using ?
do you have any other plugins installed ?
If you are not using RSE then do you have a workspace with a copy of the
remote files held locally ?
Do you have any breakpoints set ?
Can you open the file if you use the eclipse "file-->open file" menu option.
What error is in the error log ?

Dave


On 14/07/2010 21:47, kulmacet wrote:
> I am still having this issue and am not using RSE.
> Could not open the editor: Text editor does not have a document provider
>
> My configure is similar using Windows accessing a Linux server using Samba.
>
> Any support greatly appreciated.
>
> Thanks.
Previous Topic:Extending PDT
Next Topic:ebedded emftext editor
Goto Forum:
  


Current Time: Thu Dec 18 21:59:40 GMT 2014

Powered by FUDForum. Page generated in 0.01955 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software