Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » JDK 6 webstart and eclipse 3.4.2(RCP application doesn't update with jdk 6)
JDK 6 webstart and eclipse 3.4.2 [message #521262] Tue, 16 March 2010 23:31
Jesus   Luna Quiroga is currently offline Jesus Luna Quiroga
Messages: 64
Registered: July 2009
Location: Mexico
Member

I have an application based on eclipse 3.4.2 which is deployed via webstart, the jnlp file indicates that it can be run in jdk 5 and higher.

<resources os="Windows">
<j2se version="1.5+" java-vm-args="-Xmx768m -Xms256m"/>
</resources>

When the client has jdk 1.5 the application runs and verifies for updates, but when the client has jdk 1.6 the application runs but if there is a plugin that should be updated, it is not updated and the application runs with the plugins that are in the client's cache.

The jdk 6 enhancements for web start ( http://java.sun.com/javase/6/docs/technotes/guides/javaws/en hancements6.html) indicate that the <update> should be added in the jnlp for updatig purposes, I added it (<update check="always" policy="always"/>) to my application but it didn't helped.

Any ideas?

Previous Topic:Positioning the jobs progress indicator on the status line
Next Topic:Limiting dimensions of view folders / views
Goto Forum:
  


Current Time: Wed Oct 22 05:06:21 GMT 2014

Powered by FUDForum. Page generated in 0.03630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software