Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » Scout video preview
Scout video preview [message #521131] Tue, 16 March 2010 14:43 Go to next message
Claudio Guglielmo is currently offline Claudio GuglielmoFriend
Messages: 128
Registered: March 2010
Senior Member
Hi all

To shorten the waiting time until EclipseCon we'll post some videos in the next days to give you a little insight into scout sdk.

The first one shows how easy it is to create a new scout project and a form.

http://www.youtube.com/watch?v=1iCKib1gTkk

Have fun Smile

Regards
Claudio
Re: Scout video preview [message #521220 is a reply to message #521131] Tue, 16 March 2010 18:35 Go to previous messageGo to next message
Andreas Hoegger is currently offline Andreas HoeggerFriend
Messages: 174
Registered: February 2010
Senior Member
Well done Claudio thanks a lot...


Claudio Guglielmo wrote:
> Hi all
>
> To shorten the waiting time until EclipseCon we'll post some videos in
> the next days to give you a little insight into scout sdk.
>
> The first one shows how easy it is to create a new scout project and a
> form.
>
> http://www.youtube.com/watch?v=1iCKib1gTkk
>
> Have fun :)
>
> Regards
> Claudio
Re: Scout video preview [message #521384 is a reply to message #521131] Wed, 17 March 2010 13:30 Go to previous messageGo to next message
Claudio Guglielmo is currently offline Claudio GuglielmoFriend
Messages: 128
Registered: March 2010
Senior Member
Hi all

The second video preview is now available!

http://www.youtube.com/watch?v=aUKVmZIRdV4

It's about creating fields.

Enjoy Wink
Claudio
Re: Scout video preview [message #521395 is a reply to message #521384] Wed, 17 March 2010 13:43 Go to previous messageGo to next message
Frank Gerhardt is currently offline Frank GerhardtFriend
Messages: 81
Registered: July 2009
Member
Have you published the code anywhere for trying it out?
Re: Scout video preview [message #521400 is a reply to message #521395] Wed, 17 March 2010 13:53 Go to previous messageGo to next message
Stephan Leicht Vogt is currently offline Stephan Leicht VogtFriend
Messages: 102
Registered: February 2010
Location: Baden Switzerland
Senior Member

Yes we did.
Please check our wiki and this thread where we put also little howto.
Re: Scout video preview [message #521508 is a reply to message #521384] Wed, 17 March 2010 20:27 Go to previous messageGo to next message
Michael Wyder is currently offline Michael WyderFriend
Messages: 4
Registered: March 2010
Junior Member
Real nice work guys. I played little bit around with the demo app and...it works!

If some of you is missing the password for the login you'll find it in the config.ini of the server project.

Michael
Re: Scout video preview [message #521513 is a reply to message #521384] Wed, 17 March 2010 20:59 Go to previous messageGo to next message
Michael Wyder is currently offline Michael WyderFriend
Messages: 4
Registered: March 2010
Junior Member
What's about the build process? How to achieve a deployable artefact?
Re: Scout video preview [message #521577 is a reply to message #521513] Thu, 18 March 2010 07:25 Go to previous messageGo to next message
Stephan Leicht Vogt is currently offline Stephan Leicht VogtFriend
Messages: 102
Registered: February 2010
Location: Baden Switzerland
Senior Member

Hey Micheal, I appreciate it that you liked the demo.
If you'd like a zip with a runnable to start it on a separate machine, you could export the server product. In the server-product file on the right-hand-side click on the link "Eclipse Product export wizard" and follow the instructions.
Re: Scout video preview [message #521650 is a reply to message #521131] Thu, 18 March 2010 12:20 Go to previous messageGo to next message
Claudio Guglielmo is currently offline Claudio GuglielmoFriend
Messages: 128
Registered: March 2010
Senior Member
Hi all

Interested in how to load data from server to client and display them in a form? Then you should have a look at the third video preview!

http://www.youtube.com/watch?v=AnZYptB7uIk

Regards
Claudio



Re: Scout video preview [message #521863 is a reply to message #521508] Fri, 19 March 2010 00:03 Go to previous messageGo to next message
Frank Gerhardt is currently offline Frank GerhardtFriend
Messages: 81
Registered: July 2009
Member
Michael Wyder schrieb:
> Real nice work guys. I played little bit around with the demo app
> and...it works!

It doesn't work for me.

It went really nicely until I tried to launch it. Then, on the train, 20
minutes before arrival, I was on the last page. Arhhg, I need an imap
server!? Why is the example not self contained!? That imap caused me
more troubles.

When the client starts it wants a login. Ok, nice. But which? For my
imap account? Why is then this admin\=manager defined in config.ini?
What does this strange syntax mean anyway? Can I log in with admin? Or
manager? Or use one or the other as password? Nothing worked. Maybe my
imap setting is wrong. There is no example for the syntax. Do I need to
set a real imap URL, I mean something like imap://.. or just the host
name? That damned code didn't tell me! No clue what goes wrong! Lost.

Besides this I get a message when the login dialog pops up
!MESSAGE Referenced part does not exist yet:
com.example.mail.ui.swt.core.views.TablePageView.
So what's this? Do I have to panic or is this only "informative"?
That's the *only* message I get. Nothing about the failed login.

Sorry for being so negative. As I wrote, it went really nicely up to the
very last page. The tooling looks good and sets high expectations. But
then the HowTo just does not deliver in the end.

Frank.
Re: Scout video preview [message #521895 is a reply to message #521863] Fri, 19 March 2010 08:15 Go to previous messageGo to next message
Stephan Leicht Vogt is currently offline Stephan Leicht VogtFriend
Messages: 102
Registered: February 2010
Location: Baden Switzerland
Senior Member

Hi Frank

I sincerely apologize that the demo app didn't work for you. I'd like to help you, but I'm on my way to San Francisco / eclipseCon.
If you also are going to the eclipseCon I would be able to help you there and then. Else I will try to find a solution later when I'm in SF.

Greetings and apologies
Stephan
Re: Scout video preview [message #521900 is a reply to message #521863] Fri, 19 March 2010 08:33 Go to previous messageGo to next message
Claudio Guglielmo is currently offline Claudio GuglielmoFriend
Messages: 128
Registered: March 2010
Senior Member
Hi Frank

I assume you talk about the mail client/server application in this thread http://www.eclipse.org/forums/index.php?t=msg&th=164582& amp;start=0& and not about the howto videos.

In the last section of the tutorial it is written that you have to replace the existing security filter configuration with a new imap security filter configuration. This means you have to login with your imap user and password. The user and password in the config.ini of the server are only used if you use the BasicSecurityFilter.

Hope that helps a little.

Btw: Could you please post mail-howto related things in the other thread? It would be easier for other people who have the same problems to find the answers.

Regards
Claudio
Re: Scout video preview [message #579365 is a reply to message #521863] Fri, 19 March 2010 08:15 Go to previous messageGo to next message
Stephan Leicht Vogt is currently offline Stephan Leicht VogtFriend
Messages: 102
Registered: February 2010
Location: Baden Switzerland
Senior Member

Hi Frank

I sincerely apologize that the demo app didn't work for you. I'd like to help you, but I'm on my way to San Francisco / eclipseCon.
If you also are going to the eclipseCon I would be able to help you there and then. Else I will try to find a solution later when I'm in SF.

Greetings and apologies
Stephan
Re: Scout video preview [message #579387 is a reply to message #521863] Fri, 19 March 2010 08:33 Go to previous message
Claudio Guglielmo is currently offline Claudio GuglielmoFriend
Messages: 128
Registered: March 2010
Senior Member
Hi Frank

I assume you talk about the mail client/server application in this thread http://www.eclipse.org/forums/index.php?t=msg&th=164582& amp;start=0& and not about the howto videos.

In the last section of the tutorial it is written that you have to replace the existing security filter configuration with a new imap security filter configuration. This means you have to login with your imap user and password. The user and password in the config.ini of the server are only used if you use the BasicSecurityFilter.

Hope that helps a little.

Btw: Could you please post mail-howto related things in the other thread? It would be easier for other people who have the same problems to find the answers.

Regards
Claudio
Previous Topic:Scout video preview
Next Topic:Scout meets press
Goto Forum:
  


Current Time: Fri Nov 21 02:41:38 GMT 2014

Powered by FUDForum. Page generated in 0.02428 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software